Bug in versions 4.1.x?? Strange error with Delphi 7 app

Discussions related to using VirtualBox on Windows hosts.

Re: Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby Speaker » 11. Oct 2011, 03:57

Ok... I try this:
The app that i post do not use "CarpetaDeEjecucion", it just take in account ".\" as a constant to replace that variable.
Originally is, CarpetaDeEjecucion := GetCurrentDir;
But i just try to put "t:\project\VB41x_BUG_Test\", and "\\VBoxsvr\VB41x_BUG_Test\", as constant and the error still appear.
I insist... this code (the peace of the app that i post), runs in every enviroment (including the same VM), but not when it is run under VB4.1.x
This code is tested over thirteen years... it works (Win95 through Win7 64bits). Including WinE in a development test.
So, i can try every code that you want (and i will, this in computing, and never ever is something said), i really will... but you have to understand that this post is not against VB... i like VirtualBox, i use it for a long time, it is a great application, but... there is a bug in it. I will help with all test you need to find the problem, but the problem is not in my code.
From version 4.1.x till now, something has changed (now i can tell better where) in unc/lan/net name resolution that get to an error (do not blame windows (bah, you can, but it is as it is!)).
Dispite of this... keep it helping... it is great to have someone answering me about this issue...
Speaker
 
Posts: 12
Joined: 3. Oct 2011, 23:49
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP

Re: Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby scp » 12. Oct 2011, 01:26

Yes, GetCurrentDir is also OK. I also think we have tested enough code to find the point were the error is.
We can test to run it on a normal Windows share, but the error seems to be in shared folders.
scp
 
Posts: 106
Joined: 14. Feb 2010, 22:12
Primary OS: Ubuntu 12.04
VBox Version: OSE self-compiled
Guest OSses: Windows XP, 2003, 7, 8.1

Re: Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby Speaker » 12. Oct 2011, 03:49

Try it...
Reinstall vbox (4.1.4)
Runs the app with t:\... \\vboxsvr... and \\pchost\users\my_user\temporal\vb_test
The error still.

Reinstall vbox (4.0.12)
Try to execute the app from the same folders.
The error do not appear.

Can you reproduce the error?
Speaker
 
Posts: 12
Joined: 3. Oct 2011, 23:49
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP

Re: Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby scp » 13. Oct 2011, 02:42

I tried to start it from "\\VBoxsvr\TestVBSE\VirtualBoxStreamErrorTest (exe)", connected "\\VBoxsvr\TestVBSE" as T: and started from "T:\VirtualBoxStreamErrorTest (exe)".
I also tried to run it from a real windows share "\\myhost\D$\Delphi5\TestVBSE\VirtualBoxStreamErrorTest (exe)".

In all cases I never get the error and all graphics are loaded.
scp
 
Posts: 106
Joined: 14. Feb 2010, 22:12
Primary OS: Ubuntu 12.04
VBox Version: OSE self-compiled
Guest OSses: Windows XP, 2003, 7, 8.1

Re: Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby Speaker » 13. Oct 2011, 03:38

Perhaps something in net configuration?
I attach a png with that configuration, previously i attach ova configuration file.
What else can we try? i try with other installation (run the app from net with other vm, gets the same error with vb4.1.4, but not with vb4.0.12). As other installation, i mean, xp sp3 spanish without delphi...
This error is reached in notebook too, where hw is totally different.
I really do not know.
Perhaps i can post vdi file...
Attachments
netconfig.png
Net configuration in VB
netconfig.png (13.95 KiB) Viewed 838 times
Speaker
 
Posts: 12
Joined: 3. Oct 2011, 23:49
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP

Re: Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby Speaker » 10. Nov 2011, 21:31

Well... i found it... it is not an issue of my app, and probably is not a bug in VB (i am glad!!!)...

Seems to be the worst virus known by humanity... the one that reside between the chair and the keyboard... the user!!! :D, in this case... just me.

I am waiting for some update to test all again. Version 4.1.6 appears, so, i install it, i install extension pack... try the application, error still.
See the icon in tray of guest addition, read something about bugs resolved in this version about full screen... zoom in the window, try again, error still.
In devices menu i see "Install Guest Addition"... so, a lamp came to my mind... never do this!!! i install (re-install) guest addition, and the version 4.1.6 of guest addition is installed!!! i never, never update Guest Additdion... reboot, try again... the error do not still... its gone.

So... tell me this...
1) is a bug in VB (that is corrected in this version) ? so i can still with a little dignity...
2) or as never happened with other update (that is in my favor), i have to reinstall Guest Addition from here to ever, as i update VB?

Sorry and thanks!
Speaker
 
Posts: 12
Joined: 3. Oct 2011, 23:49
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP

Re: Bug in versions 4.1.x?? Strange error with Delphi 7 app

Postby scp » 13. Nov 2011, 22:01

Yes, everytime you update VB, you must install/update to the new guest additions.
Working with older guest additions with same major/minror version i.e. 4.1.2 on 4.1.6 may work some time, but there is no guarantee.
scp
 
Posts: 106
Joined: 14. Feb 2010, 22:12
Primary OS: Ubuntu 12.04
VBox Version: OSE self-compiled
Guest OSses: Windows XP, 2003, 7, 8.1

Previous

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 29 guests