Not in Text Mode! Error (guest Windows PE 3.0)

Discussions related to using VirtualBox on Windows hosts.

Not in Text Mode! Error (guest Windows PE 3.0)

Postby georgelinux » 28. Aug 2011, 23:04

I'm new to forum posting here, as I usually don't get any errors which already have workarounds on forums.

I made a Windows PE image, and I wanted to test it in VirtualBox before I wasted a CD.

It stops at the "Starting Windows..." splash, and then going in to meditation mode with this in the log file:

Code: Select all   Expand viewCollapse view
00:04:13.601 Not in text mode!
00:04:13.601 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
00:04:14.603 Changing the VM state from 'RUNNING' to 'GURU_MEDITATION'.


I've installed Windows in VirtualBox before, but without any problems at all.

Thanks!
georgelinux
 
Posts: 7
Joined: 28. Aug 2011, 22:51
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows PE, Linux 2.6, Ubuntu, Debian, Arch Linux

Re: Not in Text Mode! Error (guest Windows PE 3.0)

Postby Perryg » 29. Aug 2011, 01:55

This error usually happens when someone tries to install using EFI. If this is not the case then I would suggest that you look really hard at the image and make sure that it is a fully bootable install image.
Perryg
Site Moderator
 
Posts: 34373
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX

Re: Not in Text Mode! Error (guest Windows PE 3.0)

Postby georgelinux » 29. Aug 2011, 08:49

Perryg,

I haven't got EFI on but I'll try making a new clean PE image.
georgelinux
 
Posts: 7
Joined: 28. Aug 2011, 22:51
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows PE, Linux 2.6, Ubuntu, Debian, Arch Linux

Re: Not in Text Mode! Error (guest Windows PE 3.0)

Postby georgelinux » 29. Aug 2011, 09:17

No luck with a clean PE image,

Trying with VMWare Player now.

Thanks for your suggestion.

UPDATE: Works in VMWare Player. It seems to be a VirtualBox problem. At least I know that it works, but I would like to use VirtualBox instead of VMWare...
georgelinux
 
Posts: 7
Joined: 28. Aug 2011, 22:51
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows PE, Linux 2.6, Ubuntu, Debian, Arch Linux

Re: Not in Text Mode! Error (guest Windows PE 3.0)

Postby mpack » 29. Aug 2011, 13:33

Is IO APIC enabled in the VM settings? VMware has this enabled by default, which is why this might be working on the latter. Black screen on startup is often IO APIC related, in my experience. Symptoms are: on XP the screen is completely black, on W2K the screen said "Loading Windows". I've never tried installing W7, but hitting trouble at "Starting Windows..." sounds similar to the W2K case.

Technically, the problem is a mismatch between the HAL in the working image, and the hardware specified in the VM. I would guess that W7 HALs might assume the presence of IO APIC, though like I said I've not actually tried a W7 VM yet. VBox ought to default to IO APIC enabled too, if you choose the right Windows version... which you might not have (or you might have turned IO APIC off).
mpack
Site Moderator
 
Posts: 32034
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Not in Text Mode! Error (guest Windows PE 3.0)

Postby msheppard » 26. Oct 2011, 20:06

I got this error trying to start a VM that worked perfectly when I shut it down a few weeks prior. I had a couple more VM's running when I got the error. It turned out to be system memory.

I lowered Settings->System->Base Memory from 6032MB to 4096MB and it started fine

M@
msheppard
 
Posts: 3
Joined: 9. Mar 2011, 16:23
Primary OS: MS Windows 2008
VBox Version: OSE other
Guest OSses: Windows, all


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: megamanyoutuber and 57 guests