Unable to leave sleep mode in win 7 host

Discussions related to using VirtualBox on Windows hosts.

Unable to leave sleep mode in win 7 host

Postby thomaswiatr » 27. Aug 2011, 14:02

Hello,

I'm using virtualbox for a year without any problem, but i installed the latest release yesterday and experienced some difficulties with the windows 7 sleep mode since : When a virtual machine is running, and if windows enters in sleep mode, it's unpossible to wake up the computer (a restart is needed).

When no VM is running, there is no problem with sleep mode... I never experienced such events with previous virtualbox releases.

EDIT : i tried to re-install previous releases of virtalbox :
- same problem with 4.1.0
- no problem with 4.0.12



Does anybody encounter the same problem ?

Thank you by advance,

Host : win 7 pro 64 bits
Guest : Ubuntu 10.10 64 bits
Virtualbox : 4.1.2 + extension
thomaswiatr
 
Posts: 2
Joined: 27. Aug 2011, 13:50
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu 10.08 64 bits

Re: Unable to leave sleep mode in win 7 host

Postby tlundqvist » 29. Aug 2011, 20:50

I have the same problem (but unable to enter sleep mode)!

Windows 7 (64 bit) sometimes never enters the sleep/suspend mode. It hangs while trying to sleep. Only solution is the power button to turn it completely off.

This is very annoying since I usually have it sleep automatically after 30 min, which means an automatic freeze after 30 min.

Note: not consistent - sometimes sleep works. Same behavior on Win XP 32 bit. So it seems to be general problem for windows.

Current version: 4.1.2
Same problem in: 4.1.0
No problem in 4.0...
tlundqvist
 
Posts: 4
Joined: 29. Aug 2011, 20:38
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Debian linux

Re: Unable to leave sleep mode in win 7 host

Postby blair » 24. Sep 2011, 02:09

Same problem here. Had no problems going into sleep mode with guests running in 4.0.x, now about 80% of the time I get a hang just before entering S3, so have to forcefully poweroff/reset. Very annoying. Going to downgrade till I see more about this issue.
blair
 
Posts: 4
Joined: 24. Sep 2011, 02:01
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, CentOS

Re: Unable to leave sleep mode in win 7 host

Postby blair » 29. Sep 2011, 03:31

After reverting to 4.0.12 the problem went away for a couple of wake-sleep cycles but then reappeared. Just to reiterate, this is definitely VB related, the hang before properly sleeping only occurs with a VM active. But I think I've pinpointed the source now...
I couldn't think of anything of relevance that had changed on my machine that might be causing this, then I remembered I had used USB pass-through recently for my inbuilt Ricoh SD reader so I could ext4 format my phones card. After inserting an SD card this appears as a new USB device in the VB list, for which I created a new device filter. It seems that after removing the SD card the device disappeared, and despite it not being actively attached to the VM anymore just having it in the filter list was causing some kind of issue. This is just speculation backed up by the problem disappearing, but I'd be happy to do some proper debugging with the appropriate pointers. Guess I'll go back to 4.1.x now and check that.
blair
 
Posts: 4
Joined: 24. Sep 2011, 02:01
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, CentOS

Re: Unable to leave sleep mode in win 7 host

Postby blair » 3. Oct 2011, 02:23

No problem now in 4.1.2 without any USB device filters set.
blair
 
Posts: 4
Joined: 24. Sep 2011, 02:01
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, CentOS

Re: Unable to leave sleep mode in win 7 host

Postby tlundqvist » 4. Oct 2011, 15:59

blair wrote:No problem now in 4.1.2 without any USB device filters set.


This is interesting. I'm also using USB filters. But, I don't really want to remove them. Just installed 4.1.4 today - maybe it's been fixed?
tlundqvist
 
Posts: 4
Joined: 29. Aug 2011, 20:38
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Debian linux

Re: Unable to leave sleep mode in win 7 host

Postby ep80 » 7. Oct 2011, 12:28

The same problem in 4.1.4 using with usb filters.
When VM in use, computer can't hibernate. Downgrading to 4.0.12 solved this problem.
I us VB because there are no drivers for Win7 x64 for my printer Canon LBP1120, so this usb device is always connected to a VM.
ep80
 
Posts: 2
Joined: 7. Oct 2011, 12:21
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: WinXP, Win8

Re: Unable to leave sleep mode in win 7 host

Postby thomaswiatr » 27. Oct 2011, 18:11

Hello,

I was waiting for VB 4.1.4 to know if this issue was fixed :

The problem is still present ,it's definitly unpossible to leave sleep mode without a computer restart.

I didn't test if it happens without USB extension, because i need it to run my old printer with ubuntu.

Does anyone in the vb staff be aware of this problem, and maybe have a solution ?

Thanks by advance
thomaswiatr
 
Posts: 2
Joined: 27. Aug 2011, 13:50
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu 10.08 64 bits

Re: Unable to leave sleep mode in win 7 host

Postby neanderthal » 1. Nov 2011, 12:29

A slightly different behaviour here:
my host hangs when entering suspend only when there are USB devices captured by VB.

When I press the suspend button, the screen becomes black as it initiates suspend procedure, but never terminates it, probably due to VBox USB drivers being active.
So the PC stays frozen forever on and it is impossible to have it working again, unless I force power off.

Otherwise, no troubles if I remember to disconnect USB devices from the Devices menu. As a quick fix, suspend request on host system should at least force VB to release all USB devices.

Using VirtualBox 4.1.4 under Windows 7 64 bit, Guest on Windows 7 32 bit.
neanderthal
 
Posts: 18
Joined: 22. Apr 2011, 09:03
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Win7, WinXP, Linux

Re: Unable to leave sleep mode in win 7 host

Postby ep80 » 19. Nov 2011, 18:46

4.1.6 No chadges. Hibernate with plugged usb device not working.
4.1.6 ?? ?? ????? ? ??????????? ??? ???????????? usb ??????????.
ep80
 
Posts: 2
Joined: 7. Oct 2011, 12:21
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: WinXP, Win8


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 30 guests