error while trying to copy files from a shared folder

Discussions related to using VirtualBox on Windows hosts.

error while trying to copy files from a shared folder

Postby quasiquasar » 28. Jul 2011, 19:54

Host: Windows XP, Vbox 4.1.0; Guest Ubuntu 10.04 guest additions

I have an automatically mounted shared folder. If I try to use Nautilus to copy any file from the shared folder to the folder in the Guest system, the following error occurs:
Code: Select all   Expand viewCollapse view
Error while copying "filename"
Error splicing file: Protocol error


If I try to copy files using the command line, everything works. Any clue what might be the problem?

-- virtual hard drive is dynamic size (ext4).
quasiquasar
 
Posts: 2
Joined: 28. Jul 2011, 19:22
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Linux

Re: error while trying to copy files from a shared folder

Postby purbeckview » 28. Jul 2011, 21:18

Same problem here, although I can copy from Ubuntu to shared folder OK. As you say, CLI works fine in both directions. Using Ubuntu 11.04, VB 4.1.0 on a MacBook running OS X 10.7 (Lion). I will put a post on the Mac OS Hosts forum shortly.
purbeckview
 
Posts: 2
Joined: 28. Jul 2011, 21:11
Location: UK / France
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Ubuntu 11.04

Re: error while trying to copy files from a shared folder

Postby Sasquatch » 28. Jul 2011, 23:12

Sounds like Nautilius / Gnome is causing problems again. Gedit doesn't like SF either. To be able to use the GUI method, try a different file manager like Xfce4's Thunar or LXDE's pcmanfm.

purbeckview wrote:I will put a post on the Mac OS Hosts forum shortly.

If it's about the same thing, don't put it in a Host section. You clearly said it's on your Guest. The Host doesn't matter. And cross-posting isn't allowed either, although it wouldn't entirely be that.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: error while trying to copy files from a shared folder

Postby quasiquasar » 29. Jul 2011, 01:42

I've tried it with Windows 7 host and everything works like a charm.
quasiquasar
 
Posts: 2
Joined: 28. Jul 2011, 19:22
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Linux

Re: error while trying to copy files from a shared folder

Postby Sasquatch » 13. Aug 2011, 12:17

Then check the privileges on the shared folder on the Host. There has to be a difference somewhere on either side that causes this.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: error while trying to copy files from a shared folder

Postby Kingy » 14. Aug 2011, 22:59

Oddly, this is happening to me too on a Windows 7 64-bit host with Linux Mint 11 32-bit and Ubuntu 11.04 32-bit guests. However, I also have Linux Mint 11 64-bit and Ubuntu 11.04 64-bit guests and they work fine. Each VM is set up the same with the same latest guest additions version installed and the same shared folder. Auto Mount is off too.
Kingy
 
Posts: 13
Joined: 5. Sep 2010, 18:40
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows, Ubuntu, etc.

Re: error while trying to copy files from a shared folder

Postby rogusdev » 6. Oct 2011, 22:34

This just started happening for me too when I updated to 4.1.4. Previously, using 4.1.2 and 4.0.12 (pretty sure that was the version), I had no problems accessing this exact same setup of shared folder in the same virtual machine (guest: ubuntu 10.04 32bit), everything the same (host: windows 7 64bit), now just upgraded vbox and ga and this broke. If it helps debugging: sometimes the file is created with zero size, sometimes it's not created at all, but it always throws the "protocol error" error right after attempting to copy.
rogusdev
 
Posts: 4
Joined: 6. Oct 2011, 21:31
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 10.04, Win XP SP3

Re: error while trying to copy files from a shared folder

Postby Perryg » 6. Oct 2011, 23:20

I don't use the auto-mount for just this reason. Delete the share, make sure that the share is not working when you reboot the guest.
Then create a manual share using the options switch (make permanent in the share screen just no auto-mount)
Code: Select all   Expand viewCollapse view
mount -t vboxsf -o rw,uid=<your uid>,gid=<your gid> <share> <mount point>

Put this in /etc/rc.local after you are sure it works and you more than likely will eliminate your issues.

Note 1: I have no problem with shared folders, not even gedit. YMMV but I do this with a lot of guests and over 6 different hosts.
Note 2: manual mount on Windows guests also do not show this issue for me.
Perryg
Site Moderator
 
Posts: 25959
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: error while trying to copy files from a shared folder

Postby mike2712 » 7. Oct 2011, 14:10

Exactly the same problem here, and have not progressed since my post on this.

Win 7 host, kubuntu 11.04 (natty) guest.

Could copy files to and from the sf with VirtualBox 4.0.12, by drag and drop in Dolphin file manager. Following upgrade to 4.1.4, can copy files into sf but not out: protocol error.

I have tried different filemanagers, including thunar and pcmanfm, deleting/recreating the sf, to no avail.

If it helps:
(a) the copy function was fine following upgrade UNTIL I installed the 4.1.4 guest additions (i.e. I initially upgraded to 4.1.4 but left the old 4.0.12 ga installed.)
(b) I can confirm that the cp command in a terminal window works fine
(c) There is no problem in a VM with Debian Lenny guest

It therefore seems that there is a change in the 4.1.4 guest additions that is incompatible with kubuntu 11.04 but does not affect Debian.

Any comments will be welcome!
mike2712
 
Posts: 10
Joined: 4. Mar 2010, 16:15
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu

Re: error while trying to copy files from a shared folder

Postby Perryg » 7. Oct 2011, 16:36

@mike2712,
Are you using the auto-mount feature?
What folder are you trying to share on Windows?
Perryg
Site Moderator
 
Posts: 25959
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: error while trying to copy files from a shared folder

Postby mike2712 » 7. Oct 2011, 20:22

No, I am not using the auto-mount feature (although I have tried it).

I am not sure what you mean by your second question. The Win folder is C:\vbox_shared and has full control and access permissions for all users. I stress that this has never changed since version 2 of VirtualBox and has been OK with every successive release upto 4.1.0. It is mounted on the kubuntu mountpoint /vbox_shared that has full rw permissions for all users, and again has not changed. I have tried with different mountpoints, but the problem persists.
mike2712
 
Posts: 10
Joined: 4. Mar 2010, 16:15
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Ubuntu

Re: error while trying to copy files from a shared folder

Postby Perryg » 7. Oct 2011, 20:47

I don't have kubuntu, but my ubuntu does not show this issue.
That said:
These kinds of problems that are reproducible should be reported to bugtracker. You will need to setup an account there as it is on a different system.
It would also help if you can post the ticket number here so other can see the progress, add information, or see the final results.
Be sure to give the DEVs as much info as you can.
Perryg
Site Moderator
 
Posts: 25959
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: error while trying to copy files from a shared folder

Postby rogusdev » 8. Oct 2011, 02:10

I have created the bug ticket: https://www.virtualbox.org/ticket/9719

For the record, I myself use mount in my rc.local, not auto-mount.
rogusdev
 
Posts: 4
Joined: 6. Oct 2011, 21:31
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 10.04, Win XP SP3

Re: error while trying to copy files from a shared folder

Postby loukingjr » 30. Oct 2011, 15:38

just to throw my 2 cents in I am having the same problem with only the Phinx version of PCLinuxOS and none of the other PCLOS's. I also don't seem to have the problem with other distros.

edit: I deleted the shared folder, got a message the shared folder was broken, rebooted the guest, added the same shared folder, rebooted the guest again and it works fine now. I think the issue might be when the shared folder was created.
there are three kinds of people in the world, those that can count, and those that can't.
iMac 3.4 GHz Intel Core i7 32GB NVIDIA GeForce GTX 680MX 2048 MB... Mac OSX 10.8.4 & 10.9.2
loukingjr
Volunteer
 
Posts: 1483
Joined: 30. Apr 2009, 09:45
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: just about all that run

Re: error while trying to copy files from a shared folder

Postby swisschris » 30. Nov 2011, 02:20

I just want to confirm and update: the problem still exists, in the exact way as it has been described in the bugtracker. I have installed the latest version (4.1.6) together with the most recent guest additions. I am running virtualbox on a Mac OSx (snow leopard) and as guest I am running Ubuntu 10.10.

I have tried everything in matters of different techniques to mount the share folder, however, the problem persisted. I can copy files in the gnome-terminal, but all the other software is stopped as soon as a file is to be copied between the shared folder and the guest system (even trash is not working for files in the shared folder).

Best,
Chris
swisschris
 
Posts: 1
Joined: 30. Nov 2011, 01:58
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Ubuntu

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: noteirak and 44 guests