USB not working

Discussions related to using VirtualBox on Windows hosts.

Re: USB not working

Postby tonx » 21. Apr 2014, 20:17

hi Nayas,

Can you help with me please?
I have the same problem on windows 7 (64 bit prof) host, virtualbox using linux.

I've done advices mentioned above (delete registry key, install usb driver manually, reboot the virtualbox)
but not working still.

I've installed virtualbox gues addition + extensionpack, but they dont' fix the problem.

Any suggestions?
Posts: 12
Joined: 10. Mar 2014, 04:41

Re: USB not working

Postby tonx » 22. Apr 2014, 13:39

hi Nayis,

Is there a solution to this USB issues?

My problem is that:
USB drive / memory stick will not work (i need to reboot the host to get it back to working).
However, my usb keyboard & mouse are working properly.

I've installed virtualbox guest addition & extension pack thinking that this is the problem but it doesnt help at all.
Posts: 12
Joined: 10. Mar 2014, 04:41

Re: USB not working

Postby Konuvis » 13. Jul 2014, 06:19

Sorry for the old bump but I tried this and still having issues.
I have windows 8.1 hosting win98se and I'm trying to capture a joystick but it just won't. The joystick appears in the devices when I right click but when I go to attach it I keep getting a 'busy' error message.


Result Code:
E_INVALIDARG (0x80070057)
IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Any ideas?
Posts: 6
Joined: 11. Jul 2014, 03:17

Re: USB not working

Postby jjtjp » 18. Sep 2014, 03:39

nayasis wrote:I've got solution finally... T-T

(It seems like problem of window 7)

1. My Host is window 7 32bit home premium. But, 64bit's solution may be same because problem was caused by USB filtering function of WINDOW 7.

2. first of all, edit your registry

- Open the Windows registry, by clicking on Start > Run and typing regedit
- Navigate to the following location HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
- In the right hand panel, if the the UpperFilters entry exists, then delete it

3. Install virtualbox USB driver manually.

- Goto folder C:\Program Files\Oracle\VirtualBox\drivers\USB\filter
- Click right mouse button on file named VboxUSBMon.inf
- Check Install(I) (maybe.. My window is korean so it dose not exact. )

4. Rebooting

5. Unplug your USB memory (or joystick..)

6. Open VirtualBox and Close it rightly.
( it will remove your USB device from VM's seized list. )

7. Plug your USB memory.

8. Open VirtualBox and Run Virtual Machine.

9. Click right mouse button on USB icon placed in status bar which is below VM window.

10. Check USB device what you want to plug in.

11. Enjoy !!

** notice !!

Do not chain your USB device like snake. for example... A usb bridge <- B usb device... and check B usb device in VM. like this...

to use B usb device, you must check A usb bridge first !... it's so complicate..

Created an account to say thanks for this. I tried for 3 hours to troubleshoot my USB not working and this solved it. Reboot required, so maybe it should say "reboot" instead of "rebooting" which I took to mean that it would just happen after install. This solution should not have been this hard to find since I see stuff all over the web about people trying and trying until finally giving up. So I'm resurrecting the thread again to bring just a little bit more exposure to it in the search engines. Honestly, this should just be documented for anyone trying to use windows 7 host.

Just for info on my setup:
Host: Windows 7 home 64bit
Guest: Arch Linux 64bit
VirtualBox: 4.3.12
Symptoms: All usb devices said they were busy when trying to install to guest (arch). (or something to that effect.)

Thanks again!
Posts: 1
Joined: 18. Sep 2014, 03:33

Re: USB not working

Postby maxjr » 12. Feb 2015, 03:27

I don't know why but the reason there were NO USB DEVICES showing in mine was because somehow 2 usb hubs were disabled in the device manager.
Posts: 1
Joined: 12. Feb 2015, 03:25

Re: USB not working

Postby patc » 16. Feb 2015, 03:50

Just had to post here to say that nayasis' solution worked for me after hours of headache. THANKS!
Posts: 1
Joined: 16. Feb 2015, 03:49

Re: USB not working

Postby T Kamizi » 5. Mar 2015, 06:35

Hi everyone, I have had the same problem and I tried with two different USB 3.0 devices. The thing is, I think that was the problem, because when I changed to USB 2.0 device it worked immediately (without any filters, although you need to have the USB 2.0 support enabled before booting your VM).

So if nothing else works for your USB 3.0, try a USB 2.0 device instead! :)

PS. All my USB ports in my laptop are USB 3.0...
T Kamizi
Posts: 3
Joined: 5. Mar 2015, 06:32

Re: USB not working

Postby lamobot » 17. Jul 2015, 01:58

nayasis, you are the miracle-worker! Thank you so much!
Posts: 2
Joined: 17. Jul 2015, 01:52

Re: USB not working

Postby timur » 28. Jan 2016, 10:09

Thank you. It worked in VB 5.0.14. I post to add that you can install INF from the command line:
C:\> rundll32 syssetup,SetupInfObjectInstallAction DefaultInstall 128 C:\Program Files\Oracle\VirtualBox\drivers\USB\filter\VBoxUSBMon.inf

I guess this is the same problem: And tickets 14287 and 11251 look similar
Posts: 16
Joined: 28. Aug 2014, 14:39

Re: USB not working

Postby stickybit85 » 14. Feb 2016, 22:37


The workaround described in here is not working at all ... :/

Host: Windows 10
VBox: 5.0.14
Hardware: Asus Z170 Mainboard

Any other ideas?
Posts: 6
Joined: 4. Feb 2016, 22:09

Re: USB not working

Postby Frant » 2. Mar 2016, 02:34

Thanks a lot Nayasis! Those USB problems were extremely annoying.

It worked like a charm in the following configuration:

- VirtualBox version 5.0.14 r105127,
- Windows 10 Professional Edition 64 bits host,
- Lubuntu 15.04 64 bits guest.
Posts: 1
Joined: 2. Mar 2016, 02:27

Re: USB not working

Postby NoNoNo » 1. Apr 2016, 08:47

nayasis wrote:I've got solution finally... T-T

(It seems like problem of window 7)


It's effective for me, the solution provided by nayasis, thanks. :P

I've struggled for USB not work (Vbox said USB Busy... for untold reasons).
Just after I change hardwares (old mainboard was DEAD), I thought windows 7 64-bit is finally work again, unexpectedly Virtualbox USB is malfunction!
Posts: 51
Joined: 16. Apr 2015, 17:35
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP(32bit) / Debian 8.x / Debian 7.x / Windows 7(32bit)

Re: USB not working

Postby TekLord » 19. Apr 2016, 05:00


I can't believe this worked!

FYI: I am running Windows 10 x64 Host and Windows XP x32 Guest.

Posts: 30
Joined: 16. May 2014, 16:37

Re: USB not working

Postby Shashinka » 22. Apr 2016, 00:15

@ nayasis

My good friend, your fix has not worked for me at this stage... :?
My host is Windows 10 Pro 64bit
My guest Windows XP Pro SP3 32bit
My VBox version 5.0.16 with extension pack installed.

I have the now well documented problem of not being able to attach USB devices : 2 printers and a film scanner ; one printer (Brother HL-2040) and the scanner are machines older than USB 3.0, the other printer (Epson SC P600) is a current model and does not pose a real problem since I can use it from the host system. For the film scanner the issue is serious since only Windows XP can support it.
I have tried your fix, in which the registry step was not needed since the UpperFilters entry does not exist for me. No success.
In the VM, the USB controller is set on USB 2.0 (Windows XP does not support 3.0) ; my brand new Shuttle desktop has only one USB 2.0 terminal, so I have reconnected my Brother printer to this terminal for testing : no success.

VM Manager shows one filter for the Brother printer, but the drop-down list from the guest "devices" tab in the status bar shows Brother HL-2040 two times.., both of them giving me the same error message that you know well.

Have you any suggestions, has anybody a similar experience ?

Many thanks to nayasis and all the people here who are trying to compensate for Oracle's slow response to the problem.
Posts: 13
Joined: 15. Jan 2016, 19:16

Re: USB not working

Postby kcax » 28. Apr 2016, 21:50

Made an account just to thank you, its fixed after hours!!!! thanks!!!
Posts: 1
Joined: 28. Apr 2016, 21:49


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Mlima and 59 guests