USB not working

Discussions related to using VirtualBox on Windows hosts.

USB not working

Postby gskywalkers » 18. Feb 2011, 01:34

I am using Windows 7 Home Premium and have installed VB on this system but I am unable to get it to recognize anything to do with USB plug ins. I downloaded and installed the VB USB pack but that did not help. All of the USB devices that are used on Windows 7 are listed when I click on settings and USB. Help with this would be greatly appreciated
gskywalkers
 
Posts: 3
Joined: 14. Feb 2011, 16:18
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: xp

Re: USB not working

Postby Chasa » 18. Feb 2011, 19:39

I have the same problem. Win 7 Home Premium Host, Win32 Pro guest. All usb devices are seen but none will work? We need help for this. (Note: this post using WinXP64 host & WinXP32 guest, works without a problem so it appears to be a Win7 Home Premium Host problem)
Chasa
 
Posts: 1
Joined: 15. Feb 2010, 06:57
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: win32, ubuntu 9.10

Re: USB not working

Postby seniorvol1 » 19. Feb 2011, 00:33

I have been searching the manual, howtos, etc and had no luck finding a solution either. I must be overlooking something basic.
In one reply, it said to edit the registry and delete the upper filter entry key. Tried it and no sucess.
Current host is a Windows 7 Home Premium 64 bit machine with two guests, XP Pro and Ubuntu 10.10, VBox 4.0.2. Usb flash drives are not recognized in either guest OS.
I have also tried previous VBox versions (3.x) on this machine with same result. I also tried Vbox on two other sets of hardware with a Windows 7 Home Premium 32 bit version Host and XP Pro guest. The Virtual machine "settings/usb" shows the flash drive(s) but they will not install. I have tried generic and edited filters which contain device numbers, etc.. The error message details shows

E_INVALIDARG (0x80070057)
HostUSBDevice
IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}
seniorvol1
 
Posts: 2
Joined: 14. Feb 2011, 04:49
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: XP

Re: USB not working

Postby jorgensen » 19. Feb 2011, 08:17

seniorvol1 wrote:Usb flash drives are not recognized in either guest OS.

If Windows register the USB drive as a fixed drive VirtualBox is not able to take over that drive.
Don't know if this is intended or a bug.
jorgensen
 
Posts: 477
Joined: 20. Oct 2009, 01:22
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows, LinuxMint, Mac

Re: USB not working

Postby gskywalkers » 20. Feb 2011, 01:20

seniorvol1 wrote:I have been searching the manual, howtos, etc and had no luck finding a solution either. I must be overlooking something basic.
In one reply, it said to edit the registry and delete the upper filter entry key. Tried it and no sucess.
Current host is a Windows 7 Home Premium 64 bit machine with two guests, XP Pro and Ubuntu 10.10, VBox 4.0.2. Usb flash drives are not recognized in either guest OS.
I have also tried previous VBox versions (3.x) on this machine with same result. I also tried Vbox on two other sets of hardware with a Windows 7 Home Premium 32 bit version Host and XP Pro guest. The Virtual machine "settings/usb" shows the flash drive(s) but they will not install. I have tried generic and edited filters which contain device numbers, etc.. The error message details shows

E_INVALIDARG (0x80070057)
HostUSBDevice
IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}


Has anyone been able to get the USB to work using Windows 7 Professional? I have a feeling that this is a Windows 7 Home Premium issue.
gskywalkers
 
Posts: 3
Joined: 14. Feb 2011, 16:18
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: xp

Re: USB not working

Postby seniorvol1 » 22. Feb 2011, 04:02

New data. Host Win 7 Home Premium, The Logitech camera always says unknown but the USB flash drive indicated proper data but just would not load. See post above. I removed the Ubuntu 10.10 vm and all USB devices and reloaded Ubuntu. After installing the guest extensions I tried a flash drive. Windows showed the flash drive being loaded, and then Ubuntu said the flash was being loaded. Note: the safe remove icon disappered when Ubuntu captured the drive. Ubuntu now allows me to see and use the flash drive. Tried the Logitech camera, Both Windows and Ubuntu said they and captured the camera. However, the Camera still shows as unknown in the USB Devices box.
seniorvol1
 
Posts: 2
Joined: 14. Feb 2011, 04:49
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: XP

Re: USB not working

Postby nayasis » 23. Feb 2011, 04:08

It works well on WINDOW XP host OS.

it happens because of mis-installation of virtualbox usb driver on WINDOW 7 (32bit and 64bit) .. may be virtualbox's bug ??

This problem has happend since long time ago.. bug has reported already. see below link.

http://www.virtualbox.org/ticket/5343
nayasis
 
Posts: 3
Joined: 22. Feb 2011, 13:59
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Window XP

Re: USB not working

Postby nayasis » 24. Feb 2011, 10:14

I've got solution finally... T-T

(It seems like problem of window 7)


1. My Host is window 7 32bit home premium. But, 64bit's solution may be same because problem was caused by USB filtering function of WINDOW 7.

2. first of all, edit your registry

- Open the Windows registry, by clicking on Start > Run and typing regedit
- Navigate to the following location HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
- In the right hand panel, if the the UpperFilters entry exists, then delete it

3. Install virtualbox USB driver manually.

- Goto folder C:\Program Files\Oracle\VirtualBox\drivers\USB\filter
- Click right mouse button on file named VboxUSBMon.inf
- Check Install(I) (maybe.. My window is korean so it dose not exact. )

4. Rebooting

5. Unplug your USB memory (or joystick..)

6. Open VirtualBox and Close it rightly.
( it will remove your USB device from VM's seized list. )

7. Plug your USB memory.

8. Open VirtualBox and Run Virtual Machine.

9. Click right mouse button on USB icon placed in status bar which is below VM window.

10. Check USB device what you want to plug in.

11. Enjoy !!



** notice !!

Do not chain your USB device like snake. for example... A usb bridge <- B usb device... and check B usb device in VM. like this...

to use B usb device, you must check A usb bridge first !... it's so complicate..
nayasis
 
Posts: 3
Joined: 22. Feb 2011, 13:59
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Window XP

Re: USB not working

Postby leftyce » 24. Feb 2011, 21:05

I got mine to work by running the manual install as recommended by nayasis in his
3. Install virtualbox USB driver manually. instruction.


Then inserted USB thumb drive.
Then restarted VirtualBox.
Then went back into Settings > USB and then installed the filter for this thumb drive as described there by clicking on the Add Filter button on the right side.
leftyce
 
Posts: 1
Joined: 24. Feb 2011, 20:38
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP SP3

Re: USB not working

Postby ESP » 4. Mar 2011, 16:54

Thanks nayasis, you made my day :)
ESP
 
Posts: 7
Joined: 21. Apr 2009, 22:48
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, openSUSE, Ubuntu, Gentoo

Re: USB not working

Postby beecher » 5. Mar 2011, 02:32

Try uninstalling the AMD USB filter device driver because that's what solved my problem and if you want USB 2.0 then your going to have install the Oracle Virtualbox addons and to get it to work
Step 1: connect your USB device to a USB 1.1 port
Step 2: go into the config of the virtual machine your using and add that USB device to your USB filter list
Step 3: open the virtual machine
Step 4: Close the VM and disconnect your USB device
Step 5: connect you usb device to USB 2.0 and repeat step 2 and 3
beecher
 
Posts: 22
Joined: 28. Aug 2010, 18:32
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows xp SP3

Re: USB not working

Postby earthenware541 » 7. Oct 2012, 02:16

Nayasis, you deserve a medal. After days of pain I've got it working thanks to your instructions. I'd have given up otherwise.
Now it's days of backup via old USB2...hope I can use USB3 sometime in the future (Fedora Vortexbox being hosted). Still, it's all part of the learning...:-)
earthenware541
 
Posts: 1
Joined: 7. Oct 2012, 02:08

Re: USB not working

Postby jorgensen » 7. Oct 2012, 10:01

USB Deview is a great tool to remove USB settings from the register and refresh the USB initialization.

http://www.nirsoft.net/utils/usb_devices_view.html
jorgensen
 
Posts: 477
Joined: 20. Oct 2009, 01:22
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows, LinuxMint, Mac

Re: USB not working

Postby jonathan_rey » 19. Jan 2014, 18:24

nayasis wrote:I've got solution finally... T-T

(It seems like problem of window 7)


1. My Host is window 7 32bit home premium. But, 64bit's solution may be same because problem was caused by USB filtering function of WINDOW 7.

2. first of all, edit your registry

- Open the Windows registry, by clicking on Start > Run and typing regedit
- Navigate to the following location HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
- In the right hand panel, if the the UpperFilters entry exists, then delete it

3. Install virtualbox USB driver manually.

- Goto folder C:\Program Files\Oracle\VirtualBox\drivers\USB\filter
- Click right mouse button on file named VboxUSBMon.inf
- Check Install(I) (maybe.. My window is korean so it dose not exact. )

4. Rebooting

5. Unplug your USB memory (or joystick..)

6. Open VirtualBox and Close it rightly.
( it will remove your USB device from VM's seized list. )

7. Plug your USB memory.

8. Open VirtualBox and Run Virtual Machine.

9. Click right mouse button on USB icon placed in status bar which is below VM window.

10. Check USB device what you want to plug in.

11. Enjoy !!



** notice !!

Do not chain your USB device like snake. for example... A usb bridge <- B usb device... and check B usb device in VM. like this...

to use B usb device, you must check A usb bridge first !... it's so complicate..


This procedure, works for me

I have Windows 7 Enterprise 64 Bit Host / Windows XP SP3 Guest. My mobo have USB 3.0 / 2.0

Thank you very much
jonathan_rey
 
Posts: 1
Joined: 19. Jan 2014, 18:21

Re: USB not working

Postby Manos » 28. Jan 2014, 22:55

nayasis wrote:I've got solution finally... T-T

(It seems like problem of window 7)


1. My Host is window 7 32bit home premium. But, 64bit's solution may be same because problem was caused by USB filtering function of WINDOW 7.

2. first of all, edit your registry

- Open the Windows registry, by clicking on Start > Run and typing regedit
- Navigate to the following location HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
- In the right hand panel, if the the UpperFilters entry exists, then delete it

3. Install virtualbox USB driver manually.

- Goto folder C:\Program Files\Oracle\VirtualBox\drivers\USB\filter
- Click right mouse button on file named VboxUSBMon.inf
- Check Install(I) (maybe.. My window is korean so it dose not exact. )

4. Rebooting

5. Unplug your USB memory (or joystick..)

6. Open VirtualBox and Close it rightly.
( it will remove your USB device from VM's seized list. )

7. Plug your USB memory.

8. Open VirtualBox and Run Virtual Machine.

9. Click right mouse button on USB icon placed in status bar which is below VM window.

10. Check USB device what you want to plug in.

11. Enjoy !!



** notice !!

Do not chain your USB device like snake. for example... A usb bridge <- B usb device... and check B usb device in VM. like this...

to use B usb device, you must check A usb bridge first !... it's so complicate..







THANK YOU NAYASIS !!!!!!!!
Manos
 
Posts: 4
Joined: 25. Jan 2014, 23:14


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: cobbaut, Google [Bot], Yahoo [Bot] and 30 guests