Page 1 of 1

Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 23. Dec 2010, 08:33
by wroberte
Just upgraded from 3.2.12 to 4.0.0.

Windows XP Host and both XP and Ubuntu guests.

I have 2 physical monitors and under 3.2.12 I could get a guest to go into full-screen mode on the 2nd physical monitor. Basically, I would take it out of full-screen, drag it to the 2nd monitor and return to full screen and the guest session would "stick" to the 2nd monitor.

Under 4.0.0 whenever I put a guest into full-screen mode it always goes to the primary monitor.

How do I put a guest into full-screen mode on the 2nd monitor under 4.0.0?

Re: Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 23. Dec 2010, 23:07
by j-hager
I have the same problem on Windows 7 with version 4.0.0.

Both full-screen and seamless modes now only work on the primary monitor.

Is this a bug, or is there some new setting I need to change?

Re: Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 24. Dec 2010, 04:46
by garygao
Thia is a real Problem!!!!!!!!!

Re: Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 24. Dec 2010, 20:36
by Sasquatch
Take out the mini toolbar and select the monitor there. It's that simple. Nothing changed in v4 compared to v3.2 for this feature.

Re: Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 24. Dec 2010, 23:07
by j-hager
Thanks Sasquatch, that fixed it. :D

I've been doing the same thing as the original poster since early version 3. It's nice to have an actual menu item to select the monitor.

Now if only the toolbar would show up when I need it. It seems to go into hiding (even if pinned in place) and won't come back until I switch in and out of full-screen several times.

Re: Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 26. Dec 2010, 14:28
by Sasquatch
Move your mouse to it's location, then it will pop up. If you pin it down using the pin icon, it should stay on screen all the time. Maybe you accidentally disabled the bar in the VM settings and it just pops up once after which it disappears.

Re: Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 27. Dec 2010, 23:51
by wroberte
Thanks for the assistance, Sasquatch.

Using the mini toolbar and selecting the 2nd monitor fixed the problem.

Re: Cannot force Guest in Full Screen to 2nd Physical Monitor

PostPosted: 13. Jun 2011, 15:37
by virtuoso
wroberte wrote:Thanks for the assistance, Sasquatch.

+1! I was getting pretty frustrated trying to figure out this silly problem on my own.

Note, the VM has to be up and running in full screen mode (e.g. on the undesired monitor) before you can access the mini toolbar.