Bluetooth NOT detected. Ubuntu 10.04 on Windows XP

Discussions related to using VirtualBox on Windows hosts.

Bluetooth NOT detected. Ubuntu 10.04 on Windows XP

Postby ajaykumar » 28. Sep 2010, 15:22

Hi all,

I am trying to get Bluetooth dongle working on Ubuntu 10.04.

I have following setup:
Virtual Box Version: 3.2.8.
Installed on Host: Windows XP SP3.
Guest OS is: Ubuntu 10.04.

In the VB main-menu-bar I see:
Devices->USB Devices->Unknown device 0A12:0001 [0134]

After clicking on Unknown device ... Virtual box throws error:

Failed to attach the USB device Unkown device to the virtual machine ubuntuForYou

USB device '<unknown>' with UUID {6633cc62-348a-4a5f-9fc3-4546ff8a1a72} is busy with a previous request please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

lsusb does not show the device, ...

Can anybody please help?

withRegards,
AK
ajaykumar
 
Posts: 3
Joined: 28. Sep 2010, 14:06
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 10.04

Re: Bluetooth NOT detected. Ubuntu 10.04 on Windows XP

Postby DidrikM » 29. Sep 2010, 15:22

Go to the VM's settings and add a filter for the dongle. (Click the green + button and choose the dongle in the pop-up menu.) Then, if needed, disconnect the dongle and reattach it while the VM is running.
DidrikM
 
Posts: 16
Joined: 8. Sep 2010, 14:59
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, Windows Vista

Re: Bluetooth NOT detected. Ubuntu 10.04 on Windows XP

Postby ajaykumar » 30. Sep 2010, 09:16

Hi DidrikM,

Thank you for the response.
It worked, with some additional steps :)

1. # poweroff
2. settings -> USB -> Alt+Ins, this popped up "Unknown Device 0A12:0001[0134]",
I clicked on it, I could see the device selected under USB device Filters
3. clicke on OK.
4. Select the guest OS i.e., Ubuntu 10.04, click on start.
5. fiddled with the USB dongle (insert - remove - insert bluetooth dongle).

Now it threw a message box, "Failed to set bluetooth power, The error reported is: Connection timed out"

6. # gedit /etc/bluetooth/main.conf
7. Replace 'RememberPowered' parameter from "true" to "false" (ofcourse with out quotes :) ).
8. Save and close.
9. # reboot

After the system is up ...
10. # hciconfig -a output
this is showing me the device :)
11. # hictool scan
can see the mobiles, which have activated their bluetooth :D

Thank you once again DidrikM, for the idea.

For others, who are reading this post...
Things are not stable, you have to fiddle around these steps.
next time when I # reboot the system up I face the same problems...
I fiddled around and again its working... :D
ajaykumar
 
Posts: 3
Joined: 28. Sep 2010, 14:06
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu 10.04

Re: Bluetooth NOT detected. Ubuntu 10.04 on Windows XP

Postby Tutai » 16. Oct 2019, 19:57

I am trying this in many ways. I am using VirtualBox 6.0 on Windows 10. The CSR 4.0 Bluetooth dongle is working properly in the host OS. However, something I am missing and the Android-X86 8.1 rel_2 could not detect the external BLE dongle. Can someone help me on this ?
Tutai
 
Posts: 4
Joined: 15. Oct 2019, 16:04

Re: Bluetooth NOT detected. Ubuntu 10.04 on Windows XP

Postby scottgus1 » 16. Oct 2019, 20:33

Nine-year-old necropost, there, Tutai.

Start a new thread with the NewTopic" Button. And take a good look through USB basics and troubleshooting beforehand.

Also be aware that there are no references to Android in the Help Manual, especially missing in the Supported Guests, section 3.1.
Human government is like that crazy uncle who hides a quarter in his fist behind his back, then asks you to guess which fist the quarter is in...
No matter which side you choose, Left or Right, both Sides are empty.
scottgus1
Volunteer
 
Posts: 4863
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Win7

Re: Bluetooth NOT detected. Ubuntu 10.04 on Windows XP

Postby socratis » 17. Oct 2019, 00:39

scottgus1 wrote:Nine-year-old necropost, there, Tutai.

That's exactly why the thread is getting locked.

And because Tutai has been active in another thread as well...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27252
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 64 guests