Segfault in swrast.c:get_window_size() (vboxvideo)

Discussions related to using VirtualBox on Windows hosts.

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby backvan » 8. Jul 2010, 09:57

Well, there is NEWS tonight. Good News, that is. I updated my OSX Snow Leopard to 10.6.4. There is no news there. Then I installed today's VirtualBox 4.2.6 Beta 2. There was NO prompt to install Guest Additions so I did not. I then enabled 3D Acceleration and fired off the Fedora 13 Guest OS I made last night. My large display pixel size still works. The I fired off Desktop Effects. This time I actually got a dialog box with the two radio buttons, Standard and Compiz. So I selected Compiz and selected "WorkSpace on a Cube". And it Worked!! Hurrah. Then i tried the Wobbly Windows and that worked as well

Once again, this is Fedora 13, 2.6.33.5-124.fc13.i686. And on my i7 iMac, it is very fast. And the 27" monitor is wonderful. I have the Display size throttled back to 1400x900. I suppose I will return the display size in OSX back to it's max, something like 2400x?? and see what happens.

Seems like this last Beta did the trick. Anyone else have good luck tonight?
backvan
 
Posts: 23
Joined: 21. Apr 2010, 08:16
Primary OS: Mac OS X Leopard
VBox Version: OSE Fedora
Guest OSses: Ubuntu Lucid Lynx

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby backvan » 8. Jul 2010, 10:42

Well not quite. Still a little buggy. For some reason I decided to reboot the iMac and try to launch Fedora 13 again, just to be sure all is well. Well what happened was, Fedora seemed to boot OK and I got a Login prompt, and then tried to log in. The iMac froze up again. So I rebooted and this time turned OFF 3D acceleration and relaunched Fedora and once again got to the login prompt. This time I could log in OK. So, just on a hunch, I reran the Guest Additions build again so the same good results. Then I shutdown Fedora and enabled 3D Acceleration and relaunched Fedora and was able to log in with no problem. Once again, the Desktop on a Cube is working again.

Don't what this is all about. Then this is a Beta copy so I'm not to concerned yet. Actually I'm still thrilled it is working fine if I don't mess with it.

Is anyone else having the Luck of the Irish?
backvan
 
Posts: 23
Joined: 21. Apr 2010, 08:16
Primary OS: Mac OS X Leopard
VBox Version: OSE Fedora
Guest OSses: Ubuntu Lucid Lynx

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby backvan » 11. Jul 2010, 05:14

Since my short period of success with Desktop Effects last week, my luck has been all bad. I have not be able to reproduce a successful login with 3D Acceleration enabled. So tonight, I decided to try upgrading the kernel from 2.6.33.5-124 to 2.6.33.6-124. I noticed "desktop-effects" also got upgraded from 0.8.6-1 to a later flavor 0.8.7.2.

My results with desktop-effects is still the same. It freezes the iMac when I try to actually login-in. Not surprisingly, at the same GUI login prompt, when I switch to a textual virtual terminal, I can login in just fine. For the life of me, I can't figure out why 3D Acceleration did work 2 times about a week ago.

Here's my xorg.conf. Is there anything out of order? Ideas??

]$ more xorg.conf
# VirtualBox generated configuration file
# based on /etc/X11/xorg.conf.

Section "Monitor"
Identifier "Monitor[0]"
ModelName "VirtualBox Virtual Output"
VendorName "Sun Microsystems Inc"
EndSection

Section "Device"
BoardName "VirtualBox Graphics"
Driver "vboxvideo"
Identifier "Device[0]"
VendorName "Sun Microsystems Inc"
EndSection

Section "Screen"
SubSection "Display"
Depth 24
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection
backvan
 
Posts: 23
Joined: 21. Apr 2010, 08:16
Primary OS: Mac OS X Leopard
VBox Version: OSE Fedora
Guest OSses: Ubuntu Lucid Lynx

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby hoeferbe » 11. Jul 2010, 08:07

I believe I have the exact same problem. I'm running a Fedora 12 x86_64 guest, though. I've been unable to get 3D acceleration working in it since I first started using VirtualBox in December 2009. I submitted a bug to Red Hat back near the end of April, but it hasn't had any activity:

https://bugzilla.redhat.com/show_bug.cgi?id=585605

Looking at the backtrace between your seg fault and mine, it looks very similar in that our problem is both in swrast.c's get_window_size.

I've not tried using any other Linux distributions as guests. I did try Windows XP as a guest. 3D acceleration works in it.
hoeferbe
 
Posts: 3
Joined: 11. Jul 2010, 07:55
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Fedora 12, Fedora 15, Win2k, WinXPPro

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby backvan » 11. Aug 2010, 04:53

I see tonight that VirtualBox 3.2.8 is out about 2 days ago. One of the supposed fixes is "3D support: fixed GL_EXT_texture_sRGB support" Might this be the fix we have been waiting for? Anybody tried it yet? Any good news?
backvan
 
Posts: 23
Joined: 21. Apr 2010, 08:16
Primary OS: Mac OS X Leopard
VBox Version: OSE Fedora
Guest OSses: Ubuntu Lucid Lynx

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby SSCBrian » 20. Sep 2010, 14:04

Unfortunately, it does not appear to solve the issue. I'm on the latest VBox, with 3D acceleration enabled, Fedora 13 x64 all patched up to latest, and it's throwing "Your system is not capable of hardware accelerated 3D" errors when trying to run Stellarium.
SSCBrian
Volunteer
 
Posts: 365
Joined: 13. Jun 2008, 15:04
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 8 RTM (MSDN)

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby axdp944 » 4. Oct 2010, 06:51

intel i5 4mb ram Video: Nvidia Quadro NVS 3100M
Host Windows 7 Pro 64 bit
Guest OS: Fedora 13 Gnome - kernel 2.6.34.7-56.fc13.x86_64
Virtual Box 3.2.8 r64453

Thanks for keeping this thread going! It hasn't been easy finding info on this issue, but for the past several weeks now, when trying to run compiz, desktop-effects, or even glxinfo, I've also been getting this same segfault with a backtrace referring to a get_window_size object.

Finally, after reading one of the comments in a bug filed over at Virtual Box, I think I have a semi-decent workaround. I recommend reading through comments 4 through 6 here for more info: http://www.virtualbox.org/ticket/7061

Apparently one of the more recent responses suggested the problem may be with the recent version of Mesa's libGL (v7.8) not being completely compatible with the older version v7.2 of libGL Vbox uses.

After confirming I was running this most recent version, I first tried just reinstalling the following files:

Code: Select all   Expand viewCollapse view
$ sudo yum reinstall mesa-libGL-7.8.1-8.fc13.x86_64 mesa-libGLU-7.8.1-8.fc13.x86_64


Immediately after reinstalling these libraries, I noticed an improvement since I was able to run glxinfo, desktop-effects and compiz without running into a segfault. Nothing before this, short of rolling back to a previously known good snapshot had worked for me prior to this.

As it has only been a few hours since I verified this fix, I'm skeptical that simply reinstalling the same versions of libGL will fix this problem long term. In the meantime, I'm going to research rolling back to a prior version closer to v7.2 to see if that will fix the problem until Virtual Box can upgrade this library.

I'd definitely be curious to hear if any of you guys have similar luck or if you find an older library that works better for you.
axdp944
 
Posts: 5
Joined: 4. Oct 2010, 04:46
Primary OS: MS Windows 7
VBox Version: OSE Fedora
Guest OSses: Fedora 13

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby SSCBrian » 4. Oct 2010, 15:15

After restoring those older libraries, glxinfo does work properly now. However, Stellarium still segfaults for me. Have you tried it on yours?
SSCBrian
Volunteer
 
Posts: 365
Joined: 13. Jun 2008, 15:04
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 8 RTM (MSDN)

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby axdp944 » 5. Oct 2010, 06:16

SSCBrian wrote:After restoring those older libraries, glxinfo does work properly now. However, Stellarium still segfaults for me. Have you tried it on yours?


I can't speak to the problem you're having with Stellarium since all of my testing so far has been under Compiz, glxinfo and glxgears.
axdp944
 
Posts: 5
Joined: 4. Oct 2010, 04:46
Primary OS: MS Windows 7
VBox Version: OSE Fedora
Guest OSses: Fedora 13

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby axdp944 » 6. Oct 2010, 05:26

OK, after a bit of testing, I think I have a more permanent solution I can offer everyone until Virtualbox upgrades their support for mesa-libGL 7.7-8 library in Fedora 12-13.

Please bear in mind that I am not a Linux expert and cannot be held responsible for any problems caused by this suggestion. Note the suggestion above of just reinstalling these packages as I mentioned in a previous post is an annoying, but IS a safer option.

Summary of solution: To make my Fedora 13 guest OS more compatible with the 3D graphics support in Virtual Box and prevent the segfault errors in desktop-effects and Compiz I've downgraded my Mesa graphics library and driver packages to the Fedora 11 versions 7.5-0.14.fc11.

Before starting this process, you'll want to turn off desktop-effects and compiz since we'll be removing packages that these applications explicitly depend on.

Step 1: You need to locate older versions of the mesa-libGL, mesa-libGLU and mesa-dri-drivers. For my 64bit guest OS, I decided to use version 7.5-0.14.fc11.x86_64 from Fedora 11, though you may be able to get away with using a slightly newer package, these seemed to work for me:

mesa-libGL-7.5-0.14.fc11.x86_64.rpm
mesa-libGLU-7.5-0.14.fc11.x86_64.rpm
mesa-dri-drivers-7.5-0.14.fc11.x86_64.rpm

You can get these packages here: http://www.rpmfind.net/linux/rpm2html/search.php

Step 2: Remove the existing 7.8 mesa packages from your guest OS

as root from a command-line
Code: Select all   Expand viewCollapse view
$ sudo rpm -e --nodeps mesa-libGL-7.8.1-8.fc13.x86_64  mesa-libGLU-7.8.1-8.fc13.x86_64 mesa-dri-drivers-7.8.1-8.fc13.x86_64


note: I don't recommend using yum to remove these packages as it will also try to remove a lot of other packages that depend on these packages we'll be downgrading.

Step 3: Install your downgraded mesa library and driver packages:

now cd into the directory you downloaded your RPMs from step 1 and install these downgraded packages

as root from command-line
Code: Select all   Expand viewCollapse view
rpm -ihv mesa-dri-drivers-7.5-0.14.fc11.x86_64.rpm
rpm -ihv mesa-libGL-7.5-0.14.fc11.x86_64.rpm
rpm -ihv mesa-libGLU-7.5-0.14.fc11.x86_64.rpm


Finally, restart your guest OS and you should be able to use compiz and desktop-effects through Virtualbox without any more segfaults.

Please let me know if this worked for you or if you have any better suggestions to offer for a more permanent solution.
In particular, I played it a little safe using the v7.5 drivers. I don't know if this will cause problems with other applications however, so I'd be interested to hear if anyone has tried using a more recent version of these packages with any success.

Hope this helps someone.
axdp944
 
Posts: 5
Joined: 4. Oct 2010, 04:46
Primary OS: MS Windows 7
VBox Version: OSE Fedora
Guest OSses: Fedora 13

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby SSCBrian » 6. Oct 2010, 16:26

axdp944 wrote:You can get these packages here: http://www.rpmfind.net/linux/rpm2html/search.php


Any other places to do the same thing? rpmfind's lookup has been broken all morning. :-(
SSCBrian
Volunteer
 
Posts: 365
Joined: 13. Jun 2008, 15:04
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 8 RTM (MSDN)

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby axdp944 » 6. Oct 2010, 18:02

SSCBrian wrote:Any other places to do the same thing? rpmfind's lookup has been broken all morning. :-(


Should be working now. But there are quite a few places online you can download RPMs for Fedora and other linux builds.

Another resource I've used is http://rpm.pbone.net/

Alternatively, just search google for the packages I've references above and you should find more locations to download these.
axdp944
 
Posts: 5
Joined: 4. Oct 2010, 04:46
Primary OS: MS Windows 7
VBox Version: OSE Fedora
Guest OSses: Fedora 13

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby axdp944 » 10. Oct 2010, 04:23

Looks like I was wrong. :x

After a couple days of seemingly flawless performance from my guest OS, I encountered another segfault under the v7.5 mesa LibGL that crashed my desktop once again.

At this point my best guess is that, the virtualbox 3D drivers are still too buggy to handle 3D applications reliably and the best solution for us will probably be to wait until VB can address this in a release.

Short of that, the workaround I posted earlier of simply reinstalling mesa-drv, mesa-libGL and mesa-libGLU is still a half-decent solution that will get your 3D working again, at least temporarily.
axdp944
 
Posts: 5
Joined: 4. Oct 2010, 04:46
Primary OS: MS Windows 7
VBox Version: OSE Fedora
Guest OSses: Fedora 13

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby SSCBrian » 11. Oct 2010, 14:01

No success here at all with the Stellarium app and the old RPMs. I guess I'll just wait for a new version too. Eventually it's bound to work right. :-)
SSCBrian
Volunteer
 
Posts: 365
Joined: 13. Jun 2008, 15:04
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 8 RTM (MSDN)

Re: Segfault in swrast.c:get_window_size() (vboxvideo)

Postby hoeferbe » 26. Nov 2010, 07:53

hoeferbe
 
Posts: 3
Joined: 11. Jul 2010, 07:55
Primary OS: Linux other
VBox Version: OSE other
Guest OSses: Fedora 12, Fedora 15, Win2k, WinXPPro

Previous

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Poci and 38 guests