Virtual Machine SLAMMED by RDP

Discussions related to using VirtualBox on Windows hosts.

Virtual Machine SLAMMED by RDP

Postby akscooter » 8. Jun 2010, 22:45

I have a server 2003(x86 with 8 CPU) host running VBox with three sever 2003 Terminal Services Servers as clients.

One of them is running Japanese language packs. All three approximately 15 thin clients connected.

The Japanese server is being SLAMMED by the clients and is pegged at 100% CPU utilization. I've maxed the ram to the 1500 (I have 8 gig on server) with no significant improvement. The next step was to increase the CPU's allocated to the client, but when I do, the system won't boot.

I'm about to move the server to the backup server, but would like to make it run faster on the backup. How do I increase the CPU's allocated to the client?

Thanks
Jon
akscooter
 
Posts: 5
Joined: 5. May 2009, 00:28
Primary OS: MS Windows 2003
VBox Version: OSE other
Guest OSses: XP

Re: Virtual Machine SLAMMED by RDP

Postby vbox4me2 » 10. Jun 2010, 10:54

First investigate what process is using cpu inside the Guest, sometimes something as simple as antivrus can push cpu use to the limit.
vbox4me2
Volunteer
 
Posts: 5218
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Virtual Machine SLAMMED by RDP

Postby ToddAndMargo » 5. Jul 2010, 19:15

Hi Jon,

Did you ever figure this out?

I have the same problem, only on two Linux hosts:
http://www.virtualbox.org/ticket/6928
If you think this bug/defect applies to you, you may wish to get on the Cc: list and make a post as to your situation.

Anyway, I have two Terminal Server guests running on two Linux hosts: one with a ws2003 and one with ws2008 guests. They both get HAMMERED with CPU storms with Terminal Services clients.

On the WS2008 guest (VB 3.2.4) with an x5650 processor (6 cores), I had to restrict the guest to one processor and VT-x=off. One core with VT-x turned on stormed out. One core with VT-x turned off was the only way I could stabilize it. And it is faster than four cores and VT-x turned on. (You can only run with VT-x off if you are running one core.)

On the other ws2003 guest, I had to remove the X5650 processor and replace it with an i7-920 (4 cores), set the guest to 2 cores, and revert to VB 3.1.8. The ws2003 server still has problems with CPU storms, but at least it is stable. The X5650 had the latest VT-x microcode, where the i7-920 has the old stuff.

I do not run an antivirus on either of these.

Also, take a look at:
http://www.virtualbox.org/ticket/6936
He cured his CPU storms by reverting to VM Ware (something I really, really do not feel like doing). This may be your only way out: barring fixing ticket 6928.

VM Ware allows for multiple cores using software emulation where VB requires VT-x for multiple cores.

And, have you tried reverting to VB 3.1.8? VB 3.2.x tried to take greater advantage of VT-x and that may be the cause of both our problems. I do believe the defect is in VB's VT-x code.

Also, look into a piece of software called Thread Master:
http://threadmaster.tripod.com/
It *will not* help with the your or my current situation (I have it on both my guests), but it will help when and if this defect gets fixed.

-T
ToddAndMargo
 
Posts: 306
Joined: 6. Aug 2007, 02:24


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Cottonwoodhill, Talfurn, The_TecnoKing and 36 guests