VERR_SSM_INTEGRITY_UNIT_NOT_FOUND

Discussions related to using VirtualBox on Windows hosts.

VERR_SSM_INTEGRITY_UNIT_NOT_FOUND

Postby Gregoo » 26. May 2010, 13:52

Hello,
sometimes when I was resuming a saved machine, the GUI was silently crashing on VirtualBox 3.1 series (I don't know for 3.0 and earlier). After the crash the session was lost and the machine had to boot again from scratch. The crashes appear randomly I guess.

I think I had that bug only while powering the machine via Remote Desktop (not sure if it's related though). It crashed on Windows XP Professional x64, and it continued crashing on Windows 7 Professional x64.
Oh, the guest is a Windows Server 2003

With the new VirtualBox 3.2, I had that message (Found no handler for unit 'QGLVHWAData0' instance #0! / VERR_SSM_INTEGRITY_UNIT_NOT_FOUND) when trying to resume a machine.

Code: Select all   Expand viewCollapse view
00:00:05.249 ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Virtual machine is being powered down} aWarning=false, preserve=false
00:00:05.264 Changing the VM state from 'DESTROYING' to 'TERMINATED'.
00:00:05.479 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Found no handler for unit 'QGLVHWAData0' instance #0 (VERR_SSM_INTEGRITY_UNIT_NOT_FOUND)} aWarning=false, preserve=false
00:00:05.506 Power up failed (vrc=VERR_SSM_INTEGRITY_UNIT_NOT_FOUND, rc=ERROR_SUCCESS (0X000000))


The machine didn't resume, but I didn't lose the saved state and no Windows message about the GUI crashing. When I tried to resume it a second time, the same message appeared and I received the Windows message telling me VirtualBox GUI had crashed.

No clue if it's the same error I had with VirtualBox 3.1 series.

I've searched the forum for those keywords (QGLVHWAData and VERR_SSM_INTEGRITY_UNIT_NOT_FOUND) message and found no result came up.
I was wondering if someone already experienced that error and/or if someone was familiar with it and/or if there was a bug report about it and/or if there was anything I could do to help resolving that.

Also, I have no clue how VirtualBox logs work. I've saved something but no clue if it contains relevant information or not >: .
I'll post it if it's necessary D: .

EDIT:
There was those lines in the log o.o . Don't know if it's helpful though.
Code: Select all   Expand viewCollapse view
00:00:04.929 SSM: Found no handler for unit 'QGLVHWAData0' instance #0!
00:00:04.929 VMSetError: E:\tinderbox\win-rel\src\VBox\VMM\SSM.cpp(7918) ssmR3LoadExecV2; rc=VERR_SSM_INTEGRITY_UNIT_NOT_FOUND
00:00:04.935 VMSetError: Found no handler for unit 'QGLVHWAData0' instance #0
Gregoo
 
Posts: 3
Joined: 6. Feb 2010, 12:28
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows Server 2003

Re: VERR_SSM_INTEGRITY_UNIT_NOT_FOUND

Postby lukaswu » 30. Aug 2010, 11:57

Hi,

I've just experienced on 3.2.6 version (Linux host)- can't start Windows XP guest. The rest of my virtual machines works fine. The only thing I can do is to drop windowz machine from repository, which would be the very last thing to do.

So I upgraded to 3.2.8. Well... It did not help at all, still the problem exists.

Since I am not entitled to submit bugs, could anyone do it?

Thank you.

--
luk
lukaswu
 
Posts: 5
Joined: 20. Jan 2008, 14:05

Re: VERR_SSM_INTEGRITY_UNIT_NOT_FOUND

Postby chapeaurouge » 6. Sep 2010, 11:52

I had the same happening to me, running 3.2.8 binary on opensuse 11.3. Guest is a winXP.

I had to discard the "Saved" state of the machine to be able to start it.
chapeaurouge
 
Posts: 1
Joined: 6. Sep 2010, 11:51
Primary OS: openSUSE
VBox Version: OSE self-compiled
Guest OSses: winXP


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: dc1011 and 45 guests