USB hassle in version 3.1.4 solved for now.

Discussions related to using VirtualBox on Windows hosts.

USB hassle in version 3.1.4 solved for now.

Postby jorgensen » 17. Mar 2010, 19:34

Needed to update from version 3.1.0 to 3.1.4 because of a bug with snapshots and writethrough drives.
Feared I would run into USB problems, and that was exactly what I got in quantity!
To begin with, everything froze and hardbooting was required several times!
Was very close to rollback to 3.1.0, but as the snapshot bug was fixed, I gave the USB a try and after much fiddling it now is working.

The reason for the freeze was an USB device, that I had disabled because it only is required in a guest, but after enable it and installing the proper driver this problem was fixed.

The next problem was to get the USB devices working in the guest and here is the procedure I followed.
1: Open the Device Manager and Task Manager at the host.
2: Close VirtualBox completely and kill processes named VirtualBox.exe and VBoxSVC.exe in the Task Manager.
3: Remove the USB device and make sure it is not in the Device Manager.
4: Connect the USB device at the preferred port which is the one to be used in the future, and check the Device Manager again.
5: Start VirtualBox and the guest.
6: In the guest open the Device Manager and attach the USB device from the VirtualBox menu.
7: VirtualBox might now install a driver for routing the device. If so, install the driver and repeat from point 2.
8: When attaching the USB device in the guest keep an eye on the Device Manager in both the host and the guest. At the host, the device should detach and at the guest attach.
9: If still a problem try to repeat from point 2 and reboot the computer.

So far, I have managed to get the required USB devices to work again.

Added:
Moving the device to another USB port might solve a blocked USB setting. Also USBDeview is a good tool to control and clean up USB devices from Windows registry - http://www.nirsoft.net/utils/usb_devices_view.html

Note: Remember the 'Virtualbox Extension pack' must be installed for USB 2 support.
Last edited by jorgensen on 23. May 2013, 09:17, edited 3 times in total.
jorgensen
 
Posts: 537
Joined: 20. Oct 2009, 01:22
Primary OS: MS Windows 8.1
VBox Version: PUEL
Guest OSses: Windows, LinuxMint

Re: USB hassle in version 3.1.4 solved for now.

Postby jumpjack » 1. Mar 2011, 15:32

Thanks, it worked fine in WinXP+WinXP (VB 3.1.2)
jumpjack
 
Posts: 2
Joined: 1. Mar 2011, 15:20
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Windows XP

Re: USB hassle in version 3.1.4 solved for now.

Postby blksith0 » 4. Jul 2011, 17:43

Thank you thank you thank you.
I had been struggling with this for at least... 5 minutes. Give or take. This should be a sticky or something, someone give this guy an award. Seriously.
blksith0
 
Posts: 2
Joined: 1. Jul 2011, 20:46
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows XP

Re: USB hassle in version 3.1.4 solved for now.

Postby gurubob » 14. Nov 2011, 12:00

Win7 host, Ubuntu 11.04 guest. VirtualBox 4.1.6, USB extension pack installed, USB2.0 support enabled, filter added.

After spending a couple of hours on this (gaah) I finally tried out of frustration plugging my USB drive into another port - the difference for me was that I was initially plugging into a USB3.0 port and then I plugged into one of the front ports on my PC (presumably a 1.1 port).

I then saw my USB device pop up in the lsusb command (I had a terminal running "watch lsusb") and then Nautilus popped up with the files from the drive.

Hope this helps someone.
gurubob
 
Posts: 2
Joined: 16. Feb 2011, 04:59
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Linux


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 282 guests