Cannot start any VM VBOX_E_IPRT_ERROR

Discussions related to using VirtualBox on Windows hosts.

Cannot start any VM VBOX_E_IPRT_ERROR

Postby daveyb » 18. Jan 2010, 23:07

Hi,

I've been using VBox for a while without any real problems but today I cannot start any VM at all. I was running VBox 3.0.2 on a Win XP Pro SP3 host (and it was under 3.0.2 that I got the error shown below) but I have also upgraded to 3.1.2 this evening to try and resolve the problem (a suggestion picked up in another thread suggested the upgrade) but I have the same problem.

The error is
Code: Select all   Expand viewCollapse view
Could not launch a process for machine 'SuSE 11.2' (VERR_INVALID_PARAMETER)

Result Code: VBOX_E_IPRT_ERROR (0x80BB0005)
Component: Machine
Interface: IMachine {99404f50-dd10-40d3-889b-dd2f79f1e95e}
Callee: IVirtualBox {2158464a-f706-414b-a8c4-fb589dfc6b62}


Although this example is for a Open SuSE VM, I get the same error across ever VM (Win7, Ubuntu, BSD).

I've tried Googling & a search on this forum but cannot find any reference to this error.

Can anyone offer any advice on how to track the fault & rectify it.

Many thanks, David.
Last edited by daveyb on 19. Jan 2010, 00:01, edited 1 time in total.
daveyb
 
Posts: 5
Joined: 18. Jan 2010, 23:00
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: SuSE, Win7, Ubuntu


Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby daveyb » 18. Jan 2010, 23:34

Thanks for the quick reply but I (perhaps wrongly) didn't assume that was the specific error. I assumed that the VBOX_E_IPRT_ERROR (0x80BB0005) bit was a pretty generic runtime error and it was the "could not launch process" that was the real problem. Maybe I'm wrong.

Anyway, I've already looked through many of the Google results and can't find any that refer to my situation.

Do you know how I try and find out what process Vbox is failing to launch? (it doesn't even seem to be getting as far as rotating the logs, as VBox.log still only contains details from the previous successful VM session).

The only thing that I'm aware of that I've done since yesterday (when VBox ran successfully) is to uninstall MS SQL Server - does anyone know if that would have any bearing on VBox (I can't see why it would, or if it were, why installing a new version 3.0.2->3.1.2 wouldn't reinstall or highlight any essential missing component).

Any other suggestions?

Thanks, David.
daveyb
 
Posts: 5
Joined: 18. Jan 2010, 23:00
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: SuSE, Win7, Ubuntu

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby vbox4me2 » 19. Jan 2010, 10:21

Have you tried re-installing VBox fully?
vbox4me2
Volunteer
 
Posts: 5222
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby daveyb » 19. Jan 2010, 13:09

Yes, tried that (uninstalled and then reinstalled with reboot inbetween) but it made no difference.

It looks to me as if VBox can't even start, although the VBox GUI does and works OK, so I don't think it's anything to do with the VM images themselves. For example, if I create a new empty VM "shell" (which it seems to do fine) I then can't even start that to actually build a machine inside it.

The error (which pops up immediately on clicking "Start") says that VBox can't launch a process, presumably, to run the VM in. Do you have any idea what would stop VBox from launching a process (particularly on a WinXP machine with relatively simple security and I'm logged on as a Admin user, not a Limited user)?

There's nothing in the WIndows Error Logs to help identify what VBox is failing on so I'm struggling to work out what it's dependent on or what's restricting VBox.

Is there anyway to start VBox in a debug mode so that it gives more error information?

Thanks, David.
daveyb
 
Posts: 5
Joined: 18. Jan 2010, 23:00
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: SuSE, Win7, Ubuntu

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby daveyb » 19. Jan 2010, 13:24

Actually, not sure if this gives anyone a clue as to what's wrong, but I thought I'd try and start a VM from the command prompt (vboxmanage startvm) and this gives a little more information:

Code: Select all   Expand viewCollapse view
C:\Program Files\Sun\VirtualBox>vboxmanage startvm "SuSE 11.2"
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

ERROR: Could not launch a process for the machine 'SuSE 11.2' (VERR_INVALID_PARA
METER)
Details: code VBOX_E_IPRT_ERROR (0x80bb0005), component Machine, interface IMach
ine, callee IUnknown
Context: "OpenRemoteSession(a->session, uuid, sessionType, env, progress.asOutPa
ram())" at line 379 of file VBoxManageMisc.cpp

C:\Program Files\Sun\VirtualBox>


but unfortunately I don't know enough to work out from this what is stopping the OpenRemoteSession call.

Any thoughts?
daveyb
 
Posts: 5
Joined: 18. Jan 2010, 23:00
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: SuSE, Win7, Ubuntu

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby daveyb » 25. Jan 2010, 22:04

Has anyone any thoughts on how I can begin trying to solve this? The problem persists and I'm drawing a complete blank as to what the problem could possibly relate to.

Thanks, David.
daveyb
 
Posts: 5
Joined: 18. Jan 2010, 23:00
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: SuSE, Win7, Ubuntu

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby Perryg » 25. Jan 2010, 22:22

David,
Go here bugtracker and see if you can find an open ticket. If not then create a new one. You will need to setup an account there as it is on a different system.
It would also help if you can post the ticket number here so other can see the progress, add information, or see the final results.
Perryg
Site Moderator
 
Posts: 25923
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby bodo » 4. Apr 2010, 20:17

have exactly the same error with vbox 3.1.6 on gentoo x64 (built from portage). error happens if i enter:

$ VBoxManage startvm W2K3
Sun VirtualBox Command Line Management Interface Version 3.1.6
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.

ERROR: Could not launch a process for the machine 'W2K3' (VERR_FILE_NOT_FOUND)
Details: code VBOX_E_IPRT_ERROR (0x80bb0005), component Machine, interface IMachine, callee nsISupports
Context: "OpenRemoteSession(a->session, uuid, sessionType, env, progress.asOutParam())" at line 379 of file VBoxManageMisc.cpp

doesnt happen when i enter:
$ VBoxManage startvm W2K3 --type vrdp

first version used to work as well I believe under 3.1.4, looks like sbd forgot there was a default for this option.

hope this helps ppl who arrive to this thread in the future.

Rgds,B.
bodo
 
Posts: 12
Joined: 4. Apr 2010, 19:43
Primary OS: Linux other
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby whit » 17. Jul 2010, 15:07

Seeing the same thing, in not starting. This is with a Ubuntu 10.04 guest on VB 3.2.0. Only difference is the "Context" error cites line 377 of VBoxManageMisc.cpp - must just be the lines shifted between versions.

Actually it's progress I'm getting a clear error. This happens now since I collapsed the snapshots. Before then trying to start any of them didn't give an error at all, just put a small box of garbage on the top left of the screen. I was able to copy them all off to a Linux box, merge them there, and run the VM just fine after editing the XML and turning off the non-Linux device specs. So this may be a bug just in the Windows version of VB.
whit
 
Posts: 27
Joined: 20. Mar 2010, 20:39
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 10.04

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby zermattchris » 28. Nov 2010, 10:33

Exactly the same error/issue here.

Code: Select all   Expand viewCollapse view
ERROR: Could not launch a process for the machine 'DihedralsVServer' (VERR_BAD_EXE_FORMAT)
Details: code VBOX_E_IPRT_ERROR (0x80bb0005), component Machine, interface IMachine, callee IUnknown
Context: "OpenRemoteSession(a->session, uuid, sessionType, env, progress.asOutParam())" at line 377 of
file VBoxManageMisc.cpp


If I start the VirtualBox UI normally and launch the same VM with a double-click, all works fine.

Seems to be more of a VirtualBox issue than one of the VM?

-Chris
zermattchris
 
Posts: 1
Joined: 28. Nov 2010, 10:27
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubunutu 10.10

Re: Cannot start any VM VBOX_E_IPRT_ERROR

Postby mpack » 28. Nov 2010, 15:55

That is not "exactly the same error". The old one was INVALID_PARAMETER, yours is corrupt exe.
mpack
Site Moderator
 
Posts: 13162
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Mostly XP


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 42 guests