Ubuntu 9.10 64 bit won't boot on Win7 host

Discussions related to using VirtualBox on Windows hosts.

Ubuntu 9.10 64 bit won't boot on Win7 host

Postby learning » 3. Jan 2010, 06:35

I create the virtual machine just fine, point it at the Ubuntu 9.10 iso image, but when I start the install I get an error saying that the kernel requires an x86-64 cpu but sees only an x686 cpu.

I'm running Win7 75 bit and the processor is a pentium T4300 which is a 64 bit cpu.

As an aside, it also complained that my screen is 16 bit color when in fact it's 32.

Is the host not reporting things properly to virtualbox or something?

thanks.
learning
 
Posts: 2
Joined: 3. Jan 2010, 06:18
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Linux

Re: Ubuntu 9.10 64 bit won't boot on Win7 host

Postby airdronian » 3. Jan 2010, 10:06

I am getting the same result trying to do a new install of Linux Mint x64 v8.0 - this was working recently (as an installed vm) and stopped working today. I run Win 7 Enterprise x64 as host. I have had a problem with defective memory recently, which I replaced. I installed the new version of VirtualBox a few days ago. I uninstalled virtualbox and reinstalled with a copy freshly downloaded.

Since the existing vm didn't work I tried creating a new one and the reinstall complains of the wrong arch (it thinks the vm processor is 32 bit) and I am trying to install 64 bit.

For my vm I can always install 32 bit, but not certain why I am getting the arch complaint now.
airdronian
 
Posts: 2
Joined: 3. Jan 2010, 09:56
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: linux

Re: Ubuntu 9.10 64 bit won't boot on Win7 host

Postby Perryg » 3. Jan 2010, 15:53

Look at the bios of the PC and make sure that hardware-v is turned on.
If it is then you can try updating the bios.
Make sure that you do not have any other hypervisor running (XP mode) or KVM which will cause this as well.
Perryg
Site Moderator
 
Posts: 25942
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Ubuntu 9.10 64 bit won't boot on Win7 host

Postby airdronian » 3. Jan 2010, 20:58

OK, problem solved for me. As part of my troubleshooting a memory problem I had loaded failsafe defaults in the bios at one point. This disabled the virtualization support. I turned that back on and my 64 bit Linux guest is booting.

Thanks Perry.
airdronian
 
Posts: 2
Joined: 3. Jan 2010, 09:56
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: linux

Re: Ubuntu 9.10 64 bit won't boot on Win7 host

Postby learning » 3. Jan 2010, 21:57

Thanks for the response - it turns out my processor doesn't do hardware virtualization (I had assumed that it did but then I looked more carefully). Ubuntu Desktop, which doesn't require a 64 bit processor works just fine.
learning
 
Posts: 2
Joined: 3. Jan 2010, 06:18
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Linux


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Bing [Bot] and 18 guests