Page 1 of 1

Disable update check

PostPosted: 14. Dec 2009, 17:11
by JeanC
Hello,

How can I disable the annoying update notification I get every time I start VB?
I do not want to update, my system is fine running as it is.

Thanks, Jean.

VB on host xp sp3, several clients.

Re: Disable update check

PostPosted: 14. Dec 2009, 17:16
by Perryg
You change this under preferences -> update

Re: Disable update check

PostPosted: 14. Dec 2009, 17:37
by JeanC
Ah there it is, I wasn't looking in the right place.

Thanks.

Re: Disable update check

PostPosted: 30. Jun 2016, 21:06
by WFV
This resolution is way outdated - there is no longer an "update" option in Preferences (not in 5.0.20 or 5.0.22, and according to the 5.0.24 changelog doesn't appear to be there either).
Also, although running the command
Code: Select all   Expand viewCollapse view
VBoxManage setextradata global GUI/SuppressMessages "all"
does set the value in VirtualBox.xml file, VirtualBox ignores it. Does anyone know how to disable the updates notification/check in the newer versions?

Edit: strikethrough

Re: Disable update check

PostPosted: 30. Jun 2016, 21:20
by Perryg
Sure there is. Where do you get your copy of VirtualBox from?

update_as_of_06.30.2016.png
update_as_of_06.30.2016.png (36.01 KiB) Viewed 4179 times


It should also be noted that disabling all notices like this can get you into trouble. There are a few hot keys that can mess up your day if you hit them by mistake and are not warned and it will tick you off. But you will not be able to complain because you did it to yourself.

Re: Disable update check

PostPosted: 1. Jul 2016, 00:51
by WFV
Ok, I see that in your screenshot and the "update" option is definitely missing in the version I'm running - I'm running VirtualBox from Arch Linux repos (Community) rev 5.0.22. Maybe getting lost in the Arch re-packaging?
VirtualBox preferences.png
VirtualBox preferences.png (36.65 KiB) Viewed 4169 times

I understand the "all" setting potential and have used VBox since 2010 without issues (or found the fixes when i effed up) :? but good advise for sure. Thanks for the help Perryg! I'll look into patching the Arch package.

Edit: found this in the package build: https://bugs.launchpad.net/bugs/272212, there is a patch in the Arch build for removing the "update" popup but is not working, it does remove the "update" button, more reading to do...

Re: Disable update check

PostPosted: 1. Jul 2016, 01:21
by Perryg
Yup. Sounds like it is an issue of a fork for sure. Anyway my post was not entirely for you but someone else that came by and saw yours. Not a good idea to disable all warnings as it can and will cause issues. Oh and if you compile your own you have total control over what is done and the way it works. QT is the package you need for the GUI portion if you are not a hard programmer.

Re: Disable update check

PostPosted: 1. Jul 2016, 21:04
by WFV
I changed the "all" setting to "Update"
Code: Select all   Expand viewCollapse view
VBoxManage setextradata global GUI/SuppressMessages "Update"
and use the "do not show this message again" (balloon with slash thru it) on the other popups and so far seems to be working to suppress the Update popup.
Edit: the Update popups are back, setting the suppress messages to suppress Update doesn't work either.
The patch applies to 5 files: UIUpdateManager.cpp, UIActionPool.cpp, UIActionPool.h, UISettingsDialogSpecific.cpp, UISelectorWindow.cpp