VirtualBox install causes wireless adapter failures

Discussions related to using VirtualBox on Windows hosts.

VirtualBox install causes wireless adapter failures

Postby Veazer » 4. Dec 2009, 10:53

After install VirtualBox, I've had a variety of problems with my Wifi. Here are some of the symptoms:

  • No Wireless after standby. Sometimes the adapter is TOTALLY missing, not even listed in device manager. My laptop's hotkey for enabling/disabling wireless also stops functioning at this point
  • Adapter is present, but sees no networks
  • Adapter can connect to connect to a network, but cannot access internet.

In my case, rebooting seems to bring everything back but it's a hassle for me to lose standby completely.

I tried removing the host only adapter with no effect. I finally gave up and uninstalled VB completely but the problem is still there. It's a shame, i really like the app. VirtualPC doesn't work on Server2008R2, and I don't care much for VMware.

Is there any logs, etc. I can send to help get this resolved?

Machine is an Asus U20a laptop and wireless is Atheros AR9285 based (7.7.0.331 drivers-latest) running Windows Server 2008 R2 Standard.
Veazer
 
Posts: 5
Joined: 4. Dec 2009, 10:30
Primary OS: MS Windows 2008
VBox Version: PUEL
Guest OSses: WinXP

Re: VirtualBox install causes wireless adapter failures

Postby balusri » 5. Dec 2009, 13:09

I am getting this problem as well. I am using Windows 7 machine and installed virtualbox to test chrome OS. But since then my wireless connection is very unstable. Can somebody please help me out?
balusri
 
Posts: 1
Joined: 5. Dec 2009, 13:06
Primary OS: MS Windows 7
VBox Version: OSE Debian
Guest OSses: Chrome OS

Re: VirtualBox install causes wireless adapter failures

Postby Veazer » 6. Dec 2009, 13:40

It seems that this is affecting both Server 2008 R2 users and WIndows 7 users to the point of requiring an OS re-install [http://forums.virtualbox.org/viewtopic.php?f=6&t=24401&p=108649#p108649]. Can't the developers offer any input/feedback on this? If a new versions breaks an OS to this degree, it's a pretty serious bug.
Veazer
 
Posts: 5
Joined: 4. Dec 2009, 10:30
Primary OS: MS Windows 2008
VBox Version: PUEL
Guest OSses: WinXP

Re: VirtualBox install causes wireless adapter failures

Postby foouser » 6. Dec 2009, 19:06

I've had this problem too. I have uninstalled v3.1.0, rebooted, and my wireless interfaces are still missing from device manager. I have tried installing versions 3.02 - 3.1.0, rebooting after each install and uninstalling each one before reinstalling the next. My wireless interfaces are missing and my host cannot connect to the internet.
foouser
 
Posts: 4
Joined: 6. Dec 2009, 19:00
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu

Re: VirtualBox install causes wireless adapter failures

Postby balthorium » 6. Dec 2009, 19:26

Yeah I am seeing a similar problem, but all I have to do is just install VirtualBox (no other setup of guests or configuration) and my wifi adapter becomes unusable.

System: Lenovo T60p notebook, dual booted for WinXP SP2 and Ubuntu 9.10
Host OS for VirtualBox: WinXP SP2
VirtualBox version: 3.1.0.55467-win
Wifi adapter: Intel PRO/Wireless 3945ABG

So basically on installing VirtualBox to my WinXP SP2 host OS, the wireless card no longer sees any networks. Tried rebooting (twice actually) but that didn't help. Uninstalled VirtualBox and rebooted, and the wifi adapter became usable again. Note that the wired connection adapter (an Intel PRO/1000 PL) never had a problem, it was just the wifi adapter.

Any suggestions for what might be going on here? I'd love to get this to work...
balthorium
 
Posts: 2
Joined: 6. Dec 2009, 19:05
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: none

Re: VirtualBox install causes wireless adapter failures

Postby Templar » 6. Dec 2009, 20:30

Try uninstalling the Virtualbox Bridged Network Service from the Network Adapter properties and see if that helps. Note that you'll only be able to use NAT mode but if that fixes your WI-FI problems it's worth it.

Simon
Here lies one whose name was writ in water "Keats"
- HP 8530w - 4GB - 320 GB HD - Quadro FX770m - Win7 x64 -
Templar
 
Posts: 7
Joined: 3. Dec 2009, 00:38
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows XP

Re: VirtualBox install causes wireless adapter failures

Postby balthorium » 6. Dec 2009, 20:43

Thanks Simon, very much appreciate the suggestion. After I posted this, I started looking more closely at what my third-party network connection manager (Cisco Secure Services Client 5.1.0.39) was doing, and found that actually it was seeing my wifi network, but was for some reason no longer connecting to it automatically when VirtualBox was installed. The work-around seems to be that I just need to manually select and connect to the wifi network now anytime I need to use it. I can live with that if it means everything else works okay :).
balthorium
 
Posts: 2
Joined: 6. Dec 2009, 19:05
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: none

Re: VirtualBox install causes wireless adapter failures

Postby foouser » 7. Dec 2009, 02:16

Actually the bridged device has never installed for me. In all my installs I have only ever seen the host - only adapter despite having selected the default for 3.1.0 which is to install the bridged device.
foouser
 
Posts: 4
Joined: 6. Dec 2009, 19:00
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu

Re: VirtualBox install causes wireless adapter failures

Postby foouser » 7. Dec 2009, 02:47

I uninstalled Virtualbox. Then I went into Device Manager and uninstalled my Intel Pro/1000 PL and Intel Pro/Wireless 3495ABG devices. Then I rebooted. Plug and Play reinstalled them and everything came back. I can connect and I can see my network interfaces in Device Manager again.
foouser
 
Posts: 4
Joined: 6. Dec 2009, 19:00
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu

Re: VirtualBox install causes wireless adapter failures

Postby foouser » 7. Dec 2009, 03:08

Next, I installed VirtualBox 3.1.0 again because I am stubborn. It installed without any errors although I was wondering if it was going to hang at the end because there was no movement of the progress bar for about 5 minutes.

However, when I check my Network Connections in the Control Panel I saw an oddly named network device with a yellow exclamation point instead of the desired Host-Only interface. I looked in Device Manager and I did see a Host-Only device there which had no red x and no yellow exclamation point.

I rebooted.

Every thing came up happy. I could still connect to the internet with my wifi device on the host. Network Connections had a Host-Only interface with no yellow exclamation point. Device Manager looked good. I had to click Settings on my virtual machine to select the correct ethernet device to use. For some reason it was empty. Then I started up VirtualBox and everything worked and I could use the network from my guest machine.


My gut instinct is that this whole problem is somehow related to the fact I have a 3rd party network manager.
I have seen people mention them in a lot of forum posts that are similar to my issue. In my case I have a Lenovo ThinkPad T60 which has some kind of crazy connection manager that I have to use to connect to the internet instead of the standard windows tools. I think its generally better and more advanced than the standard windows xp connection programs. However it doesn't always play nice with VirtualBox. I have had some other problems in the past when upgrading VirtualBox. Note to self: upgrade less often.
foouser
 
Posts: 4
Joined: 6. Dec 2009, 19:00
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Ubuntu

Re: VirtualBox install causes wireless adapter failures

Postby misha » 7. Dec 2009, 11:58

To all having issues with wireless networking after VBox is installed, some questions to clarify the situation:
What was the last (if any) VBox version that worked OK for you on that system?
Could you specify the list of any custom networking-related software installed on your system (e.g. VPN clients, Antivirus, Firewalls, Other virtualizers like VMWare or Virtual PC, etc.) ?
misha
Oracle Corporation
 
Posts: 285
Joined: 19. Dec 2008, 11:10

Re: VirtualBox install causes wireless adapter failures

Postby Veazer » 7. Dec 2009, 17:36

misha wrote:To all having issues with wireless networking after VBox is installed, some questions to clarify the situation:
What was the last (if any) VBox version that worked OK for you on that system?
This is my first experience with VirtualBox other than USBuntu Live creator which adds a portable VirtualBox install

misha wrote:Could you specify the list of any custom networking-related software installed on your system (e.g. VPN clients, Antivirus, Firewalls, Other virtualizers like VMWare or Virtual PC, etc.) ?
None really, this is a barebones Server 2008 R2 install from Dreamspark. I needed to be sure that at least some form of VM software would work on this OS. Virtual PC 2007 SP1 64bit installs and runs but the network components fail so it was removed. I don't have any firewalls or AV software installed yet, I'm running as a limited user and being quite careful at this point.
Veazer
 
Posts: 5
Joined: 4. Dec 2009, 10:30
Primary OS: MS Windows 2008
VBox Version: PUEL
Guest OSses: WinXP


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 17 guests