USB device is busy with a previous request

Discussions related to using VirtualBox on Windows hosts.

USB device is busy with a previous request

Postby Kakao » 29. Jul 2009, 20:37

Fedora 11 guest in a Windows XP host. VB 3.0.2.

I was using a pen drive normally. After a crash all I get is:

Code: Select all   Expand viewCollapse view
Failed to attach the USB device to the virtual machine Fedora 11. USB device is busy with a previous request


It looks like a lock was left somewhere but I can't find it. Reinstalled guest additions and read many pages on the web.

Any ideas?
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: USB device is busy with a previous request

Postby Perryg » 29. Jul 2009, 21:03

Do a complete power down (cold boot) and see if it returns.
Perryg
Site Moderator
 
Posts: 25913
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: USB device is busy with a previous request

Postby Kakao » 29. Jul 2009, 21:10

Done that and also danced all the sacred dances.
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: USB device is busy with a previous request

Postby Perryg » 29. Jul 2009, 21:23

After you have Windows booted you can try to unplug the USB drive and plug it back in or unplug it with the guest OS powered off and then plug it back in when it is on so the guest gets focus again. (be sure to cross fingers and turn around twice this time, it works for me Sacred dances are so old school).
Perryg
Site Moderator
 
Posts: 25913
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: USB device is busy with a previous request

Postby Kakao » 29. Jul 2009, 21:43

Still no success. Details:
Code: Select all   Expand viewCollapse view
Result Code:
E_INVALIDARG (0x80070057)
Component:
HostUSBDevice
Interface:
IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee:
IConsole {0a51994b-cbc6-4686-94eb-d4e4023280e2}
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: USB device is busy with a previous request

Postby Perryg » 29. Jul 2009, 21:51

Ok let's go at this a little differently.
First is this USB device active in the HOST?
Secondly remove any defined USB filters in the guest once you are sure that the device works in the Host.
Then start the guest and click on the device tab then select the USB device in USB and see if it energizes.
Perryg
Site Moderator
 
Posts: 25913
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: USB device is busy with a previous request

Postby Kakao » 29. Jul 2009, 22:03

Perryg wrote:Ok let's go at this a little differently.
First is this USB device active in the HOST?

Yes. Shoudn't id be? I think I tried it inactive.
Perryg wrote:Secondly remove any defined USB filters in the guest once you are sure that the device works in the Host.
Then start the guest and click on the device tab then select the USB device in USB and see if it energizes.

It works in the host. It didn't energize. Same message.
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: USB device is busy with a previous request

Postby Perryg » 29. Jul 2009, 22:14

I assume you are shutting down the guest and not saving the state, would I be correct?
So what if you completely turn off the USB for the guest and then boot into the Windows. Let it settle down and then shut down Windows.
Then enable the USB again, start Windows and see if it returns.
Perryg
Site Moderator
 
Posts: 25913
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: USB device is busy with a previous request

Postby Kakao » 29. Jul 2009, 22:26

Perryg wrote:I assume you are shutting down the guest and not saving the state, would I be correct?

Yes shutting down.

Perryg wrote:So what if you completely turn off the USB for the guest and then boot into the Windows.

You mean deleting the filter from the vbox host interface? It is already deleted. Tried with and without filter. And then shutting the guest down? I think I don't understand.
[/quote]
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: USB device is busy with a previous request

Postby Perryg » 29. Jul 2009, 22:31

Actually I meant to take the check mark out of the enable usb in the guest settings.
Somehow as you say there must be something hung that is keeping this from working again.
Frankly this is the first time I have ever seen this happen and just throwing things out there for you to try.
Also you can look in the machine folder and the name of the guest and see if the *.XML has any setting that looks out of place.
Perryg
Site Moderator
 
Posts: 25913
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: USB device is busy with a previous request

Postby Kakao » 30. Jul 2009, 14:17

Unchecked it and restarted the host. No success. I found this thread in the Mac OS X hosts forum:

viewtopic.php?f=8&t=10276

Followed those advices and still no luck. I will fill a bug. Thanks for your patience.
Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: USB device is busy with a previous request

Postby Kakao » 30. Jul 2009, 14:58

Kakao
 
Posts: 21
Joined: 29. Jul 2009, 20:29
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 11.10, 12.04 and Centos 6

Re: USB device is busy with a previous request

Postby abhay » 9. Sep 2009, 19:18

I was facing this problem since very long now but I solved it today so wanted to share the solution here.
What I did was to just disable USB 2.0 (EHCI) support in BIOS and then everything works...NO PROBLEMS at all!!!
I don't know why Virtualbox can't handle USB 2.0 but at least my scanner works now :D
abhay
 
Posts: 1
Joined: 9. Sep 2009, 19:14
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: Windows XP SP3

Re: USB device is busy with a previous request

Postby Mr Incredible » 26. Sep 2009, 12:38

abhay wrote:I was facing this problem since very long now but I solved it today so wanted to share the solution here.
What I did was to just disable USB 2.0 (EHCI) support in BIOS and then everything works...NO PROBLEMS at all!!!
I don't know why Virtualbox can't handle USB 2.0 but at least my scanner works now :D


That worked for me too. What Host are you running? Mine is Windows 7 64 Bit Ultimate RTM 7100
Mr Incredible
 
Posts: 14
Joined: 21. Sep 2009, 22:10
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows Home Server

Re: USB device is busy with a previous request

Postby shinji » 29. Sep 2009, 05:23

I'm curious but do you get the same resolve if you leave USB 2.0 enabled in the bios but disable it in the VM settings?
shinji
 
Posts: 36
Joined: 30. Sep 2007, 19:20
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows 7 Starter

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 43 guests