Vista x64 host, E_NOINTERFACE error (0x80004002)

Discussions related to using VirtualBox on Windows hosts.

Vista x64 host, E_NOINTERFACE error (0x80004002)

Postby Atcom » 6. May 2009, 14:50

I installed Virtual Box 2.2.2 on Vista x64, with administrator privileges. After installation process, when i start the application the following error dialog appears: Failed to create the VirtualBox COM object. Callee RC: E_NOINTERFACE (0x80004002).
I tried manually start VBoxSVC.exe, reregister it and reinstall the VirtualBox with disabled NOD32 4.0, but not solved the problem.

Does anyone have any suggestions for this?
Atcom
 
Posts: 2
Joined: 6. May 2009, 14:34
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Vista x64 host, E_NOINTERFACE error (0x80004002)

Postby Perryg » 6. May 2009, 15:51

Reinstall and select repair. If it tells you that you need to reboot for these changes to take effect, reboot. If it does not tell you to reboot, reboot anyway.
Perryg
Site Moderator
 
Posts: 25959
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Vista x64 host, E_NOINTERFACE error (0x80004002)

Postby Atcom » 6. May 2009, 18:36

Perryg wrote:Reinstall and select repair. If it tells you that you need to reboot for these changes to take effect, reboot. If it does not tell you to reboot, reboot anyway.


Thanks for the answer! I tried this, but not solved the problem.
Atcom
 
Posts: 2
Joined: 6. May 2009, 14:34
Primary OS: Mac OS X Leopard
VBox Version: PUEL
Guest OSses: Linux, Windows

Re: Vista x64 host, E_NOINTERFACE error (0x80004002)

Postby jsthill » 7. Oct 2009, 18:08

Hi,

I downloaded Virtualbox 3.0.8 and tried running it on my Windows Vista Business OS. Each time I try to launch the application I get the following error message.

Failed to create the VirtualBox COM object.
The application will now terminate.

Callee RC: E_NOINTERFACE (0x80004002)

I uninstalled and rebooted twice to no avail. I also installed it by right clicking on the installed file and left click on "Run as administrator". What else can I try? Thanks in advance for your assistance.

Julian
jsthill
 
Posts: 1
Joined: 7. Oct 2009, 16:05
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Windows Vista

Re: Vista x64 host, E_NOINTERFACE error (0x80004002)

Postby Perryg » 7. Oct 2009, 23:45

@jsthill
First thing to do is to uninstall if it is still installed.
Then reboot.
Then right Click on the install and left click on run as admin. Watch for the drivers to load and you must accept them all.
Reboot again. Then see if it will start.
If this fails I need to know if this is the first install or an upgrade. Please list the last known version that worked if this is an upgrade.
Perryg
Site Moderator
 
Posts: 25959
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: Vista x64 host, E_NOINTERFACE error (0x80004002)

Postby pwarner » 22. Oct 2009, 20:02

I am also using Vista Business OS, and havign the same issue. Have tried the remove restart install restart and still nothing same error. This was originally a fresh install.

In addition it is a 32bit OS as well
pwarner
 
Posts: 1
Joined: 22. Oct 2009, 19:58
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Windows

Re: Vista x64 host, E_NOINTERFACE error (0x80004002)

Postby Perryg » 22. Oct 2009, 20:28

@pwarner,
What version did you have before you tried to upgrade?
Perryg
Site Moderator
 
Posts: 25959
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot], mpack, Supuhstar and 47 guests