Vista host networking problem V2.2.2

Discussions related to using VirtualBox on Windows hosts.

Vista host networking problem V2.2.2

Postby vb@cmicroci.plus.com » 30. Apr 2009, 14:12

I have just tried to upgrade my Virtual box machine to the latest version 2.2.2.

The upgrade appeared to proceed OK and I can start the old virtual machines. But my host networking appears unable
to route packets beyond the local network after rebooting.

1) uninstal the software and reboot and the host network is working.
2) install virtualbox and the host networking still works.
3) reboot and the host network is in local network only mode. (non local ping -> 'general failure')
4) uninstalling and the host network is again functional.

Virtual box installs the host only network ok. The filter driver appears to be installed and added to the nic.The host networking is able to get it's address from the local DHCP server ipfconfig release/renew (so has access to the local network) but any attempt to ping beyond the local network results in a 'general failure'. pings to local network addresses work. Windows Network sharing center indicates that the link beyond the network is unavailable.

Default gateway (ipconfig/route print) and routing (route print) appears to remain correctly configured in the disfunctional state.

Uninstalling virtual box returns to functional network.

Is there something I am missing in the install?
vb@cmicroci.plus.com
 
Posts: 4
Joined: 30. Apr 2009, 13:48
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: debian ubuntu suse windows

Re: Vista host networking problem V2.2.2

Postby vbox4me2 » 30. Apr 2009, 15:08

Re-install, select repair option.
vbox4me2
Volunteer
 
Posts: 5218
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: Vista host networking problem V2.2.2

Postby vb@cmicroci.plus.com » 30. Apr 2009, 15:38

Thanks for suggestion,

I tried the reinstall repair.

Full connectivity reappeared temporarily at the end of the repair.

The repair demanded a reboot.

The problem re-occured after the boot.

I have uninstalled again and networking is back to normal.

Ian
vb@cmicroci.plus.com
 
Posts: 4
Joined: 30. Apr 2009, 13:48
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: debian ubuntu suse windows

Re: Vista host networking problem V2.2.2

Postby vb@cmicroci.plus.com » 30. Apr 2009, 16:52

Sorry guys this is the same problem raised previously.

The VirtualBox Host-Only Network know to vista as "unidentified network" is deemed to be "Public".

I am using Windows firewall which now switches to the "Public Profile" and shuts down my network access.

Ian
vb@cmicroci.plus.com
 
Posts: 4
Joined: 30. Apr 2009, 13:48
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: debian ubuntu suse windows

Re: Vista host networking problem V2.2.2

Postby vb@cmicroci.plus.com » 30. Apr 2009, 17:44

The fix appears to be to find the registry entry for the "VirtualBox Host-Only Ethernet adapter"

in my case the entry 0007 below: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}

and add the DWORD key *NdisDeviceType with a value 1.

Then Disable and reenable the Network connection which apparently prevents this local only adaptor being seen as a connection to a remote network.

for more details and all of the usual caveats about editing your registry, see the thread in this forum entitled "Small issues with host-only networking in Vista" and the vmware oriented description refered to there: http://aspoc.net/archives/2008/10/30/unidentified-network-issue-with-vmwares-virtual-nics-in-vista/
vb@cmicroci.plus.com
 
Posts: 4
Joined: 30. Apr 2009, 13:48
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: debian ubuntu suse windows

Re: Vista host networking problem V2.2.2

Postby mawcs » 2. May 2009, 22:44

I'm having the same difficulty. Additionally, there are some applications that think my IP address is something other than it should be. By disabling the Virtualbox Host-only Network, everything returns to normal.

The Registry fix mentioned above did not fix my issue.
mawcs
 
Posts: 1
Joined: 2. May 2009, 22:41
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Kubuntu, Linux Mint, Gos, Fedora, ubuntu

Re: Vista host networking problem V2.2.2

Postby VinyJones » 8. Nov 2010, 06:52

I had the same difficulty and The Registry fix mentioned above did not fix my issue.

But this simple one fix ( http://systemmangler.com/post/474592471 ... rk-the-fix ) work fine for me.

The fact seme to be "untill the ip configuration gateway target answer, network is not identified".

Sorry for my english and i hope it will help some.

See You
VinyJones
 
Posts: 1
Joined: 8. Nov 2010, 06:44
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: gentoo, win7, usb boot test

Re: Vista host networking problem V2.2.2

Postby Numbergod » 18. Mar 2018, 12:09

The problem appears to still be occurring.

I've managed to fix it following the SystemMangler post, which is long dead, but is available at archive org.
Unfortunately I'm not allowed to post URLs. Grrrr.


Thanks to all. This was driving me nuts. :-)

D.
Numbergod
 
Posts: 1
Joined: 18. Mar 2018, 12:05


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 272 guests