[2.2] VirtualBox Host-Only Network adapter not created

Discussions related to using VirtualBox on Windows hosts.

[2.2] VirtualBox Host-Only Network adapter not created

Postby seagal82 » 22. Apr 2009, 07:09

after virtualbox 2.2 installed ,
there should be a Network card named "VirtualBox Host-Only Network adapter " created in [Network Connections]

but i stupidly manually uninstalled this "VirtualBox Host-Only Network adapter " when i first time installed virtualbox 2.2 ...
( coz it seemed not functioning properly , kept showing cant get the correct IP ....)

However , now i realized how may i use it, and i really do need it !!! > <

i've tried to uninstall virtualbox 2.2 and reinstall it, but the "VirtualBox Host-Only Network adapter " just wont show up in [Network Connections] ... :(
and i tried using option in virtualbox : "File->preference->Network:Host-Only Networks" to "Add Host-only Network" , it just wouldnt work ...
kept showing "Failed to create the host-only network interface"

is there anyone has some experience in this? or knowing how to solve this problem ? > <
plz help ~ :(
seagal82
 
Posts: 3
Joined: 22. Apr 2009, 06:48
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: ubuntu

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby vbox4me2 » 22. Apr 2009, 11:50

When reinstalling VBox select the repair option.
vbox4me2
Volunteer
 
Posts: 5222
Joined: 21. Nov 2008, 20:27
Location: Rotterdam

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby seagal82 » 22. Apr 2009, 15:50

yeah , i have done that as well, but still ... malfunctioning ....Q_Q
seagal82
 
Posts: 3
Joined: 22. Apr 2009, 06:48
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: ubuntu

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby Cougar_II » 22. Apr 2009, 18:06

Hi,

The issue I had with v2.2.0 (Windows XP PRO SP3) was after a reboot, XP detected new hardware called "Net"

and regardless when I pointed, it just could not find the proper drivers for that Network Adapter.

So I still have a Unknown Device in my network adapters.

I have since rolled back to v2.1.4 waiting to v2.2.1 or v2.2.2 to be released, let's see if then it will properly delect that NIC and let me install or remove this Unknown Device.
Cougar_II
 
Posts: 4
Joined: 21. Apr 2009, 19:29
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: Windows 7 ßeta

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby Perryg » 22. Apr 2009, 18:19

Windows Host is finicky You need to uninstall VBox 2.2 and then reboot. After that you need to install VBox 2.2 as administrator (right click on the install file and left click on run as, then select admin). And yes reboot again. After that you should have your files you need. For best results you should also install the guest additions in your guest.
Perryg
Site Moderator
 
Posts: 25920
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby coulr » 24. Apr 2009, 00:19

I'm having the same problem as Seagal82. On Win XP SP3 I can't get Host-Only Network to work. After installing, repairing, de-installing and re-installing several times I had two unknown network devices with errors left in Device Manager even after VirtualBox uninstall. VirtualBox clearly needs some better cleanup code on uninstall! After a lot of searching I found a way to remove those remnant "ghost" devices (below). But now I can't install the VirtualBox Network adapter at all! If I reboot and try to do a clean VirtualBox then all is well until the second of the two "unverified" messages that Windows throws during the installation. The says that the installation will be aborted and then does so. Any suggestions on how to solve that problem? (If I in the install options uncheck the network adapter then the install works. But if I then within VirtualBox try to add a host-only network adapter I get an error message.)

Anyway, here's how I removed the "ghost" network devices VirtualBox left after uninstall:
- just right clicking and deleting them in device manager did not work; Windows complained that they were needed for the system or something like that
- device manager > select the "ghost" device > properties > details > device ID.
In my case it was:
device-ID = ROOT\NET\0001

Win > Run > regedit :
- goto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\NET\0001 (vary the details based on your specific device ID in the previous step)
- right click, the 0001 key , permissions... , allow
- the delete the 0001
- refresh the devices in device manager; the "ghost" device should now be gone
- repeat if you had more than one such ghost device


keywords so that folks googling will find this solution faster and not spend two hours looking for it like I had to:
network device host-only network virtualbox remove ghost remnant can't remove deinstall delete uninstall nic unknown net
coulr
 
Posts: 19
Joined: 24. Apr 2009, 00:07
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: ubuntu

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby Sasquatch » 24. Apr 2009, 01:18

Why don't you just open the VB Global Preferences, go to Network, and add the adapter there?
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby coulr » 24. Apr 2009, 01:29

I have tried repeatedly but only get "Failed to create the host-only network interface":
Image

edit: I see that there's a much longer thread with other 2.2 network issues. The problem's I'm encountering seem similar to some of the ones described there.
coulr
 
Posts: 19
Joined: 24. Apr 2009, 00:07
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: ubuntu

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby seagal82 » 24. Apr 2009, 11:06

yeah ~ ! that just seem to be the same problem i have ( coulr's picture above )

little happy to see Finally someone has the same problem ... ~_~"
very sad to see there is still no effective solutions T_________T

sigh ~
seagal82
 
Posts: 3
Joined: 22. Apr 2009, 06:48
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: ubuntu

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby coulr » 29. Apr 2009, 17:07

The installation problems are gone for me in v2.2.2
coulr
 
Posts: 19
Joined: 24. Apr 2009, 00:07
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: ubuntu

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby Hardecode » 2. May 2009, 10:39

Hello,

I got the same problem yesterday, after that I switched from v.2.1.4 to 2.2.2, and then returned to 2.1.4, because I noticed that 2.2.2 was not running so smoothly on my PC station.

From that moment, I´m not able to solve this issue. Tried uninstalling, than restart, reinstalling, restart, repairing and so on. Without success. Virtualbox just add "Unknown Device" to my network adapters. Tried also installing manually drivers for that device, without success.

I can post my vbox.log also here, if anyone is able to identify problem from it.

thanks in advance
Hardecode
 
Posts: 1
Joined: 2. May 2009, 03:00
Primary OS: MS Windows Vista
VBox Version: OSE other
Guest OSses: Windows XP, Windows Server, FreeBSD

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby alexzeit » 6. May 2009, 07:25

Dear All,
I have the same problem with VBox OSE. Is Host-Only Network adapter missing in OSE binary?
alexzeit
 
Posts: 12
Joined: 3. Apr 2009, 14:39
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Linux

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby hugues » 3. Jul 2009, 11:59

Same problem for me...
Yesterday I have unistalled the version 2.2.4 and installed the version 3.0 (without rebooting..... I know....)
After rebooting, I have the same pb (unknow device in section Network adapter, device called "NET" detected at windows startup)
When I tried to remove this device, I obtain a message like "can not remove this device, this device is required by windows startup".

Anyone have clean solution ?
hugues
 
Posts: 1
Joined: 3. Jul 2009, 11:54
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: XP, Ubuntu

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby Perryg » 3. Jul 2009, 14:56

First you should try to reinstall by right clicking the install icon and then left click on run as admin. select repair when offered and then reboot.

To remove the NET device you will need to boot into safe mode without network and remove it then.

Remember even if it does not ask, Windows always needs a reboot when changing things like this or weird things can happen.
Perryg
Site Moderator
 
Posts: 25920
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: [2.2] VirtualBox Host-Only Network adapter not created

Postby nezlo » 2. Dec 2009, 18:52

Dang, I am having this same problem.

When I initially installed VB, four versions back, the virtualbox host only adapter did show.... But I wanted to bridge it with a NIC... So I did... But what I was attempting did not work, so I disabled the bridge connection, but I never got my virtualbox host only adapter...

I've tried uninstalling and reinstalling (several times), but no fix :(

So no solution for this?
nezlo
 
Posts: 4
Joined: 9. Oct 2009, 21:22
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Windows XP

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Bing [Bot], Pat-virtualb and 39 guests