Virtual Box 1.2.4 Vlan issues (Errors)

Discussions related to using VirtualBox on Windows hosts.

Virtual Box 1.2.4 Vlan issues (Errors)

Postby jascanio » 9. Mar 2009, 12:23

Dears sirs:

I've been trying to work with virtualbox 2.1.4 on a Windows Xp Professional, and I've found the following issues.

1.- When you have a network card that support Vlan, and you create, some vlan interfaces (in my case, an Intel 82566DM-2 Gigabit Network), VirtualBox Host Interface Networking driver is attached to the new Vlan interfaces you've created, but is not disabled from the main network interface from which vlan interfaces derives.

As a result, Virtual Machines network interfaces associated to host Vlan Interfaces are not able to receive any network packet, so machines we will not be able to negotiate DHCP IP, or get any packet from the associated vlan.

Disabling Virtualbox Host Interface Networking Driver solutions this behaviour.

2.- VirtualBox must be using the Friendly Name attribute from the registry network interface definition, to distinguish between network interfaces of the system when you associate Vbox Interface to host interface.

When you create a Vlan Interface, the name (attribute Friendly Name) of the interface is greater than the original interface name, cause the system appends some expressiones in order to differentiate them.

The size of this resulting name, is greater than max size Virtual box assumes (compares), and as a result of this, Virtual box can associate Vbox network card 01 to host Interface 01 and Virtual box network card 02 to host interface 02, but when you are going to start the machine, it respond with an Incompatible type network interface error, due to the fact that the 2 names it's comparing are equal.

In my Case:

Original interface name:

Intel 82566DM-2 Gigabit Network Connection

Vlan Interface names:

Intel 82566DM-2 Gigabit Network Connection - Vlan : Main
Intel 82566DM-2 Gigabit Network Connection - Vlan : Wifi

The comparison finished at the word Vlan.

My Solution until this trouble will be solved by virtualbox (if it's really a virtual box error): changed Friendly Name of the main network
interface in the registry
. I'ts neccesary give permssions to local administrator over the corresponding registry subtree to acomplish this.

Final result:

Original interface name:

Intel 82566DM-2 Gigabit Network

Vlan Interface names:

Intel 82566DM-2 Gigabit Network - Vlan : Main
Intel 82566DM-2 Gigabit Network - Vlan : Wifi

Virtual machine now starts OK, and has two interfaces, each of one associated to the corresponding phisical Vlan interface:

eth0 Link encap:Ethernet HWaddr 08:00:27:8a:cf:1d
inet addr:10.141.187.154 Bcast:10.141.187.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14773 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1128140 (1.0 MiB) TX bytes:7125 (6.9 KiB)

eth1 Link encap:Ethernet HWaddr 08:00:27:b5:04:57
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

I hope this can help.
Bye.
jascanio
 
Posts: 1
Joined: 9. Mar 2009, 11:20

Re: Virtual Box 1.2.4 Vlan issues (Errors)

Postby Sasquatch » 9. Mar 2009, 15:26

If you're posting a bug, please do that in the Bugtracker.
For a suggestion, we have a Suggestions subforum.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Virtual Box 1.2.4 Vlan issues (Errors)

Postby avok00 » 13. Sep 2009, 23:42

Thanks man! You saved me a lot of trouble!
avok00
 
Posts: 29
Joined: 29. Apr 2009, 14:58
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Windows XP


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot], mpack and 16 guests