Page 1 of 1

Boot vm stored on external hard drive ExFAT (doesn't work)

PostPosted: 2. Dec 2021, 02:26
by terrestica
So heres a quick summary of my situation and Problem.

I have two hosts one is running MacOS and one Windows. I want my guests to be stored on an ExFAT formatted SSD that is then attached to the machienes via USB, so that I can use the VMs on boths hosts. I use ExFAT because NTFS is not supported by Mac OS.

What works:
I have created a virtual Alpine Linux guest (vbox and vdi) with the windows host on a different USB drive that is FAT fromatted.
First booting on the Mac host failed but after creating a new virtual machine (vbox) and attaching the Virtual harddisk located on the usb drive (VDI) it booted perfectly fine.
TLDR: create with windows on FAT, boot with mac

What does not work
I then created windows server2019, win10 and opensuse Linux guests (vbox and vdi) on the ExFAT formatted SSD using the Mac host.
From now on I will focus on the opensuse guest since all guests have the same Problem but I know it kind of worked the other way around using a linux guest in the past (See: What works).
First booting on the windows host failed again (something like disk not found), but this time cerating a new virtual machine (vbox) did not fix the issue entirely. Even though the machine started to boot it took forever to initiate ramdisk (multiple times of what was needed using the mac host), eventually i got a boot screen (logo of distro and so on) but after some time the loading indicator stopped spinning and while my keaboard was captured the shift lock indicator as well as the led beside it blinked simultaneously (I guess linux kernel panic). Btw same thing for windows server: it freezes during bootup.
Booting the vbox file created with windows on mac strangely works.

TLDR: create with mac on ExFAT, boot with windows

By specs the windows computer should be faster.
Sorry for my typos and my bad english.

Does anybody have any experience running virtual machines of of an ExFAT formatted external USB drive on an Windows host?

Any ideas would be appreciated!

Edit: fixed typo, added: "Booting the vbox file created with windows on mac strangely works."

Re: Boot vm stored on external hard drive ExFAT (doesn't work)

PostPosted: 2. Dec 2021, 04:56
by scottgus1
As far as I understand, the partition format of the host disk doesn't matter, as long as the host OS can read and write the partition correctly.

So if your Windows host and your Mac host can both read and write to the exFAT partition without error, then Virtualbox won't have a problem running from the exFAT partition either.

Here is a test. Have each host OS copy a large file, like a several-hundred-megabyte video, from an internal drive to the exFAT partition, then FC file-compare the source and copy. If no errors are found, then writes to the exFAT are not a problem.

The Windows and Mac hosts each have their own nuances running Virtualbox VMs. If the above file compare test is successful, it could be these nuances are the foundation behind the problem, not the exFAT.

Also, use of USB 2 could masquerade as problems or cause timeouts because of slow data. USB 3 is pretty essential.

Let's deal with the Windows host here. Please make a VM on the exFAT partition, and provide a VM log: Start the VM from full normal shutdown, not save-state. Run until you see the problem happen, then shut down the VM from within the VM's OS if possible. If not possible, close the Virtualbox window for the VM with the Power Off option set.

Right-click the VM in the main Virtualbox window's VM list, choose Show Log. Save the far left tab's log and the hardening log next to it, zip them, and post the zip file, using the forum's Upload Attachment tab.

(BTW, a Mac guest is only allowed by Apple if the physical computer is an Apple computer OSX guests on non-Apple hardware
So if your Windows host is not a Mac running Windows, then we won't be able to help with the Mac guest when the Windows host is running it.)

Re: Boot vm stored on external hard drive ExFAT (doesn't work)

PostPosted: 5. Dec 2021, 21:33
by terrestica
Thank you very much for the suggestions. Before I was going to test out your suggestions I ran some more tests on my own and it turns out the Problem was a faulty USB cable or to be more precise two of them.
The external SSD housing came with two UBS cables (one type C to type C and one type C to type A) and both of them were faulty and caused the problems.
I am so sorry to have bothered you with these stupid questions. I just didn't expect both of them beeing faulty even after I discovered that the type C to type C one was broken.
Now that I am using a USB cable that properly supports USB (Apples TB3 cable) my SSD is happily running at 10 Gbits using USB 3.1 Gen2 and VirtualBox works flawlessly. I don't know why the broken cables worked on MacOS but tbh. I don't care either.

Re: Boot vm stored on external hard drive ExFAT (doesn't work)

PostPosted: 6. Dec 2021, 00:14
by scottgus1
Not a stupid question at all! It was an interesting problem, and I'm glad it turned out so easy a solution. Glad you're up and running!