Page 2 of 2

Re: Connection issue

PostPosted: 27. Jul 2021, 10:40
by HuaMin
Host machine is working fine with assign public IP 2?.?.?. This is the way both host and guest VM have been working there for long time. For instance, host machine is with IP 2?.?.?, then other guest VM is with IP like 2?.?.2, 2?.?.3, etc.

Only issue is that, after the change yesterday, guest VM is not able to get assigned public IP 2?.?.?, regarding bridged adapter.

Re: Connection issue

PostPosted: 27. Jul 2021, 10:50
by mpack
As I said, the basic facts are as already explained: the VM has no access to DHCP. Only you have the equipment nearby, so only you can find out why.

Re: Connection issue

PostPosted: 27. Jul 2021, 14:42
by scottgus1
HuaMin, are you sure the "cable" to the VM is still connected? See the VM's Network settings, Bridged adapter, Advanced dropdown, Cable Connected should be checked.

Re: Connection issue

PostPosted: 28. Jul 2021, 04:02
by HuaMin
Scott,
It is with options below (I never changed it)

2a.png
2a.png (12.56 KiB) Viewed 884 times


It is perfect/fine to work with NAT option but using Bridged adapter, it is not able to be assigned with IP like "223.???", while before the modem change, it is working fine with Bridged adapter, using such real IP 223?????.

Re: Connection issue

PostPosted: 28. Jul 2021, 16:57
by scottgus1
Good, the "cable" is connected.

Your problem is not in Virtualbox and cannot be fixed with Virtualbox.

Despite what your vendor is saying, the new hardware is missing a setting that the old hardware was using.

There have been many ideas posted above about why your VM cannot get an IP address. You should go back and try to understand them. A short summary:

  • Check that the new hardware's DHCP server is running correctly according the old settings.
  • Check if your ISP was giving you multiple public IP addresses and the new hardware has to give one of those public IP addresses to your VM.
  • get a router between your new hardware and your host PC, so the PC no longer gets a public IP address but a private one, and the VM will also be able to get a private IP address.

You cannot solve this by changing Virtualbox settings. You can only solve it by configuring your new hardware properly.