Page 1 of 2

kernel requires an x86_64 cpu, but only detected an i686 cpu

PostPosted: 9. Oct 2008, 00:17
by zionahead
I'm getting this error on my vista 64bit host using ubuntu 8.10 beta desktop amd64 iso as guest.

kernel requires an x86_64 cpu, but only detected an i686 cpu
unable to boot - please use a kernel appropriate for your cpu

PostPosted: 9. Oct 2008, 00:32
by Sasquatch
Please see the Manual chapter 1.6 or VirtualBox FAQ. You need virtualisation and a few other options. Without that, you can't run 64 bit Guests.

PostPosted: 9. Oct 2008, 00:49
by zionahead
I enabled vt-x/amd-v and started up, same error.

I'm running vista 64bit ultimate sp1 with ubuntu 64bit 8.10 beta amd64 iso mounted.

I have a core 2 duo processor laptop as well

PostPosted: 9. Oct 2008, 14:38
by Dest
Not all laptops have virtualization support, you'll have to do some research to find out if yours does.

However if it does, there usually is a setting in BIOS that needs to be turned on. On my D830 it was in the "Posting" section of Bios and was listed as "Virtualization Extension"

PostPosted: 9. Oct 2008, 22:25
by Sasquatch
Dest wrote:Not all laptops have virtualization support, you'll have to do some research to find out if yours does.

However if it does, there usually is a setting in BIOS that needs to be turned on. On my D830 it was in the "Posting" section of Bios and was listed as "Virtualization Extension"

For laptops, this is indeed a tricky thing, but it's for workstations too. My laptop has a VT-x enable CPU, but my mainboard does not support nor provide a Virtualisation function. It might support it, but there isn't in the BIOS. Keep that in mind too.

PostPosted: 10. Oct 2008, 23:45
by michcss
My laptop supports intel VT, i have enabled it in BIOS but still i've got error
kernel requires an x86_64 cpu, but only detected an i686 cpu
unable to boot - please use a kernel appropriate for your cpu

I'm trying to install ubuntu 8.04 on vista x64. J've got virtualbox 64 and enabled options conneted with intel vt.

PostPosted: 11. Oct 2008, 01:25
by Sasquatch
Do you have any other virtualisation programs installed, like MS VPC? Only one virtualisation program can use the virtualisation extention at a time (run several VMs with one program can, but not in different programs with VT-x/AMD-V enabled for them).

PostPosted: 11. Oct 2008, 13:27
by michcss
No other programs using virtualisation. Only VirtualBox.

PostPosted: 11. Oct 2008, 15:26
by stefan.becker
On the VMWARE Homepage there is a Tool to check for 64 Bit Guest. Try this. If thta says no, VirtualBox will not run, too.

Another idea is a Bios Update for the Mainboard.

PostPosted: 15. Oct 2008, 16:17
by michcss
VMWare 64-bit Copatibility Check Passed
This host is capable of running 64-bit guest operating system under this VMWare Product.

edit: it's strange, after a few days it works!

PostPosted: 19. Oct 2008, 05:28
by Dopefish
I am having this issue, as well.

I am using VirtualBox v2.0.2 x64. Virtualization is enabled in the BIOS. VT-x is enabled in VBox.

Here is an image of my settings:
http://imk.cx/junk/vbox64.png


I have ran that VMware tool that checks compatibility and it reports:
"This host is capable of running a 64-bit guest operating system under this VMware product."

Here is a link to my VBox.log:
http://imk.cx/junk/VBox.log

PostPosted: 20. Oct 2008, 21:22
by Sasquatch
Dopefish wrote:I am having this issue, as well.

I am using VirtualBox v2.0.2 x64. Virtualization is enabled in the BIOS. VT-x is enabled in VBox.

Here is an image of my settings:
http://imk.cx/junk/vbox64.png


I have ran that VMware tool that checks compatibility and it reports:
"This host is capable of running a 64-bit guest operating system under this VMware product."

Here is a link to my VBox.log:
http://imk.cx/junk/VBox.log

You missed the link to the Manual/FAQ. It clealy states that you also need I/O APIC and PAE enabled for it to be available. Enable those settings and you're good to go.

PostPosted: 21. Oct 2008, 01:27
by Dopefish
I've tried either of those, too, and neither work.

I had actually tried those first. The manual actually states that IO ACPI is only recommended for Windows, it's not required.

PostPosted: 21. Oct 2008, 01:37
by Sasquatch
Dopefish wrote:I've tried either of those, too, and neither work.

I had actually tried those first. The manual actually states that IO ACPI is only recommended for Windows, it's not required.

Indeed, but I quote from the manual:
Warning
You should enable the I/O APIC for virtual machines that you intend to use in 64-bit mode. This is especially true for 64-bit Windows VMs.
So you should enable it. It's advised, though not a dependency for 64 bit support.

If VB is unable to use it, then I would guess that you don't have full virtualisation. But that is strange, as the VMWare tool checks for that.

PostPosted: 21. Oct 2008, 02:32
by Dopefish
Well, whether I use those options or not, it does not seem to affect whether I can use 64-bit guests or not.

I filed a bug report here:
http://www.virtualbox.org/ticket/2440

It seems like my BIOS might have broken support for it. :/