Page 2 of 2

PostPosted: 21. Oct 2008, 13:30
by petrossa
actually, i have the same problem. Bios,MB Virtualisation enabled. I get same error: your system needs an x64 CPU.

Vista x64 SP1, Phenom 9600, AMI Bios dated september 2008.

Seems to me this a real VB bug.

PostPosted: 21. Oct 2008, 14:44
by sandervl
petrossa wrote:actually, i have the same problem. Bios,MB Virtualisation enabled. I get same error: your system needs an x64 CPU.

Vista x64 SP1, Phenom 9600, AMI Bios dated september 2008.

Seems to me this a real VB bug.


Could you add your VBox.log to the defect above? Note that quite a few MB vendors are not capable of properly enabling VT-x or AMD-V.

PostPosted: 21. Oct 2008, 19:28
by petrossa
sure, will do. But the MB is virtualisation certified. M2A-VM HDMI latest bios. All uitilities is tried indicate virtualisation is up and running.
see screenshot www.petrossa.com/amdcpu.bmp

Sorry.

PostPosted: 21. Oct 2008, 19:35
by SSCBrian
Very strange. No problems like that here. x64 guests work great on my AMD box!

PostPosted: 21. Oct 2008, 20:45
by Sasquatch
Petrosa, Sander meant that you upload your log file to the defect, not post it here. Please remove your log here and update the bug ticket. You need a separate account for that system.

PostPosted: 23. Oct 2008, 12:05
by petrossa
Purely by chance i installed http://www.virtualbox.org/ticket/2212#comment:35, because i happened upon it and found startup a bit slow.

After which vista x64 installed without a hitch....Might be a fluke i don't know but it works now

kernel requires an x86_64 cpu, but only detected an i686 cpu

PostPosted: 23. Feb 2009, 23:17
by northmilo
Hi,
I had the same problem using VirtualBox 2.1.4 on my laptop lenovo w500.
Solution came fast end efficient :) When setting virtual support in bios there is a note to POWER DOWN machine otherwise the change will not work. I shut down the system, turn off AC and switch off battery for a few seconds.
Now I can easily set up guest Gentoo x64 on vista 64 host.

Re: kernel requires an x86_64 cpu, but only detected an i686 cpu

PostPosted: 13. May 2009, 05:43
by ilbarto08
I have found a solution. The problem is in the Virtual Media Manager. You should release the virtual hard disk from the virtual media manager (menu file), and then mount it again from the virtual machine itself. This error occurs because the state of the virtual hard disk is saved and if in there was a incompatibility (in my case when I install microsoft virtualpc), it is saved and it stays there.

Re: kernel requires an x86_64 cpu, but only detected an i686 cpu

PostPosted: 5. Jul 2009, 01:04
by philgons
Updating my BIOS solved the problem for me. I have an EVGA nVidia 650i Ultra mainboard with a Q6600 CPU. Updating my BIOS was the only solution that worked for getting VirtualBox to accept a 64-bit guest OS (Ubuntu 9.10 under Vista Home Premium 64-bit).

Re: kernel requires an x86_64 cpu, but only detected an i686 cpu

PostPosted: 5. Jul 2009, 14:02
by vbox4me2
These issues are in the FAQ, its a combo of things that gets vt-x working.