Page 1 of 1

VirtualBox started crashing with VERR_IEM_INSTR_NOT_IMPLEMENTED

PostPosted: 16. Apr 2021, 10:06
by Lazzz
I believe that this might be different problem than described here (can't paste link but you'll figure it out):
viewtopic.php?f=6&t=102298
but feel free to close / duplicate if you know better.

In my case I was using VirtualBox 6.1 for 4 months on Windows 10 host running Ubuntu 18.04 virtual machine. I've used 2 monitors all the time and my way of working would be to start VM, then at the end of the day save VM state and start it again the next day.
However, couple days ago VirtualBox started crashing with Guru Meditation error when I was trying to load saved state. I've done multiple tests and I figured out that:
1. When I start VM, save and load it works ok.
2. When I start VM, enable second screen, save and load then it will crash every time during load.
3. When I start VM, enable second screen, then disable second screen, save and load then it works ok.

As I've mentioned it worked well for past 4 months and suddenly broken. As a workaround I'll be using approach #3 and disable second screen before saving machine state but maybe there is better way to fix that?

Re: VirtualBox started crashing with VERR_IEM_INSTR_NOT_IMPLEMENTED

PostPosted: 16. Apr 2021, 21:00
by scottgus1
Let's clear this one up first, then see what happens:

Hyper-V is enabled and needs to be disabled. See HMR3Init: Attempting fall back to NEM (Hyper-V is active).

Re: VirtualBox started crashing with VERR_IEM_INSTR_NOT_IMPLEMENTED

PostPosted: 19. Apr 2021, 11:29
by Lazzz
I've tried disabling that. Actually I've also tried disabling all acceleration (except VT-x/AMD-V because it was not optional) but the problem remained.
I also don't think that it's related to virtual box configuration because I think I didn't change that configuration from months.

Or is this some Windows configuration which changed recently?

Re: VirtualBox started crashing with VERR_IEM_INSTR_NOT_IMPLEMENTED

PostPosted: 19. Apr 2021, 17:16
by scottgus1
Did you read the tutorial? It covers what to do if this:
Lazzz wrote:I've tried disabling that.

fails.

Re: VirtualBox started crashing with VERR_IEM_INSTR_NOT_IMPLEMENTED

PostPosted: 21. Apr 2021, 08:41
by Lazzz
Sorry, I've misunderstood your previous message and was focusing only on virtualbox settings.
This time I've followed the thread and it seems the problem was solved but I will monitor it in the next days.

I've also attached screenshots, maybe they will be useful for someone who would find this thread in future.

1.png
Device guard
1.png (40.07 KiB) Viewed 196 times


2.png
Core isolation
2.png (127.3 KiB) Viewed 196 times


3.png
Disabling hyper-v
3.png (21.33 KiB) Viewed 196 times

Re: VirtualBox started crashing with VERR_IEM_INSTR_NOT_IMPLEMENTED

PostPosted: 21. Apr 2021, 19:06
by scottgus1
Great! Glad you're up and running!

Moving to Windows Hosts.