delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Discussions related to using VirtualBox on Windows hosts.

delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby DaveEar » 5. Mar 2021, 12:22

Hello, just updated to a version 6.1.18 r142142 (Qt5.6.2), now, each touch on my VM machine ( XP ) they respond after 2 seconds...even if you click a button or move a windows.....Does anyone have the same problem?Do you think is possible? Is there a Fix?

Thankyou
DaveEar
 
Posts: 30
Joined: 19. Dec 2016, 18:29

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby mpack » 5. Mar 2021, 13:56

Almost certainly this is due to 2 factors:

  1. VirtualBox 6.1.x has dropped support for hosts that don't have VT-x or AMD-v enabled, since it's more than a decade now since that feature was introduced.
  2. You have Hyper-v enabled, which grabs VT-x/AMD-v and doesn't like to share. One of the symptoms is that VMs slow to a crawl.
Read related FAQ: I have a 64bit host, but can't install 64bit guests.
mpack
Site Moderator
 
Posts: 33464
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby DaveEar » 5. Mar 2021, 15:02

Thankyou for your answer, but.
This VM is created and daily used from 10years, it's a XP OS. and..

machine is i7 cpu and Virtual Hw is ON on BIOS
paravirtual is in default ( as always )
PAE/NX is unchecked
HW virtualization is ON

Each touch on explorer take 2 seconds and CPU ( ov VM ) shot to 100% for a while....

What i have to do?

Thanks
DaveEar
 
Posts: 30
Joined: 19. Dec 2016, 18:29

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby DaveEar » 5. Mar 2021, 15:08

I Just resolved ( temporary ) reinstall previous version 6.1.12 r139181 (Qt5.6.2), but what about next releases?
DaveEar
 
Posts: 30
Joined: 19. Dec 2016, 18:29

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby mpack » 5. Mar 2021, 19:10

6.1.12 is also in the 6.1.x family and hence would not solve the problem I outlined. Since you seem to be saying that you have a different problem I have no way to know what difference future versions will make.
mpack
Site Moderator
 
Posts: 33464
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby DaveEar » 5. Mar 2021, 19:31

thas'ts why i told you. With the 6.1.12 everything went back well again.....
DaveEar
 
Posts: 30
Joined: 19. Dec 2016, 18:29

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby KZK » 28. Mar 2021, 13:15

I have experienced a similar issue when moving from 6.1.14 to 6.1.18. Also a Windows 10 host and XP VM. I was careful to use the correct extension pack version. To recover I have simply re-installed 6.1.14 and the extension pack for that without even uninstalling 6.1.18 (i.e simply ran the 6.1.14 install executable). So I guess something has changed between these two different versions. I'm not 100% sure but the issue could have started in V6.1.16. Also it seems a little bit progressive in the sense that after starting up the VM it appears not too bad but seems to get worse after some time. I checked memory usage but nothing obviously wrong there

Sorry that I'm not providing much else in the way of detail to help diagnose but for moment I thought just to flag up that it appears it is not an isolated incident
KZK
 
Posts: 2
Joined: 28. Mar 2021, 13:05

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby scottgus1 » 28. Mar 2021, 14:28

DaveEar & KZK, when you see a problem like this happen, posting a zipped vbox.log showing the VM having the problem may help us find the solution. It can also be especially helpful if you could also post a vbox.log from the earlier time when the VM was not having problems, for comparison.

Start the VM from full normal shutdown, not save-state. Run until you see the problem happen, then shut down the VM from within the VM's OS if possible. If not possible, close the Virtualbox window for the VM with the Power Off option set.

Right-click the VM in the main Virtualbox window's VM list, choose Show Log. Save the far left tab's log, zip it, and post the zip file, using the forum's Upload Attachment tab.
scottgus1
Site Moderator
 
Posts: 11351
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: delay on VM in Version 6.1.18 r142142 (Qt5.6.2)

Postby KZK » 31. Mar 2021, 12:31

Thanks for your instructions. Must find the setting to get e-mails when someone posts to a relevant thread ... :) (edit: just found subscribe topic button..)

I didn't want to shut down my machine at present (and also re-install 6.1.18 and then back to 6.1.14), so following the instructions fully may have to wait. However when I checked the show log I found it had recorded what I think to be probably useful enough recent historical logs covering boot ups using 6.1.18 and 6.1.14. Just skimming through the 6.1.18 ones with my totally untrained eye I do see some kind of non response logs for 6.1.18 but there again the 6.1.14 log has some reports indicating some audio component issues (but no obvious symptoms on performance - not that I'm using audio).

BTW, while I'm at it, the clipboard function has not worked for a long time. By which I mean doing something like Copy from VM to then Paste to Host. So I just do an elaborate notepad workaround using a shared folder. If you happen to notice anything obvious that I'm doing wrong then ... otherwise just live with it as a minor issue considering everything else i can do with what I think is a great piece of work.
Attachments
Logs.zip
V6.1.14 and 6.1.18 logs for performance stutters in 6.1.18 issue
(77.15 KiB) Downloaded 2 times
KZK
 
Posts: 2
Joined: 28. Mar 2021, 13:05


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 24 guests