vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Discussions related to using VirtualBox on Windows hosts.

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby arjun » 26. Apr 2009, 23:15

nettobr wrote:Hi there,

Ok, the coin dropped and connection has been established.

GA stands for Guests Addictions.

NettoBr


Actually, it is Guest Additions, but I like your version better. It is addictive :-)
arjun
 
Posts: 8
Joined: 25. Apr 2009, 21:16
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: xubuntu 9.04

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby arjun » 26. Apr 2009, 23:23

Sasquatch wrote:I've written a howto in the Linux Guests forum. Check that, it has a sample xorg.conf. Use that, then it will work. I have no issues with 9.04 as VM.


Sasquatch/Peter, I wonder if this problem can be replicated if you try installing on a PC with resolution that is lesser than 1024x768? Maybe I faced a problem because I was trying it on a netbook who's resolution was 1024x600. But in general I am confused. VB 2.2 and Ubuntu 8 worked great on the same netbook. So the problem is not only with VB. At the same time, the fact that GA vboxvideo works great even after you restart the guest OS, but stops working after you powerdown the VM implies there is a problem in how VB and xubuntu 9 are interacting.

Anyway, I read this in your tut:
Note, more recent versions of Xserver might not need this kind of configuration and everything is done automatically. The developpers are planning to stop using xorg.conf for configuration and let HAL take over.


That's a great step. I've always believed xorg.conf to be the bane of linux graphical systems. A small mistake and you are in for quite a journey with a lot of reading. OTOH, if xorg.conf gets ignored I can imagine linux afficionados get frustrated why changes are not being reflected :-) I hope, whenever you do it, it is made evident that xorg is being ignored and here is how to change it back.


BTW, thankyou for the awesome support.
arjun
 
Posts: 8
Joined: 25. Apr 2009, 21:16
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: xubuntu 9.04

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby Sasquatch » 27. Apr 2009, 13:02

As I've said, no issues on my end with Ubuntu 9.04. But then again, I use Xfce as Desktop Manager. That seems to have some influence on some issues, that are more a Gnome nature.

The fact that xorg.conf won't be used anymore is already visible in 1.6.x of Xserver. I installed my laptop with 9.04, brand new setup, and all works just fine without any xorg.conf data. The xorg/xserver devs will abandon this config some day completely. I just hope that they keep some kind of tweak options somewhere.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby nettobr » 27. Apr 2009, 16:46

Hi People,

Sorry about the :oops: ADDICTIONS...

Sasquatch, very good its GA is doing well for you, but not for me...

I have followed your howto step by step, except for system preparation.

Well, My Host is a XP Pro on a Core 2 Duo CPU and 3 Gb of ram.

VBox is a 2.1.4. VBox 2.2 Gave many error in Network allocation, so I´ve rolled out.

My Guest is a UBUNTU 9.04 fresh copy.

What did I do:

DKMS instalation - OK.

GA instalation - OK.

And recompiled the guest kernel modules, using this command: /etc/init.d/vboxadd setup

You can see below Xorg log:

Thanks

NettoBr

Code: Select all   Expand viewCollapse view
X.Org X Server 1.6.0
Release Date: 2009-2-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-23-server i686 Ubuntu
Current Operating System: Linux ubuntu-Box 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686
Build Date: 09 April 2009  02:10:02AM
xorg-server 2:1.6.0-0ubuntu14 (buildd@rothera.buildd)
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 27 10:04:54 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Configured Monitor"
(**) |   |-->Device "Configured Video Device"
(**) |-->Input Device "vboxmouse"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
   Entry deleted from font path.
(==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
   If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Loader magic: 0x3bc0
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 5.0
   X.Org XInput driver : 4.0
   X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@0:2:0) InnoTek Systemberatung GmbH VirtualBox Graphics Adapter rev 0, Mem @ 0xe0000000/16777216
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.6.0, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.6.0, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.6.0, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.6.0, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.6.0, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.6.0, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "vboxvideo"
(WW) Warning, couldn't open module vboxvideo
(II) UnloadModule: "vboxvideo"
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(II) LoadModule: "vboxmouse"
(WW) Warning, couldn't open module vboxmouse
(II) UnloadModule: "vboxmouse"
(EE) Failed to load module "vboxmouse" (module does not exist, 0)
(EE) No drivers available.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log
nettobr
 
Posts: 5
Joined: 26. Apr 2009, 19:16
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: UBUNTUSES

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby Sasquatch » 27. Apr 2009, 16:55

(II) LoadModule: "vboxvideo"
(WW) Warning, couldn't open module vboxvideo
(II) UnloadModule: "vboxvideo"
(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(II) LoadModule: "vboxmouse"
(WW) Warning, couldn't open module vboxmouse
(II) UnloadModule: "vboxmouse"
(EE) Failed to load module "vboxmouse" (module does not exist, 0)
(EE) No drivers available.

Are you sure the GA are installed properly? You said you skipped the system preparation, why? That is needed, else the compilation will fail.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby nettobr » 28. Apr 2009, 15:53

Hi People,

OK Sasquatch, I thought Ubuntu was fully prepared for the compilation, as in manual, this task is not mentioned.

Well, build-essentials was not installed in my guest, and now it is.

I made a GA re-installation, but I´m still getting same low resolution message.

Taking a look to vboxadd-install.log i found this error message.

Installing the X Window System drivers
Unknown version 1.6.0 of the X Window System installed - not installing drivers.


Is there a issue for installing GA for VBox 2.1.4?

Although, there is a error in installation process message Successfully completed. is displayed. This make me think it was ok.

See below the full log.

Bye from Brazil,

NettoBr

Code: Select all   Expand viewCollapse view
Installing VirtualBox 2.1.4 Guest Additions, built Mon Feb 16 17:26:56 CET 2009

Testing the setup of the guest system

Building a test kernel module...

make KBUILD_VERBOSE=1 -C /lib/modules/2.6.28-11-generic/build SUBDIRS=/tmp/selfgz4454/module/test SRCROOT=/tmp/selfgz4454/module/test modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || (      \
   echo;                        \
   echo "  ERROR: Kernel configuration is invalid.";      \
   echo "         include/linux/autoconf.h or include/config/auto.conf are missing.";   \
   echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";   \
   echo;                        \
   /bin/false)
mkdir -p /tmp/selfgz4454/module/test/.tmp_versions ; rm -f /tmp/selfgz4454/module/test/.tmp_versions/*
make -f scripts/Makefile.build obj=/tmp/selfgz4454/module/test
  gcc -Wp,-MD,/tmp/selfgz4454/module/test/.test.o.d  -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.3.3/include -D__KERNEL__  -Iinclude  -I/usr/src/linux-headers-2.6.28-11-generic/arch/x86/include -include include/linux/autoconf.h -Iubuntu/include  -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -O2 -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i586 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Iarch/x86/include/asm/mach-default -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -Wdeclaration-after-statement -Wno-pointer-sign -fwrapv -I/lib/modules/2.6.28-11-generic/build/include -I/tmp/selfgz4454/module/test/ -I/tmp/selfgz4454/module/test/include -I/tmp/selfgz4454/module/test/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -D_X86_ -DIN_RT_R0 -DIN_SUP_R0 -DVBGL_VBOXGUEST -DVBGL_HGCM -DVBOX_WITH_HGCM -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(test)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxadd_test)"  -c -o /tmp/selfgz4454/module/test/.tmp_test.o /tmp/selfgz4454/module/test/test.c
  ld -m elf_i386   -r -o /tmp/selfgz4454/module/test/vboxadd_test.o /tmp/selfgz4454/module/test/test.o
(cat /dev/null;   echo kernel//tmp/selfgz4454/module/test/vboxadd_test.ko;) > /tmp/selfgz4454/module/test/modules.order
  Building modules, stage 2.
make -f /usr/src/linux-headers-2.6.28-11-generic/scripts/Makefile.modpost
  scripts/mod/modpost -m -a -i /usr/src/linux-headers-2.6.28-11-generic/Module.symvers -I /tmp/selfgz4454/module/test/Module.symvers  -o /tmp/selfgz4454/module/test/Module.symvers -S -K /usr/src/linux-headers-2.6.28-11-generic/Module.markers -M /tmp/selfgz4454/module/test/Module.markers -w  -s
  gcc -Wp,-MD,/tmp/selfgz4454/module/test/.vboxadd_test.mod.o.d  -nostdinc -isystem /usr/lib/gcc/i486-linux-gnu/4.3.3/include -D__KERNEL__  -Iinclude  -I/usr/src/linux-headers-2.6.28-11-generic/arch/x86/include -include include/linux/autoconf.h -Iubuntu/include  -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -O2 -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i586 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Iarch/x86/include/asm/mach-default -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -Wdeclaration-after-statement -Wno-pointer-sign -fwrapv -I/lib/modules/2.6.28-11-generic/build/include -I/tmp/selfgz4454/module/test/ -I/tmp/selfgz4454/module/test/include -I/tmp/selfgz4454/module/test/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -D_X86_ -DIN_RT_R0 -DIN_SUP_R0 -DVBGL_VBOXGUEST -DVBGL_HGCM -DVBOX_WITH_HGCM  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(vboxadd_test.mod)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxadd_test)"  -DMODULE -c -o /tmp/selfgz4454/module/test/vboxadd_test.mod.o /tmp/selfgz4454/module/test/vboxadd_test.mod.c
  ld -r -m elf_i386  --build-id -o /tmp/selfgz4454/module/test/vboxadd_test.ko /tmp/selfgz4454/module/test/vboxadd_test.o /tmp/selfgz4454/module/test/vboxadd_test.mod.o
Inserting the test module module/test/vboxadd_test.ko into the kernel.
Attempt to remove old DKMS modules...
  removing module vboxadd version  2.1.4
  removing module vboxvfs version  2.1.4
Done.

Building the VirtualBox Guest Additions kernel module.

Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxadd/2.1.4/source ->
                 /usr/src/vboxadd-2.1.4

DKMS: add Completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=2.6.28-11-generic -C /lib/modules/2.6.28-11-generic/build M=/var/lib/dkms/vboxadd/2.1.4/build...........

Running the post_build script:
cleaning build area....

DKMS: build Completed.

vboxadd.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/2.6.28-11-generic/updates/dkms/

depmod....

DKMS: install Completed.

Building the shared folder support kernel module.

Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxvfs/2.1.4/source ->
                 /usr/src/vboxvfs-2.1.4

DKMS: add Completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Running the pre_build script:

Building module:
cleaning build area....
make KERNELRELEASE=2.6.28-11-generic -C /lib/modules/2.6.28-11-generic/build M=/var/lib/dkms/vboxvfs/2.1.4/build.........
cleaning build area....

DKMS: build Completed.

vboxvfs.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/2.6.28-11-generic/updates/dkms/

depmod....

DKMS: install Completed.
Installing the Guest Additions kernel module system service.
Installing the shared folder system service.
Installing the time synchronisation system service.
Installing the VBoxControl command line interface.
Installing the X Window System user service.
install_x11_startup_app(): dest is vboxclient.desktop
install_x11_startup_app(): executing install -m 0644 vboxclient.desktop /etc/xdg/autostart/vboxclient.desktop
Creating udev rule for the Guest Additions kernel module.
Installing the X Window System drivers
Unknown version 1.6.0 of the X Window System installed - not installing drivers.

Successfully completed.
nettobr
 
Posts: 5
Joined: 26. Apr 2009, 19:16
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: UBUNTUSES

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby Perryg » 28. Apr 2009, 16:53

Your guest is newer than your VBox. Version 2.1.4 of VBox doesn't know about the newer version of X.
VBox 2.2.2 has just been released if you would like to give that a try.
Perryg
Site Moderator
 
Posts: 25943
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby Sasquatch » 28. Apr 2009, 17:28

And if you want to stick to 2.1.4, check the Linux Guests forum. That has the solution.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: vbox video error with Virtualbox 2.2 and Xubuntu 9.04

Postby nettobr » 28. Apr 2009, 19:14

Hi there,

Yeah, Now it's working...

Vbox 2.2 did not work for me, with many problems in networking.

Now I've upgraded to VBox 2.2.2. And now it is pretty good...

I've installed a fresh copy of UBUNTU 9.04...

Only ran sudo sh ./VBoxLinuxAditions-x86.run, made a reboot and its working, and no system preparation was necessary.

For me, this issue is solved.

Thanks for all, for patience, and answering very quickly...

Thanks from Brazil, Land of very beautiful places and women..

NettoBr.
nettobr
 
Posts: 5
Joined: 26. Apr 2009, 19:16
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: UBUNTUSES

Previous

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 37 guests