Linux guest VM runs very slow after moving from Lenovo P53 host to Lenovo P1 host, both on Windows11

Discussions related to using VirtualBox on Windows hosts.
Post Reply
Goz
Posts: 2
Joined: 30. May 2023, 02:27

Linux guest VM runs very slow after moving from Lenovo P53 host to Lenovo P1 host, both on Windows11

Post by Goz »

A CentOs Linux guest VM running on Lenovo P53 laptop (Windows 11 host) runs very well. On this P53 windows host, the VM resource allocation was 11gb ram, 7 cpus, video memory of 16mb. Here the VirtualBox version was 7.0.6

I had to move this VM to another Windows11 laptop (Lenovo P1) which has much higher specs compared to Lenovo P53. When I ran the same VM here in P1, it degraded its performance and runs very slow. I even tried increasing the resources to 12gb ram, 9 cpus and maxed the display/video memory to 128mb. I even upgraded the Virtual Box version to 7.0.8 and also updated the guest additions. But still no luck.

Please review the attached logs as zip file and advice what has to be done to make it run better in the new host (P1) or at-least run similar to old host (P53)

Thank you
Attachments
vbx-logs-display-ram-maxed.zip
Logs after updating guest additions and display ram maxed out
(76.56 KiB) Downloaded 3 times
Goz
Posts: 2
Joined: 30. May 2023, 02:27

Re: Linux guest VM runs very slow after moving from Lenovo P53 host to Lenovo P1 host, both on Windo

Post by Goz »

I had the following features turned off for my above post: Hyper-V, Guarded host, Virtual Machine, Platform, Windows Hypervisor Platform, Windows Sandbox, WSL.

I tried bcdedit as per post: /viewtopic.php?f=25&t=99390 and shutdown, deactivated battery in bios, waited 20+ seconds, restarted and it still did not work

Also tried gpcedit as per post: /viewtopic.php?f=1&t=62339#p417512 changed it from "Not defined" to "Disabled" and it still did not work...

It still shows the turtle-V icon.

It worked after editing the registry keys as mentioned in post: /viewtopic.php?f=6&t=105887&p=517076#p517076 changed it from 1 to 0
It kind of seems right as my new laptop P1 came with Windows11 whereas my previous laptop P53 was upgraded form Windows10 to Windows11.

:D
mpack
Site Moderator
Posts: 38849
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Linux guest VM runs very slow after moving from Lenovo P53 host to Lenovo P1 host, both on Windo

Post by mpack »

Ignoring later comments. Going only by the log.

Hyper-v is NOT turned off. It is on, and it interferes.
00:00:10.481186 HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
...
00:00:10.493664 NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...
See HMR3Init: Attempting fall back to NEM (Hyper-V is active).
Post Reply