"...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Discussions related to using VirtualBox on Windows hosts.

"...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby ant » 19. Oct 2021, 23:13

(Mod Edit: 6.1.28 may have introduced a bug causing this error to arise. Please see Klaus' post below: viewtopic.php?f=6&t=104175&p=507402#p507484)

This was in my upgraded VB v6.1.28 from v6.1.26 in my updated, 64-bit W10 Pro. PC. VB kept showing this after starting a guest VM:

"Failed to open a session for the virtual machine ...

Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}".


They last worked on a couple days ago too in v6.1.26 before upgrading to v6.1.28. Is anyone else seeing this too? I already tried rebooting, repairing, etc. I didn't uninstall and reinstall VB yet. I might go downgrade it back to v6.1.26 soon? Let's see if we can fix it first. Attached and http://zimage.com/~ant/temp/AntsVirtualBox6.1.zip for my VB settings and logs.

Thank you for reading and hopefully answering soon. :)
Attachments
AntsVirtualBox6.1.zip
(85.97 KiB) Downloaded 345 times
Last edited by scottgus1 on 21. Oct 2021, 16:02, edited 4 times in total.
Reason: added mod edit note
ant
 
Posts: 270
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows and macOSes

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby scottgus1 » 20. Oct 2021, 01:04

scottgus1
Site Moderator
 
Posts: 13734
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby ant » 20. Oct 2021, 01:22

Interesting. How come I didn't have this problem before upgrading VirtualBox this morning PDT? BTW, I forgot to upload my vbox.log files so I added them into my zip file and reuploaded into the same location. Maybe that will give more clues.

Where is this "Windows Hypervisor Platform (NEM)" option at as mentioned in "If Hyper-V cannot be disabled, e.g. due to company policy, then VirtualBox v6.x has a new ability to run via the Windows Hypervisor Platform (NEM), however Windows 10 (1809) or later is required, the feature still has bugs (as of VirtualBox 6.1.12), Microsoft keeps changing it, and it currently causes a significant drop in VM performance." in viewtopic.php?t=62339#p506311? I need Hyper-V for Credential Guard, Windows Sandbox, etc. :( Although, OptionalFeatures.exe doesn't show any Hyper-V checked. And my Windows Sandbox still works. Weird/Odd.
ant
 
Posts: 270
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows and macOSes

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby AndyCot » 20. Oct 2021, 01:57

I get the same problem with 6.1.28

I have tired the following Virtualbox versions:
OKAY - VirtualBox-6.1.26-145957-Win.exe
OKAY - VirtualBox-6.1.27-147422-Win.exe (test build)
OKAY - VirtualBox-6.1.97-147373-Win.exe (yes 6.1.97 test build)
BAD - VirtualBox-6.1.28-147628-Win.exe

So it looks like a change between SVN 147422 and 147628 has caused the NEMR0InitVMPart2 failure to occur.

I have changed between the different versions listed above without any reboots or Windows changes, so the only changes are with the different VirtualBox installs.

The following is the dialog message containing the error:
Failed to open a session for the virtual machine XUbuntu-2004.

Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

AndyCot
 
Posts: 49
Joined: 29. Feb 2020, 03:04

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby ant » 20. Oct 2021, 02:09

AndyCot wrote:I get the same problem with 6.1.28

I have tired the following Virtualbox versions:
OKAY - VirtualBox-6.1.26-145957-Win.exe
OKAY - VirtualBox-6.1.27-147422-Win.exe (test build)
OKAY - VirtualBox-6.1.97-147373-Win.exe (yes 6.1.97 test build)
BAD - VirtualBox-6.1.28-147628-Win.exe

So it looks like a change between SVN 147422 and 147628 has caused the NEMR0InitVMPart2 failure to occur.

I have changed between the different versions listed above without any reboots or Windows changes, so the only changes are with the different VirtualBox installs.

The following is the dialog message containing the error:
Failed to open a session for the virtual machine XUbuntu-2004.

Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Oh good. I'm not alone! So, I downgraded back to .26 (didn't even uninstall and reboot to reinstall). It's back to normal. It looks like .28 has issues. Please kindly let me know if I need to test a fix for this issue. ;) Does a bug report exist for it yet?
ant
 
Posts: 270
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows and macOSes

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby AndyCot » 20. Oct 2021, 02:31

I have no idea if there is a ticket for this.
AndyCot
 
Posts: 49
Joined: 29. Feb 2020, 03:04

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby ant » 20. Oct 2021, 08:27

AndyCot wrote:I have no idea if there is a ticket for this.
I think we need to write it up if it's indeed a bug. I'm hoping others will report in that they have this issue too.
ant
 
Posts: 270
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows and macOSes

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby mpack » 20. Oct 2021, 12:28

I doubt it's a bug. More likely Microsoft just moved the goalposts again. That's why the advice has always been to disable Hyper-v: see the link in Scott's post above.

Living with Hyper-v has experimental status only.
mpack
Site Moderator
 
Posts: 34887
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby ant » 20. Oct 2021, 17:14

mpack wrote:I doubt it's a bug. More likely Microsoft just moved the goalposts again. That's why the advice has always been to disable Hyper-v: see the link in Scott's post above.

Living with Hyper-v has experimental status only.
I still don't understand why .26 works, but not .28. What changed in VB?
ant
 
Posts: 270
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows and macOSes

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby scottgus1 » 20. Oct 2021, 17:16

Look at the change log in: viewtopic.php?f=1&t=104172
scottgus1
Site Moderator
 
Posts: 13734
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby mpack » 20. Oct 2021, 18:25

I'm suggesting that the relevant change could have been in Windows, not VirtualBox.
mpack
Site Moderator
 
Posts: 34887
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby ant » 20. Oct 2021, 18:56

scottgus1 wrote:Look at the change log in: viewtopic.php?f=1&t=104172
I don't see anything interesting from it that could be related and its viewtopic.php?f=1&t=104171 forum thread link. Am I not seeing it?
ant
 
Posts: 270
Joined: 9. Jul 2007, 20:02
Location: An Ant Farm
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: Windows and macOSes

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby scottgus1 » 20. Oct 2021, 18:59

You can make a ticket in the Bugtracker, with as much documentation as you can come up with, like a log of a working VM, and another log of the same VM that fails when 6.1.28 is installed, and a link to this forum topic. That may help the devs if there is in fact a Virtualbox bug.
scottgus1
Site Moderator
 
Posts: 13734
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby klaus » 20. Oct 2021, 19:52

Sounds like the fixing of NEM for Windows 11 has broken it for Windows 10...
klaus
Oracle Corporation
 
Posts: 870
Joined: 10. May 2007, 14:57

Re: "...Call to NEMR0InitVMPart2 failed: VERR_NEM_INIT_FAILED (VERR_NEM_VM_CREATE_FAILED)..."

Postby srpen6 » 20. Oct 2021, 20:05

Same problem here. Switching to 6.1.26 (and changing nothing else) fixed it for
me.

Also, I dont appreciate the different comments about the Hyper-V, as that
obviously has nothing to do with the issue. All youre doing is sending people on
a wild goose chase. Please dont do that, unless youre certain thats the problem.
Which in this case, its not.
srpen6
 
Posts: 1
Joined: 20. Oct 2021, 20:01

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 52 guests