No internet on guest after host goes to sleep

Discussions related to using VirtualBox on Windows hosts.

No internet on guest after host goes to sleep

Postby harald123 » 9. May 2021, 19:06

I am aware this is an old problem ( https://www.virtualbox.org/ticket/14374 ) , but I still have it today with an updated Vbox version.

VirtualBox: 6.1.18
Host Win 10
Guest LinuxMint

What I tried until now without success:
- restart network service on Linux (this worked in previous versions)
- connected and disconnected network adapter on the network icon in the right down corner
- switched from NAT to Bridge and back (this worked in previous versions)
- editing promiscuous mode
Code: Select all   Expand viewCollapse view
VBoxManage.exe controlvm "LinuxMint19" nicpromisc1 allow-all
VBoxManage.exe controlvm "LinuxMint19" nicpromisc1 deny

- in the VBox adapter in Windows diagnose
- disabled and enabled the VBox adapter in Windows
- in network settings switched between different adapter types - Settings - Network - advanced - adapter type
- updated everything on the LinuxMint machine
- the MAC adress in network settings in Vbox matched Mac address in network information on the guest

I found these on different forums on the web, but they did not work.
There is another solution from here, but I do not know how to do this or if it is possible. https://communities.vmware.com/t5/VMwar ... d-p/874898

Is there any other solution available than restarting guest?

Thank you
harald123
 
Posts: 36
Joined: 30. Oct 2020, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Linux Mint 19 Tara

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 57 guests