Can't start up VM after installing Mesa

Discussions related to using VirtualBox on Windows hosts.

Can't start up VM after installing Mesa

Postby Exuin » 19. Apr 2021, 17:55

Hi, I'm trying to test something on a Windows 10 32-bit VM. Since the application was upside-down when I opened it, I installed Mesa on VirtualBox. But now I can't start my VM. It just gives me an error message. :(
I would post the link to the GitHub repo but I just made this account and it won't let me. The repo is mesa-dist-win tho.
Exuin
 
Posts: 5
Joined: 19. Apr 2021, 17:52

Re: Can't start up VM after installing Mesa

Postby scottgus1 » 19. Apr 2021, 17:58

Exuin wrote:It just gives me an error message.

First step in asking for help is reporting what the error message was. :wink:

Then, please start the VM from full power off, not save-state. Run until you see the problem happen, then shut down the VM from within the VM OS if possible. If not possible, close the Virtualbox window for the VM with the Power Off option set.

Please right-click the VM in the main Virtualbox window's VM list, choose Show Log. Save the far left tab's log and the next tab over (the hardening log), zip both files, and post the zip file, using the forum's Upload Attachment tab.
scottgus1
Site Moderator
 
Posts: 11704
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Can't start up VM after installing Mesa

Postby Exuin » 19. Apr 2021, 18:32

Hi, in the meantime, I managed to mess up VirtualBox so much that it no longer opens. I tried reinstalling it, but that didn't change anything.

"The code execution cannot proceed because OPENGL32.dll was not found. Reinstalling the program may fix this problem."
Exuin
 
Posts: 5
Joined: 19. Apr 2021, 17:52

Re: Can't start up VM after installing Mesa

Postby scottgus1 » 19. Apr 2021, 19:43

Did you install Mesa in the VM or on the host OS?

Exuin wrote:in the meantime, I managed to mess up VirtualBox so much that it no longer opens.

Yes, random thrashing often does that.

Try this:
Reboot the host so no Virtualbox processes are running.
Open "C:\Users\{youraccount}"
Move the ".Virtualbox" folder (note the period in the name) to the desktop.
Try Virtualbox again.
scottgus1
Site Moderator
 
Posts: 11704
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Can't start up VM after installing Mesa

Postby Exuin » 19. Apr 2021, 20:45

Unfortunately that did not work. The same error is shown.
Exuin
 
Posts: 5
Joined: 19. Apr 2021, 17:52

Re: Can't start up VM after installing Mesa

Postby scottgus1 » 19. Apr 2021, 20:51

Bummer. Without knowing exactly what you did, there is not much else I can do.

Still waiting on this one:
scottgus1 wrote:Did you install Mesa in the VM or on the host OS?


Exuin wrote:"The code execution cannot proceed because OPENGL32.dll was not found. Reinstalling the program may fix this problem."

This does not appear to be a Virtualbox error message. Is this showing on the host OS?
scottgus1
Site Moderator
 
Posts: 11704
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Can't start up VM after installing Mesa

Postby Exuin » 19. Apr 2021, 21:07

I installed Mesa on the host OS. Should I have installed it on the virtual machine? I wasn't sure which one to install it on lol

And yeah, the error message is showing on the host OS.

So what I did was open up the exe for per-application deployment and put in the path for VirtualBox. Then I said yes to all the options and opened VirtualBox. After that I tried to run my VM, which didn't work. So I tried deleting Mesa but now VB won't open.
Exuin
 
Posts: 5
Joined: 19. Apr 2021, 17:52

Re: Can't start up VM after installing Mesa

Postby scottgus1 » 19. Apr 2021, 22:28

Mesa should have been installed inside the VM to influence the VM's graphics. I suspect your host OS is damaged. I don't know how to fix it short of starting over fresh with a new host OS install.
scottgus1
Site Moderator
 
Posts: 11704
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Can't start up VM after installing Mesa

Postby Exuin » 19. Apr 2021, 23:00

I see, thanks for replying.
Exuin
 
Posts: 5
Joined: 19. Apr 2021, 17:52


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 31 guests