[HELP] "Your CPU does not support long mode"

Discussions related to using VirtualBox on Windows hosts.

[HELP] "Your CPU does not support long mode"

Postby hisatsu21 » 7. Oct 2010, 03:30

Good Day,

Im quite new at using VirtualBox, I have read some facts and guides around the net so I figured to test it out.
I installed Virtual Box 3.2.8 and continued to create my guest OS (CentOS 5.4 x86) but during the first installation
part, I encountered this problem "Your CPU does not support long mode Use 32bit distribution". I browsed the net
for some answers and tried their solutions but none of them work. I will be glad if someone will lend a hand.
Thanks in advance

Host OS - Windows XP SP3 32bit
Guest OS - CentOS 5.4 x86_64
Processor - AMD Athlon x2 5000 (2.6ghz) Virtualization Capable
BIOS - Virtualization Enabled
hisatsu21
 
Posts: 1
Joined: 7. Oct 2010, 00:55
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: CentOS

Re: [HELP] "Your CPU does not support long mode"

Postby fixedwheel » 7. Oct 2010, 11:07

Hi,
hisatsu21 wrote:... and continued to create my guest OS (CentOS 5.4 x86)
...
Host OS - Windows XP SP3 32bit
Guest OS - CentOS 5.4 x86_64

in the guest settings: set the guest OS Version to "Red Hat (64bit)"

see manual
3. If you want to use 64-bit guest support on a 32-bit host operating system, you must also select a 64-bit operating system for the particular VM. Since supporting 64 bits on 32-bit hosts incurs additional overhead, VirtualBox only enables this support upon explicit request.

On 64-bit hosts, 64-bit guest support is always enabled, so you can simply install a 64-bit operating system in the guest.
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Re: [HELP] "Your CPU does not support long mode"

Postby leonspencer » 17. Oct 2010, 19:15

No 64-bit option available. Just lists Redhat. Vbox version 3.2.10. :?:
leonspencer
 
Posts: 5
Joined: 17. Oct 2010, 18:55
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: CentOS Debian

Re: [HELP] "Your CPU does not support long mode"

Postby Sasquatch » 17. Oct 2010, 19:18

If you can't select a 64 bit OS in the VM settings, then your AMD-V isn't working. Update your BIOS and recheck the settings.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: [HELP] "Your CPU does not support long mode"

Postby leonspencer » 17. Oct 2010, 19:50

I really do think this is a problem with VirtualBox. It rightfully does not required V-x support. It only requires it be enabled. Thus it is enabled in my BIOS eventhough my Intel U5400 does not support it. And this is a 64bit Windows 7 host.

So it is odd I can run CentOs 64bit directly on the hardware yet not run it under VirtualBox ala 'CPU does not support long mode' messages.
leonspencer
 
Posts: 5
Joined: 17. Oct 2010, 18:55
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: CentOS Debian

Re: [HELP] "Your CPU does not support long mode"

Postby Perryg » 17. Oct 2010, 20:02

To be able to run a 64-bit guest in VirtualBox your host must support hardware virtualization. Running a 64-bit OS on metal does not need this requirement.
If the CPU and the BIOS both do not support hardware virtualization then you will not be able to run 64-bit guests in VirtualBox.

http://ark.intel.com/Product.aspx?id=49156
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: [HELP] "Your CPU does not support long mode"

Postby leonspencer » 17. Oct 2010, 20:14

The BIOS does support V-x and it is enabled. However, the Intel U5400 does not. It is a 64bit proc running Windows 7 64-bit.

The Vbox user guide clearly says VT-x hardware support is not required but the BIOS MUST support 'enabling' of it:

http://www.virtualbox.org/manual/ch10.html#hwvirt

As opposed to other virtualization software, for many usage scenarios, VirtualBox does not require hardware virtualization features to be present. Through sophisticated techniques, VirtualBox virtualizes many guest operating systems entirely in software. This means that you can run virtual machines even on older processors which do not support hardware virtualization.

Even though VirtualBox does not always require hardware virtualization, enabling it is required in the following scenarios:

Certain rare guest operating systems like OS/2 make use of very esoteric processor instructions that are not supported with our software virtualization. For virtual machines that are configured to contain such an operating system, hardware virtualization is enabled automatically.

VirtualBox's 64-bit guest support (added with version 2.0) and multiprocessing (SMP, added with version 3.0) both require hardware virtualization to be enabled. (This is not much of a limitation since the vast majority of today's 64-bit and multicore CPUs ship with hardware virtualization anyway; the exceptions to this rule are e.g. older Intel Celeron and AMD Opteron CPUs.)
leonspencer
 
Posts: 5
Joined: 17. Oct 2010, 18:55
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: CentOS Debian

Re: [HELP] "Your CPU does not support long mode"

Postby Perryg » 17. Oct 2010, 20:22

I am sure you know a lot more about this than I do, so I will leave you to your experiments.
Perryg
Site Moderator
 
Posts: 25964
Joined: 6. Sep 2008, 22:55
Primary OS: Linux other
VBox Version: OSE self-compiled
Guest OSses: *NIX - Other

Re: [HELP] "Your CPU does not support long mode"

Postby leonspencer » 17. Oct 2010, 20:24

Well, this appears to be a Vmware issue too:
http://communities.vmware.com/message/1553904
leonspencer
 
Posts: 5
Joined: 17. Oct 2010, 18:55
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: CentOS Debian

Re: [HELP] "Your CPU does not support long mode"

Postby leonspencer » 17. Oct 2010, 20:26

Perryg, not really. I guess I am stuck with developing under 32-bit CentOS then using an RPM src for deploying to 64-bit CentOS. Sucks.
leonspencer
 
Posts: 5
Joined: 17. Oct 2010, 18:55
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: CentOS Debian


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 24 guests