Page 1 of 1

[Solved] Schlechte Performance seit Upgrade auf 6.0

PostPosted: 3. Jan 2019, 11:15
by FalkS
Ich benutze VBox seit Jahren. Meine aktuelle Umgebung ist ein Windows Server 2016 als Host mit Windows 10 Pro als Guest. Unter VBox 5.x lief das sehr gut, unter 6.0 "stottert" die VM gewaltig ohne erkennbaren Grund. Das Host-System hat eigentlich nichts weiter zu tun, Speicher und andere Resourcen sind reichlich vorhanden. Was könnte da die Ursache sein?

Falk

Re: Schlechte Performance seit Upgrade auf 6.0

PostPosted: 3. Jan 2019, 13:12
by socratis
DeepL translator wrote:I've been using VBox for years. My current environment is a Windows Server 2016 host with Windows 10 Pro as guest. Under VBox 5.x this worked very well, under 6.0 the VM "stutters" enormously for no apparent reason. The host system actually has nothing else to do, memory and other resources are abundant. What could be the cause?

Does the problem go away if you downgrade? Did you update the Guest Additions after upgrading? We need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image

Re: Schlechte Performance seit Upgrade auf 6.0

PostPosted: 4. Jan 2019, 10:35
by FalkS
I don't know if the problem goes away, when i downgrade. Can i downgrade with the guest additions for version 6?

Yes the Guest Additions where upgraded too.

I've attached the requested log file

Regards
Falk

Re: Schlechte Performance seit Upgrade auf 6.0

PostPosted: 4. Jan 2019, 12:05
by socratis
00:00:03.706914 NumCPUs <integer> = 0x0000000000000004 (4)
00:00:04.129849 CPUM: Physical host cores: 4
You have assigned all your CPUs to the VM. The host is going to run low on resources, since VirtualBox cares about physical processors (cores), not logical ones (threads).

00:00:03.707092 3DEnabled <integer> = 0x0000000000000000 (0)
00:00:04.638323 GUI: 2D video acceleration is disabled
Shut down the VM. Go to the VM Settings » Display » Screen. Enable 2D and 3D acceleration. Increase the VRAM to the max 256 MB. Start the VM...

FalkS wrote:Can i downgrade with the guest additions for version 6?
Uninstall the GAs, downgrade VirtualBox, re-install the matching GAs.

Re: Schlechte Performance seit Upgrade auf 6.0

PostPosted: 5. Jan 2019, 14:53
by FalkS
Changing the number of CPU's to 3 made the VM more fluid. That's good.

When i enabled 3D acceleration, the screen flickered terribly from time to time, java applications had major drawing problems (portions of the screen stood black). I disabled it again.

I am using two Monitors driven by an NVIDIA GTX630. The VM runs on the main screen in fullscreen mode.

Regards
Falk

Re: Schlechte Performance seit Upgrade auf 6.0

PostPosted: 5. Jan 2019, 15:37
by socratis
So, it's working now? Do you want to post a new log to take a look at?

Re: Schlechte Performance seit Upgrade auf 6.0

PostPosted: 8. Jan 2019, 16:34
by FalkS
It's working. Thanks for your help.

Falk

Re: Schlechte Performance seit Upgrade auf 6.0

PostPosted: 9. Jan 2019, 04:49
by socratis
OK, thanks for confirming. Marking as [Solved].