Page 1 of 1

[Resolved] VirtualBox 5.2.18 - Mageia6

PostPosted: 16. Aug 2018, 08:49
by ManfredB
Hallo zusammen,

ich habe eben auf Mageia6 VirtualBox-5.2.18 installiert.

Die VMs von Linux konnte ich alle aufnehmen,
doch Windwos10 will ich in Gruppe2 aufnehmen,
da kommt folgende Meldung:

Code: Select all   Expand viewCollapse view
Konnte die virtuelle Maschine in /VMs/VirtualBox/Neue Gruppe 2/Windows 10/Windows 10-1.14-linux.vbox nicht öffnen.
'Windows10_64' is not a valid Guest OS type.


Was hat das denn zu bedeuten?
Ist Windows10 inzwischen von VirtualBox nicht mehr akzeptiert?

Das habe ich ja bisher so noch nie erlebt.

Gruß
Manfred

Re: VirtualBox 5.2.18 - KM Exception Not Handled

PostPosted: 16. Aug 2018, 09:01
by ManfredB
Ergänzung:

Unter PCLinuxOS habe ich es eben auch gemacht: Update von 5.2.16 auf 5.2.18.

Alle Distributionen (Linux und Windows 10) sind eingebunden.

Kann es bei Mageia mit systemd zu tun haben?

Gruß
Manfred

Re: VirtualBox 5.2.18 - Mageia6

PostPosted: 16. Aug 2018, 09:21
by socratis
ManfredB, you're a volunteer. You should know better not to hijack someone else's thread. I split your posts from the thread "VirtualBox 5.2.18 - KM Exception Not Handled".

What's the output of "VBoxManage -version"? Post a ZIPPED VBox.log from the affected VM.

Re: VirtualBox 5.2.18 - Mageia6

PostPosted: 16. Aug 2018, 10:13
by ManfredB
here a failure with extensionpack:

Code: Select all   Expand viewCollapse view
Das Zusatzpaket /Daten/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.2.18.vbox-extpack konnte nicht installiert werden.
VBoxExtPackRegister returned VERR_VERSION_MISMATCH, pReg=0000000000000000 ErrInfo='Helper version mismatch - expected 0x10002 got 0x10000'.


And here a log-file:

Code: Select all   Expand viewCollapse view
VirtualBox (XP)COM Server 4.1.18 r78361 linux.amd64 (Jun 20 2012 11:47:56) release log
00:00:00.003 main     Log opened 2018-08-17T08:06:17.841789000Z
00:00:00.003 main     OS Product: Linux
00:00:00.003 main     OS Release: 4.14.62-desktop-2.mga6
00:00:00.003 main     OS Version: #1 SMP Fri Aug 10 21:46:23 UTC 2018
00:00:00.003 main     OS Service Pack: #1 SMP Fri Aug 10 21:46:23 UTC 2018
00:00:00.003 main     Executable: /opt/VirtualBox/VBoxSVC
00:00:00.003 main     Process ID: 15223
00:00:00.003 main     Package type: LINUX_64BITS_GENERIC
00:00:00.121 nspr-2   Loading settings file "/home/manbla/.VirtualBox/VirtualBox.xml" with version "1.12-linux"
00:00:00.199 nspr-2   VDInit finished
00:00:00.271 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/ArchLinux/ArchLinux.vbox" with version "1.16-linux"
00:00:00.282 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/CalculateNightly/CalculateNightly.vbox" with version "1.16-linux"
00:00:00.289 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/Fedora/Fedora.vbox" with version "1.16-linux"
00:00:00.301 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/KUbuntu/KUbuntu.vbox" with version "1.16-linux"
00:00:00.302 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/Mageia6/Mageia6.vbox" with version "1.16-linux"
00:00:00.309 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/Manjaro/Manjaro.vbox" with version "1.16-linux"
00:00:00.317 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/PCLinuxOS/PCLinuxOS.vbox" with version "1.16-linux"
00:00:00.326 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/PCLinuxOS-Test/PCLinuxOS-Test.vbox" with version "1.16-linux"
00:00:00.326 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/PCLOS-2018.03.23/PCLOS-2018.03.23.vbox" with version "1.16-linux"
00:00:00.339 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/PCLOS-Alternativ/PCLOS-Alternativ.vbox" with version "1.16-linux"
00:00:00.339 nspr-2   Loading settings file "/VMs/VirtualBox/Neue Gruppe 1/PCLOS-remaster/PCLOS-remaster.vbox" with version "1.16-linux"
00:00:00.843 nspr-3   WARNING [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={dab4a2b8-c735-4f08-94fc-9bec84182e2f} aComponent={Host} aText={VirtualBox is not currently allowed to access USB devices.  You can change this by adding your user to the 'vboxusers' group.  Please see the user manual for a more detailed explanation}, preserve=true
00:00:01.106 nspr-3   WARNING [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={dab4a2b8-c735-4f08-94fc-9bec84182e2f} aComponent={Host} aText={VirtualBox is not currently allowed to access USB devices.  You can change this by adding your user to the 'vboxusers' group.  Please see the user manual for a more detailed explanation}, preserve=true
00:00:12.515 ExtPackUninst ExtPack: Executing '/opt/VirtualBox/VBoxExtPackHelperApp''uninstall' '--base-dir' '/opt/VirtualBox/ExtensionPacks' '--name' 'Oracle VM VirtualBox Extension Pack'
00:00:17.465 ExtPackUninst ExtPack: enmReason=1 iStatus=0 stderr='rcExit=RTEXITCODE_SUCCESS
00:00:17.465 ExtPackUninst '
00:00:17.465 ExtPackUninst ExtPackManager: Successfully uninstalled extension pack 'Oracle VM VirtualBox Extension Pack'.
00:00:48.635 ExtPackInst ExtPack: Executing '/opt/VirtualBox/VBoxExtPackHelperApp''install' '--base-dir' '/opt/VirtualBox/ExtensionPacks' '--cert-dir' '/opt/VirtualBox/ExtPackCertificates' '--name' 'Oracle VM VirtualBox Extension Pack' '--tarball' '/Daten/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.2.18.vbox-extpack' '--sha-256' '3ecb43c71502741f4eb790576c608eb65cd424bcf3dfdb56471e4a2cac806f68'
00:01:00.308 ExtPackInst ExtPack: enmReason=1 iStatus=0 stderr='rcExit=RTEXITCODE_SUCCESS
00:01:00.308 ExtPackInst '
00:01:00.308 ExtPackInst ExtPackManager: Found bad extension pack 'Oracle VM VirtualBox Extension Pack': VBoxExtPackRegister returned VERR_VERSION_MISMATCH, pReg=0000000000000000 ErrInfo='Helper version mismatch - expected 0x10002 got 0x10000'
00:01:00.308 ExtPackInst ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={3295e6ce-b051-47b2-9514-2c588bfe7554} aComponent={ExtPackManager} aText={VBoxExtPackRegister returned VERR_VERSION_MISMATCH, pReg=0000000000000000 ErrInfo='Helper version mismatch - expected 0x10002 got 0x10000'}, preserve=false

Re: [erledigt] VirtualBox 5.2.18 - Mageia6

PostPosted: 16. Aug 2018, 10:22
by ManfredB
Sorry, but Mageia uses own vbox-packages, today 5.2.14.

Therefoe I cannot use 5.2.18.

Gruß
Manfred

Re: VirtualBox 5.2.18 - Mageia6

PostPosted: 16. Aug 2018, 10:23
by socratis
ManfredB wrote:
VirtualBox (XP)COM Server 4.1.18 r78361 linux.amd64 (Jun 20 2012 11:47:56) release log
ManfredB wrote:
'/Daten/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.2.18.vbox-extpack'
ManfredB wrote:
VBoxExtPackRegister returned VERR_VERSION_MISMATCH

I believe that the situation is self-explanatory. You're using a 4.1.18 version from 2012 :shock: (did you try hard to find it in the archives?) with a just released yesterday 5.2.18 ExtPack. And you get a "Version Mismatch" error. No kidding... :roll:

Uninstall what you currently have (except your VMs and settings), then install the latest VirtualBox from the Linux Downloads section. Then install the ExtPack...