bekomme über "NAT" keine Internetverbindung

Allgemeine Diskussionen über den Einsatz von VirtualBox.

bekomme über "NAT" keine Internetverbindung

Postby Gerhard999 » 23. Jul 2018, 18:35

Hallo,

ich möchte gerne eine VM erstellen, welche ins Internet kommt.
Jedoch soll die Maschine isoliert von Host und vom anderen Netzwerkkomponenten sein.

Leider bekomme ich mit der NAT-Definition keine Internetverbindung.

hat hierzu jemand eine Idee ?

Vielen Dank
Gerhard999
 
Posts: 12
Joined: 27. Feb 2018, 14:17

Re: bekomme über "NAT" keine Internetverbindung

Postby Blauvogel » 5. Aug 2018, 11:35

Was meinst du mit NAT-Definition?

NAT wird normalerweise nicht konfiguriert. NAT ist einfach ein Software-Router, der zwischen deiner virtuelle Maschine und deinem Host-System geschaltet wird.

Hat deine VM nur eine Netzwerkkarte, müsste sie vom internen DHCP-Server von VirtualBox eine IP-Adresse im Bereich 10.0.2.0/24 erhalten. Das Standardgateway müsste 10.0.2.2 sein. Der DNS-Server wird von deiner Host-Konfiguration übernommen.

Prüfe bitte, ob deine VM die oben angegebene Konfiguration hat. Natürlich muss in der Konfiguration deiner VM NAT ausgewählt sein. Das kannst du überprüfen, indem du das Kommando VBoxManage showinfo "Name deiner VM" | grep "NIC 1:" ausführst. Ist dein Host ein Windowssystem, ersetze grep durch find.
Blauvogel
 
Posts: 5
Joined: 5. Aug 2018, 10:38
Primary OS: MS Windows other
VBox Version: PUEL
Guest OSses: Windows, Linux


Return to Allgemeine Diskussionen

Who is online

Users browsing this forum: No registered users and 7 guests