Fehler beim Verbinden mit VirtualBox-VM per RDP

Allgemeine Diskussionen über den Einsatz von VirtualBox.

Fehler beim Verbinden mit VirtualBox-VM per RDP

Postby tkansgar » 25. Apr 2018, 21:43

Hallo,

ich habe auf einem Rechner mit Ubuntu 16.04 eine VM mit Ubuntu 14.04 eingerichtet. Diese läuft an sich problemlos. Nun wollte ich mich aber von einem fernen Windows-PC aus per RDP mit der VM verbinden. Dafür hatte ich den entsprechenden Schalter in den VM-Einstellungen eingeschaltet. Als Port habe ich 13389 angegeben. Die Verbindung muss durch einen SSH-Tunnel laufen. In dessen Einstellungen habe ich also den vollständigen Namen des Wirts der VM und 13389 als Remote-Port und als lokalen 33389 angegeben. Die VM läuft, und der Tunnel ist geöffnet. In den RDP-Angaben habe ich localhost und Port 33389 angegeben (wie bei SSH-Tunneln üblich). Trotzdem meldet das Windows-RDP folgendes:

Dieser Computer kann keine Verbindung mit dem Remotecomputer herstellen.

Wiederholen Sie den Verbindungsversuch. Wenn das Problem weiterhin besteht, wenden Sie
sich an den Besitzer des Remotecomputers oder an den Netzwerkadministrator.


In der Ereignisanzeige finde ich ein Ereignis mit der ID 1026 mit folgendem Text:

Die Verbindung mit RDP ClientActiveX wurde getrennt (Ursache= 2308)


Ich habe schon danach gegooglet, finde aber nur Fälle von Windows nach Windows, die mir nicht weiterhelfen. In Zusammenhang mit VirtualBox finde ich nichts passendes. Wer kann mir helfen?

Viele Grüße
tkansgar
tkansgar
 
Posts: 19
Joined: 12. Feb 2016, 13:54
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: Ubuntu 14.04

Re: Fehler beim Verbinden mit VirtualBox-VM per RDP

Postby tkansgar » 27. Apr 2018, 16:03

Hat wirklich niemand eine Idee, was man machen könnte?
tkansgar
 
Posts: 19
Joined: 12. Feb 2016, 13:54
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: Ubuntu 14.04

Re: Fehler beim Verbinden mit VirtualBox-VM per RDP

Postby tkansgar » 5. May 2018, 22:39

Hallo,

das Problem mit der RDP-Verbindung ist (fast) gelöst. Ich habe zweierlei gemacht:
1. Den Schalter "Gleichzeitige Verbindungen erlauben" angeschaltet.
2. Sichergestellt, dass nicht VNC als VRDE-Modul verwendet wird, sondern "Oracle VM VirtualBox Extension Pack".
Eins von beiden muss das Problem behoben haben. Ich weiß aber derzeit noch nicht, welches.

Dafür gibt es jetzt ein neues Problem: Die Reaktion auf Tastendrücke und Mausklicks ist unerträglich langsam. Es dauert etwa 8-9 Sekunden, bis die Reaktion sichtbar wird. Wenn ich gleichzeitig über TurboVNC mit dem Wirt der VM verbunden bin, sehe ich die VM auch im TurboVNC-Client. Und interessanterweise erscheint dort die Reaktion unmittelbar ohne jegliche Verzögerung. Es liegt also nicht an der Übertragung der Tastendrücke an die VM, sondern einzig und allein an der Übertragung des Bildschirminhalts zu mir nach Hause. Nun könnte man meinen, warum ich dann nicht die VM über den TurboVNC-Client bediene. Nun, das mache ich derzeit. Aber da gibt's auch ein Problem: Über den TurboVNC-Client kommen in der VM die falschen Tasten an. Ich vermute, dass das US-amerikanische Tastatur-Layout benutzt wird (z und y sind vertauscht, / liegt auf der &-Taste etc.), obwohl in allen beteiligten Betriebssystemen das deutsche Tastatur-Layout konfiguriert ist. Um dieses Problem will sich der TurboVNC-Entwickler kümmern. Mir geht es hier jetzt hauptsächlich um die langsame Bildübertragung ins RDP-Fenster bei Tastendrücken und Mausklicks. Kennt jemand dafür eine Lösung?

Grüße
tkansgar
tkansgar
 
Posts: 19
Joined: 12. Feb 2016, 13:54
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: Ubuntu 14.04


Return to Allgemeine Diskussionen

Who is online

Users browsing this forum: No registered users and 6 guests