Virtuelle Maschine wird nicht als ausgeführt angezeigt.

Allgemeine Diskussionen über den Einsatz von VirtualBox.

Virtuelle Maschine wird nicht als ausgeführt angezeigt.

Postby Yunus92 » 27. Mar 2018, 09:49

Hallo,

ich habe bei der Aufgabenplanung von Windows 10 eine Virtuelle Maschine eingestellt, welche immer mit dem Systemstart im Headless-Modus ausgeführt werden soll. Dabei wird sie mit dem Benutzer ausgeführt, bei dem man sich nach dem Systemstart anmelden kann. Das funktioniert auch alles soweit, nur habe ich das Problem, dass wenn ich mich anmelde und den VirtualBox Manager starte, steht bei der virtuellen Maschine, dass sie "ausgeschaltet" sei. Die Maschine läuft aber, da man sich über SSH verbinden kann. Wenn ich die Maschine dann herunterfahre und über Cmd genau den gleichen Befehl nochmal ausführe, wird es im VirtualBox Manager richtig angezeigt.

Der Befehl sieht so aus:
"C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" startvm "VM-ID" --type headless

Im Taskmanager werden in beiden Fällen der gleiche Benutzer für den Prozess angezeigt.
Woran könnte das liegen?

Für die Leute die sich fragen, warum ich das brauche:
Man hat im VirtualBox Manager die Möglichkeit, die GUI der virtuellen Maschinen, die anfangs im Headless-Modus gestartet wurden im Nachhinein anzuzeigen.

MfG
Yunus92
Yunus92
 
Posts: 1
Joined: 27. Mar 2018, 09:26

Re: Virtuelle Maschine wird nicht als ausgeführt angezeigt.

Postby ZeFix » 28. Dec 2018, 13:20

Altbekanntes Problem. Zwei getrennte Start-Kontexte (Sessions) kann VirtualBox leider immer noch nicht.
Sind dann 2 getrennte COM Prozesse, die voneinander isoliert arbeiten.

Ich würde mich auch freuen, wenn das mal als ein zentraler Prozess im System verankert warden würde.
Da gibts leider aktuell keine wirkliche Lösung dafür
ZeFix
 
Posts: 2
Joined: 28. Dec 2018, 13:17


Return to Allgemeine Diskussionen

Who is online

Users browsing this forum: No registered users and 3 guests