Netzwerk einrichten Win 10 Host und Debian Gast

Allgemeine Diskussionen über den Einsatz von VirtualBox.

Netzwerk einrichten Win 10 Host und Debian Gast

Postby rammi22 » 28. Jul 2017, 09:27

Hallo,

seid 2 Tagen versuche ich von meinen Win10 Host (Wirt) auf die virtuelle Maschine zuzugreifen. Als Fehler bekomme ich immer wieder
Code: Select all   Expand viewCollapse view
C:\Users\xxx>net use y: \\192.168.56.1\
Systemfehler 53 aufgetreten.

Der Netzwerkpfad wurde nicht gefunden.


Das Ziel soll sein, das die VM als Server für lokale Webseiten dient. Die Skripte werden auf dem Windowshost enstwickelt.

Installiert habe ich:
- Win 10
- VB Version 5.1.24 r117012 (Qt5.6.2)
- als VM Debia 9 (stretch)
- Samba

ipconfig:
Code: Select all   Expand viewCollapse view
C:\Users\xxx>ipconfig

Windows-IP-Konfiguration
...
Ethernet-Adapter VirtualBox Host-Only Network:

   Verbindungsspezifisches DNS-Suffix:
   Verbindungslokale IPv6-Adresse  . : fe80::ec05:f13d:70b7:b62e%8
   IPv4-Adresse  . . . . . . . . . . : 192.168.56.1
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Standardgateway . . . . . . . . . :
...


Einstellung in der /etc/network/interfaces
Code: Select all   Expand viewCollapse view
...
auto ethl
iface ethl inet static
  address 192.168.56.2
  netmask 255.255.255.0


/etc/samba/smb.conf:
Code: Select all   Expand viewCollapse view
[global]
   workgroup = WORKGROUP
   netbios name = HALLORAMMI
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
   usershare allow guests = yes
[homes]
   comment = Home Directories
   browseable = no
   read only = yes
   create mask = 0700
   directory mask = 0700
   valid users = %S
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
[freigabe]
   path = /media
   public = yes
   writable = yes
   read only = no
   create mask = 0777


wenn irgendeine Ausgabe fehlt, bitte schreiben. Ansonsten wäre ich für jede Hilfe Dankbar.

Benutzte Tuts (u.a.): kann ich leider nicht posten, Forumregeln...

*** EDIT ***
eine fehlermeldung
Code: Select all   Expand viewCollapse view
root@xxx:/home/rammi# systemctl status networking.service
● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2017-07-28 09:30:58 CEST; 28min ago
     Docs: man:interfaces(5)
  Process: 550 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
  Process: 343 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --exclude=lo)" ] && udevadm settle (code=exited, status=0/SUCCESS)
 Main PID: 550 (code=exited, status=1/FAILURE)

Jul 28 07:12:44 magi-virtual-debian systemd[1]: Starting Raise network interfaces...
Jul 28 09:30:58 magi-virtual-debian ifup[550]: Cannot find device "eth1"
Jul 28 09:30:58 magi-virtual-debian ifup[550]: ifup: failed to bring up eth1
Jul 28 09:30:58 magi-virtual-debian systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
Jul 28 09:30:58 magi-virtual-debian systemd[1]: Failed to start Raise network interfaces.
Jul 28 09:30:58 magi-virtual-debian systemd[1]: networking.service: Unit entered failed state.
Jul 28 09:30:58 magi-virtual-debian systemd[1]: networking.service: Failed with result 'exit-code'.
rammi22
 
Posts: 5
Joined: 28. Jul 2017, 08:35

Re: Netzwerk einrichten Win 10 Host und Debian Gast

Postby ThomasK. » 28. Jul 2017, 11:23

Hallo rammi22,

was mir als erstes mal auffällt, wenn ich richtig sehe hat dein Windows Host die IP \\192.168.56.1\ und dein Debian-Gast die IP \\192.168.56.2\
Mit dem Befehl
Code: Select all   Expand viewCollapse view
net use y: \\192.168.56.1\
würdest du ja von deinem Host auf deinen Host zuzugreifen, der Gast hätte ja die ".2" am Ende.

Der Befehl würde aber auch mit der ".2" nicht funktionieren, da du noch den Freigabenamen des Ordners ergänzen musst, also z.B.:
Code: Select all   Expand viewCollapse view
net use y: \\192.168.56.2\Transport

für den Fall das du den freigegebenen Ordner Transport genannt hast.

Zur Sicherheit bitte auch noch prüfen ob der Windows-Host sich auch wie der Gast in der Arbeitsgruppe WORKGROUP befindet (kann ich anhand der Logs nicht erkennen).

Was die Fehlermeldung angeht, mit
Code: Select all   Expand viewCollapse view
ifconfig -a

den neuen Namen deines Adapters finden und in der /etc/network/interfaces "eth1" durch den neuen Namen ersetzen.

Gruß Thomas
ThomasK.
 
Posts: 3
Joined: 7. Apr 2014, 13:56

Re: Netzwerk einrichten Win 10 Host und Debian Gast

Postby rammi22 » 28. Jul 2017, 12:26

ThomasK. wrote:Hallo rammi22,

was mir als erstes mal auffällt, wenn ich richtig sehe hat dein Windows Host die IP \\192.168.56.1\ und dein Debian-Gast die IP \\192.168.56.2\...

Gruß Thomas

Vielen Dank für die Antwort, es war tatsächlich die falsche IP. Damit bin ich schon mal einen grossen Schritt weitergekommen
rammi22
 
Posts: 5
Joined: 28. Jul 2017, 08:35


Return to Allgemeine Diskussionen

Who is online

Users browsing this forum: No registered users and 6 guests