USB funktioniert nicht

Allgemeine Diskussionen über den Einsatz von VirtualBox.

USB funktioniert nicht

Postby nierewa » 8. Mar 2011, 09:22

Hallo.

Benutze die aktuelle Version 4.04.
Die Gasterweiterungen und die Extras installiert.

Wenn die virtuelle Maschiene läuft und ich stecke einen USB Stick an, wird er nicht erkannt.
Das heißt er erscheinen nicht unter USB-Geräte.
Außer ich habe sie schon am USB-Port stecken, bevor ich den "richtigen, echten" PC hochfahre.

Deinstalliere ich im Gerätemanager unter "Nicht-PnP-Treiber" den VirtualBox USB Monitor Driver ohne Neu zu starten wie vom BS gewünscht,
wird das USB Gerät auch aufgeführt (nicht ausgegraut), aber geht nicht einzubinden.
Ich wähle es aus, aber es passiert nichts.
Wähle ich es nochmals aus erhalte ich eine Fehlermeldung:

Code: Select all   Expand viewCollapse view
    Fehlercode:
    E_INVALIDARG (0x80070057)
    Komponente:
    HostUSBDevice
    Interface:
    IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
    Callee:
    IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}


Entferne ich das Gerät vom Host, ist es in der Liste der USB-Geräte jedoch immer noch aufgeführt.

Ich benutze ein USB Desktop Set.
Dieses wird als MOSART Semi. Input device aufgeführt. Es ist immer aufgelistet und funktioniert auch.

Ich habe ein Board mit USB 3. Das Gastsystem ist Windows XP. Das Hostsystem ebenfalls.
nierewa
 
Posts: 10
Joined: 16. Feb 2011, 11:25
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Windows XP

Re: USB funktioniert nicht

Postby nierewa » 10. Mar 2011, 17:03

Hat wirklich keiner einen Tip?
nierewa
 
Posts: 10
Joined: 16. Feb 2011, 11:25
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Windows XP

Re: USB funktioniert nicht

Postby stefan.becker » 10. Mar 2011, 17:34

Außer USB Filtern wüsste ich nicht, was da helfen sollte.
stefan.becker
Volunteer
 
Posts: 7386
Joined: 7. Jun 2007, 21:53

Re: USB funktioniert nicht

Postby nierewa » 23. Mar 2011, 11:08

Das hat leider nichts gebützt :cry:

Ich hab ein Mainboard mit AMD Chipsatz. Kann es daran liegen?
nierewa
 
Posts: 10
Joined: 16. Feb 2011, 11:25
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Windows XP

Re: USB funktioniert nicht

Postby nierewa » 23. Mar 2011, 22:13

Habe irgendwo in den Weiten des Internet diese Anleitung gefunden.
Jetzt funktioniert alles :D
Code: Select all   Expand viewCollapse view
Start-->Ausführen-->regedit
Enter drücken
Den Reg-Schlüssel: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{36FC9E60-C465-11CF-8056-444553540000} öffnen
Die Zeile "UpperFilter"..."usbfilter" löschen
x64 Host-System neu starten
Die Oracel VM VirtualBox starten und unter USB das USB-Gerät hinzufügen (Filter)
Dann die Virtuelle Maschine starten.
Unter Geräte-->USB-Geräte das USB-Gerät aussuchen welchen ihr in der VBox nutzen wollt.
Sollte es immernoch nicht gehen die VBox nochmal ausmachen, USB-Gerät abstecken, Host neustarten
VBOX starten und nochmal auf Geräte-->USB-Geräte klicken
Dann gehts bestimmt
nierewa
 
Posts: 10
Joined: 16. Feb 2011, 11:25
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: Windows XP


Return to Allgemeine Diskussionen

Who is online

Users browsing this forum: Google [Bot] and 2 guests