Centos 5.3 64bit boot problem

Discussions related to using VirtualBox on Mac OS X hosts.

Centos 5.3 64bit boot problem

Postby instigator » 25. Nov 2009, 00:34

I was virtual box running on Windows 7 RC and have now transferred to mac, but when i open the vdi file in mac and try and boot centos 5.3 x64 i get this error message and it doesn't boot:

Memory for crash kernel (0x0 to 0x0) notwithin permissible range

Kernel alive
kernel direct mapping tables up to 100000000 @ 8000-d000


does anyone know what the problem could be? i have tried lots of different settings for the virtual including the memory size and it is set on redhat 64 as the OS at the current time. I have tried different options and i received the same result.
instigator
 
Posts: 2
Joined: 25. Nov 2009, 00:29
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Mac OS X

Re: Centos 5.3 64bit boot problem

Postby instigator » 25. Nov 2009, 03:37

got it sorted.

for anyone else who is having this problem, try this:

enable IO APIC, then when booting edit the boot command by adding noapic parameter. No idea why this fixed the issue for me, but im just happy its working.

If this does fix it for you, you will probably want to edit /boot/grub/menu.lst so it will automatically add the parameter when booting the virtual.
instigator
 
Posts: 2
Joined: 25. Nov 2009, 00:29
Primary OS: Mac OS X Leopard
VBox Version: OSE other
Guest OSses: Mac OS X

Re: Centos 5.3 64bit boot problem

Postby nreaction » 11. Dec 2009, 08:06

Instigator,

Thank you so much for posting your fix, my windows xp crashed and my web application was stored on the VM and i couldn't figure out how to get past that Memory Crash. thank you again

nreaction
nreaction
 
Posts: 1
Joined: 11. Dec 2009, 08:02
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: centos 5.4

Re: Centos 5.3 64bit boot problem

Postby rpmurray » 11. Dec 2009, 15:56

instigator wrote:enable IO APIC, then when booting edit the boot command by adding noapic parameter. No idea why this fixed the issue for me, but im just happy its working.


According to the VirtualBox manual, you have to enable IO APIC if you want to run a 64-bit guest.

Page 48 (VB 3.1.0)
Note: Enabling the I/O APIC is required for 64-bit guest operating systems,
especially Windows Vista; it is also required if you want to use more than one
virtual CPU in a virtual machine.
rpmurray
Volunteer
 
Posts: 917
Joined: 3. Mar 2009, 00:29
Location: Between Heaven and Hell
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Windows 7, Mac OS X (various flavors)

Re: Centos 5.3 64bit boot problem

Postby gimel » 18. Jul 2011, 10:58

instigator wrote:enable IO APIC

I just enabled it without changing grub and it works. I have the warning but the boot process continues.

Thanks for the hint.


rpmurray wrote:According to the VirtualBox manual, you have to enable IO APIC if you want to run a 64-bit guest.

Oh, never read that anywhere.
Thanks.
gimel
 
Posts: 14
Joined: 6. Jan 2010, 12:31
Location: Lyon, France
Primary OS: MS Windows 2008
VBox Version: OSE other
Guest OSses: Windows 2003


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: scottgus1 and 21 guests