Keine USB unterstützung unter Linux / Ubuntu ???

Allgemeine Diskussionen über den Einsatz von VirtualBox.

Keine USB unterstützung unter Linux / Ubuntu ???

Postby mh75 » 28. Dec 2008, 20:54

Hi Gemeinde,

bin seit kurzem auf Linux umgestiegen und benötige noch ein Windoof auf dem meinem Rechner.
Da ich unter anderem USB unterstützung brauche, wollte ich es mit Vbox probieren.
Allerdings findet Vbox kein einziges Gerät, dass ich am USB port einstecke.
Geht usb unter ubuntu nicht, oder liegt der Fehler an meinem Rechner?
Auf dem Host arbeiten Alle USB Ports makellos!

mfg mh75

PS. frohes Fest und einen Guten Rutsch euch allen :lol:
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Postby stefan.becker » 28. Dec 2008, 21:15

VirtualBox unterstützt kein Windoof als Gast.

Diverse Windows Varianten gehen. Eventuell hast du ja die richtige auch im Zugriff.

Ansonsten bitte das Handbuch und die FAQs lesen, das Thema wird ausführlich beschrieben.
stefan.becker
Volunteer
 
Posts: 7047
Joined: 7. Jun 2007, 21:53

Postby linjerry » 28. Dec 2008, 23:14

Hallo mh75,

Virtualbox soll MS Fenster 4, 5, 6 und sogar 7 als Gast unterstützen. Für 5 = 2000 kann ich das bestätigen.
In der Open Source Edition ohne, in der SUN-binary-Version mit USB-Unterstützung.
Du kommst am schnellsten zum Ziel, wenn Du Dir einmal das Manual, die FAQs und HowTos durchliest.
==> http://www.virtualbox.org/wiki/Documentation
linjerry
 
Posts: 4
Joined: 27. Dec 2008, 20:40

Postby mh75 » 5. Jan 2009, 13:06

Hallo,

erst mal danke für eure tipps,

habs fast hinbekommen, inzwischen erscheinen die verschiedenen angeschlossenen geräte in den einstellungen des jeweiligen virtuellen xp.
allerdings nicht im jeweiligen system, also um genau zu sein, sehe ich zwar im laufenden virtuellen xp unter geräte - usb die verschiedenen vorher aktivierten usb geräte, sie sind
aber grau unterlegt und nicht mit der maus aktivierbar, egal wann und wie ich die usb geräte anstecke.

was fehlt bei mir noch?


mfg mh75
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Postby stefan.becker » 5. Jan 2009, 20:24

Kann man ohne Infos nicht sagen.

Was wie eingerichtet? Was für Geräte sind es? Gehen die Geräte auch am Host?
stefan.becker
Volunteer
 
Posts: 7047
Joined: 7. Jun 2007, 21:53

Postby mh75 » 5. Jan 2009, 20:42

zumindest die usb platten und -stick funktionieren am host.

habe kubuntu 8.10 und folgendes in fstab eingegeben:

none /proc/bus/usb usbfs devgid=1001,devmode=664 0 0

danach konnte ich in den vm einstellungen die usb geräte, die ich ansteckte sehen und hinzufügen. Als ich dann mein xp startete, fand ich die hinzugefügten geräte im menü unter geräte-usb, sie waren aber alle grau unterlegt und nicht markierbar. Unter arbeitsplatz wurden auch keine angezeigt, wenn sie neu angesteckt wurden, bzw. im angesteckten zustand hochgefahren wurde!


mfg mh75
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Postby mh75 » 5. Jan 2009, 20:50

mh75 wrote:zumindest die usb platten und -stick funktionieren am host.

habe kubuntu 8.10 und folgendes in fstab eingegeben:

none /proc/bus/usb usbfs devgid=1001,devmode=664 0 0

danach konnte ich in den vm einstellungen die usb geräte, die ich ansteckte sehen und hinzufügen. Als ich dann mein xp startete, fand ich die hinzugefügten geräte im menü unter geräte-usb, sie waren aber alle grau unterlegt und nicht markierbar. Unter arbeitsplatz wurden auch keine angezeigt, wenn sie neu angesteckt wurden, bzw. im angesteckten zustand hochgefahren wurde!
am usb icon in der unteren leiste des bildschirmes werden alle hinzugefügten usb geräte in grau angezeigt, wenn ich aber mit der maus draufklicke, bekomme ich die info, dass kein usb gerät vorhanden ist.


mfg mh75
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Postby stefan.becker » 5. Jan 2009, 21:33

Lies mal in der FAQ nach. Für SchnickSchnackBuntu muss man mehr machen.
stefan.becker
Volunteer
 
Posts: 7047
Joined: 7. Jun 2007, 21:53

Postby mh75 » 8. Jan 2009, 00:09

jetzt hab ich's wie beschrieben gemacht,

komm aber auf keinen grünen zweig!!!

meine fstab:

Code: Select all   Expand viewCollapse view
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda6
UUID=66400679-de1d-4749-bb82-d0f72e529ac3 /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda7
UUID=c076f4ef-9ce2-4ea9-a23d-c9893d71cebc none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
none  /proc/bus/usb  usbfs  auto,busgid=125,busmode=0775,devgid=125,devmode=0664  0  0




meine /etc/init.d/mountdevsubfs.sh:

Code: Select all   Expand viewCollapse view
#! /bin/sh
### BEGIN INIT INFO
# Provides:          mountdevsubfs
# Required-Start:    mountkernfs
# Required-Stop:
# Should-Start:      udev
# Default-Start:     S
# Default-Stop:
# Short-Description: Mount special file systems under /dev.
# Description:       Mount the virtual filesystems the kernel provides
#                    that ordinarily live under the /dev filesystem.
### END INIT INFO
#
# This script gets called multiple times during boot
#

PATH=/lib/init:/sbin:/bin
TTYGRP=5
TTYMODE=620
[ -f /etc/default/devpts ] && . /etc/default/devpts

TMPFS_SIZE=
[ -f /etc/default/tmpfs ] && . /etc/default/tmpfs

KERNEL="$(uname -s)"

. /lib/lsb/init-functions
. /lib/init/mount-functions.sh

do_start () {
   #
   # Mount a tmpfs on /dev/shm
   #
   SHM_OPT=
   [ "${SHM_SIZE:=$TMPFS_SIZE}" ] && SHM_OPT=",size=$SHM_SIZE"
   domount tmpfs shmfs /dev/shm tmpfs -onosuid,nodev$SHM_OPT

   #
   # Mount /dev/pts. Master ptmx node is already created by udev.
   #
        domount devpts "" /dev/pts devpts -onoexec,nosuid,gid=$TTYGRP,mode=$TTYMODE

mkdir -p /dev/bus/usb/.usbfs
      domount usbfs "" /dev/bus/usb/.usbfs usbfs -obusmode=0700,devmode=0600,listmode=0644
      ln -s .usbfs/devices /dev/bus/usb/devices
      mount --rbind /dev/bus/usb /proc/bus/usb



}

 



case "$1" in
  "")
   echo "Warning: mountdevsubfs should be called with the 'start' argument." >&2
   do_start
   ;;
  start)
   do_start
   ;;
  restart|reload|force-reload)
   echo "Error: argument '$1' not supported" >&2
   exit 3
   ;;
  stop)
   # No-op
   ;;
  *)
   echo "Usage: mountdevsubfs [start|stop]" >&2
   exit 3
   ;;
esac



normal muss das doch klappen!!!

mfg mh75
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Postby stefan.becker » 8. Jan 2009, 22:13

sudo /etc/init.d/mountdevsubfs.sh start

Sagt was?
stefan.becker
Volunteer
 
Posts: 7047
Joined: 7. Jun 2007, 21:53

Postby mh75 » 8. Jan 2009, 22:25

Code: Select all   Expand viewCollapse view
sudo /etc/init.d/mountdevsubfs.sh start


sagt:

Code: Select all   Expand viewCollapse view
ln: Erzeuge symbolische Verknüpfung „/dev/bus/usb/devices“: File exists



Sobald ich ein usb gerät anstecke ... usb stick, wird dieser am icon (unterer rand) aktualisiert, trotzdem heisst es "kein usb gerät angeschlossen"
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Postby stefan.becker » 8. Jan 2009, 23:02

Schon mal die USB Filter getestet?
stefan.becker
Volunteer
 
Posts: 7047
Joined: 7. Jun 2007, 21:53

Postby mh75 » 8. Jan 2009, 23:08

was soll ich dort testen?

fernzugriff?!?
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Postby stefan.becker » 9. Jan 2009, 00:21

Nein, bestimmt nicht. Mit den Filtern kannst du in der VBOX Oberfläche USB Geräte zielgerichtet weitergeben.

PS: Was sagen denn folgende Befehle:


cat /etc/group | grep vbox
ls -l /dev/bus/usb/devices
stefan.becker
Volunteer
 
Posts: 7047
Joined: 7. Jun 2007, 21:53

Postby mh75 » 9. Jan 2009, 09:43

Code: Select all   Expand viewCollapse view
vboxusers:x:125:


und
Code: Select all   Expand viewCollapse view
lrwxrwxrwx 1 root root 14 2009-01-09 08:39 /dev/bus/usb/devices -> .usbfs/devices



kann es noch was mit den benutzerrechten zu tun haben?
mfg mh75
mh75
 
Posts: 28
Joined: 22. Oct 2007, 14:37

Next

Return to Allgemeine Diskussionen

Who is online

Users browsing this forum: No registered users and 2 guests