virtuelle Disk lässt sich nicht löschen

Allgemeine Diskussionen über den Einsatz von VirtualBox.

virtuelle Disk lässt sich nicht löschen

Postby bluelupo » 18. Nov 2008, 20:45

Hallo zusammen,
ich habe in einer virt. Maschine (Host: Linux Gast: Linux) zwei Disks erstellt. Die zweite (sdb) möchte ich nun gerne wieder löschen. Leider lässt sich im Medienmanager diese Disk nicht entfernen (Buttons sind ausgegraut). Die virt. Maschine selbst hat nur noch eine Disk (sda). Wie kann ich die zweite Disk löschen?

Ciao
bluelupo

Version:
virtualbox-2.0 2.0.4-38406_Debian_lenny Sun xVM VirtualBox
Host: Sidux 2008-03 (Kernel 2.6.27-6.slh.5-sidux-amd64)
bluelupo
 
Posts: 7
Joined: 18. Nov 2008, 20:37

Re: virtuelle Disk lässt sich nicht löschen

Postby fixedwheel » 18. Nov 2008, 21:57

Hi,
bluelupo wrote:Leider lässt sich im Medienmanager diese Disk nicht entfernen (Buttons sind ausgegraut).

erst das .vdi file Freigeben - der Button neben dem ausgegrauten Entfernen
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Re: virtuelle Disk lässt sich nicht löschen

Postby bluelupo » 18. Nov 2008, 23:49

fixedwheel wrote:erst das .vdi file Freigeben - der Button neben dem ausgegrauten Entfernen

Hi fixedwheel,
freigeben geht ebenso wenig, da ebenfalls deaktiviert (ausgegraut). Auch ein manuelles verschieben des vdi-Files aus vbox-Ordner bringt nur eine Fehlermeldung beim Start von vbox (Medldung sinngemäß: Zugriff auf eine virt. Festplatte nicht mehr möglich bis das Problem behoben ist).
bluelupo
 
Posts: 7
Joined: 18. Nov 2008, 20:37

Postby fixedwheel » 19. Nov 2008, 00:08

läuft die virtuelle Maschine noch, oder ist sie ausgeschaltet mit sichern des Zustands (VBoxManage controlvm <vm> savestate) oder snapshots vorhanden?



hier ist virtualbox-2.0 2.0.4-38406_Debian_lenny auf einem Debian Lenny x86, und keine generellen Probleme mit löschen von VDI über den virtuellen Medienmanager
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Postby bluelupo » 19. Nov 2008, 09:45

fixedwheel wrote:läuft die virtuelle Maschine noch, oder ist sie ausgeschaltet mit sichern des Zustands (VBoxManage controlvm <vm> savestate) oder snapshots vorhanden?

Das ganze habe ich im ausgeschalteten Zustand versucht. Die VM zeigt im ausgeschalteten Zustand unter "Details" nur noch eine primäre Disk an und trotzdem kann die ehemalige zweite eingebunden Disk nicht im Medienmanager freigegeben bzw. entfernt werden. Ich bin auch schon zum ersten Sicherungspunkt zurück was aber leider nichts gebracht hat.

Hier bei mir läuft ein Sidux 2008-03 64 Bit (basiert auf Debian SID).
bluelupo
 
Posts: 7
Joined: 18. Nov 2008, 20:37

Postby xeno » 19. Nov 2008, 22:53

interessant wäre die fehlermeldung auf der konsole:

VBoxManage modifyvm $name_der_maschine -hdaX none

Dann die Registrierung des Image aufheben:

VBoxManage unregisterimage disk $name_der_festplatte.vdi
xeno
 
Posts: 30
Joined: 18. Aug 2008, 14:42

Postby ro » 24. Nov 2008, 14:13

Ich habe das selbe Problem wie bluelupo. Ich kann kein Image fntfernen oder freigeben - die Buttons sind ausgegraut.


VBoxManage modifyvm $name_der_maschine -hdaX none bringt:
Code: Select all   Expand viewCollapse view
user@machine:~$ VBoxManage modifyvm Windows\ XP -hda none
VirtualBox Command Line Management Interface Version 2.0.4
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.


So weit so gut.

VBoxManage unregisterimage disk $name_der_festplatte.vdi hingegen führt zu einer Fehlermeldung:
Code: Select all   Expand viewCollapse view
user@machine:~$ VBoxManage unregisterimage disk Windows\ XP.vdi
VirtualBox Command Line Management Interface Version 2.0.4
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

[!] FAILED calling virtualBox->UnregisterHardDisk(uuid, hardDisk.asOutParam()) at line 6704!
[!] Primary RC  = NS_ERROR_FAILURE (0x80004005) - Operation failed
[!] Full error info present: true , basic error info present: true
[!] Result Code = NS_ERROR_FAILURE (0x80004005) - Operation failed
[!] Text        = Hard disk '/home/user/.VirtualBox/VDI/Windows XP.vdi' is attached to a virtual machine with UUID {b9978bd1-c62b-46a7-b0e6-4ae8eb0aebdd}
[!] Component   = HardDisk, Interface: IHardDisk, {fd443ec1-000f-4f5b-9282-d72760a66916}
[!] Callee      = IVirtualBox, {557a07bc-e6ae-4520-a361-4a8493199137}


Das alles unter Ubuntu Intrepid mit VirtualBox 2.0.4.
ro
 
Posts: 14
Joined: 17. Jul 2008, 11:51

Postby ro » 26. Nov 2008, 15:30

Die Lösung war einfach: Alle Snapshots löschen und dann gings wieder!
ro
 
Posts: 14
Joined: 17. Jul 2008, 11:51


Return to Allgemeine Diskussionen

Who is online

Users browsing this forum: No registered users and 6 guests