Stuttering Sound - For Windows and Linux Guests

Discussions related to using VirtualBox on Linux hosts.

Stuttering Sound - For Windows and Linux Guests

Postby Gruelius » 2. Jul 2007, 18:37

Hey all,
For the life of me i cant figure out what i did to upset Virtualbox but now whenever any sounds are created by the guest they come out as slightly distorted elongated sounds with constant stuttering. If you need me to i can record it with a microphone of somesort.

It happens in my XP guest and when i use the ubuntu live cd.

I use the alsa driver for my virtual machines.

My PC is running KDE on FF 7.04 ubuntu

thanks
Julius
Gruelius
 
Posts: 2
Joined: 2. Jul 2007, 18:34

Postby nburles » 7. Jul 2007, 01:21

I have this same problem... all sounds are stuttering in my guest (WinXP, though I checked it with the live cd also).

I tried installing the low-latency kernel in case that helped, but to no avail. Could it be related to the sound card in use? (Mine is the hd-audio riser card that comes with the Asus Striker Extreme)

Thanks,
Nathan
nburles
 
Posts: 4
Joined: 7. Jul 2007, 01:15

Postby stefan.becker » 7. Jul 2007, 10:40

Sound in a VM uses EMulation. That can not have the Quality of the original sound card.Forget it, use the Host for Multimedia.

Except of crippled downloaded mp3 with copy protrection is multimedia on a linux host no problem.
stefan.becker
Volunteer
 
Posts: 7576
Joined: 7. Jun 2007, 21:53

Postby nburles » 7. Jul 2007, 11:15

The only reason I want sound to work in the XP guest is so I can use skype with video... it doesn't need to be high quality, just not stuttering / choppy. Apart from that, there's nothing I want to do in XP that I cannot do in linux (ubuntu 7.04).

Cheers,
Nathan
nburles
 
Posts: 4
Joined: 7. Jul 2007, 01:15

Postby stefan.becker » 7. Jul 2007, 16:42

The only setting i know is to play with to choose alsa or oss in the Guest Configuration.
stefan.becker
Volunteer
 
Posts: 7576
Joined: 7. Jun 2007, 21:53

Postby nburles » 7. Jul 2007, 17:41

Yeah, I tried that already :-(

I'm just setting it up on another system (with another built-in sound card) to see if that one works - if so I guess I'm out of luck for this system as I can't afford to buy a sound card!

Cheers,
Nathan
nburles
 
Posts: 4
Joined: 7. Jul 2007, 01:15

Postby stefan.becker » 7. Jul 2007, 19:52

Try this. But i dont think thats the real sound card is the problem.
stefan.becker
Volunteer
 
Posts: 7576
Joined: 7. Jun 2007, 21:53

Postby nburles » 7. Jul 2007, 20:12

It works perfectly (having done exactly the same) - including mixing the host and guest sounds - on the older shuttle system, so there must be an issue either with the sound card support in my host (which I don't think there is as it plays perfectly) or in the emulated card (when running on my real card).

Ah well, thanks for trying :),
Nathan
nburles
 
Posts: 4
Joined: 7. Jul 2007, 01:15

Postby sjc1963 » 9. Jul 2007, 02:27

I just recently switched from Vista Home Basic to Ubuntu Feisty Fawn 7.04 and I would like to use my old Creative Labs External USB modem as an answering machine as I had done under Windows. My Windows XP guest (What I had before getting Vista) recognizes the modem just fine, but the quality of the transmission is terrible. It only hears 1 ring and just sits there waiting until it times out. I had it call my cell and it couldn't dial out because the phone couldn't understand the garbled carrier tones. I tried switching the sound engines and it does sound better in the Guest, but still no go though the modem. I have an Audigy 2 Value sound card.
sjc1963
 
Posts: 1
Joined: 9. Jul 2007, 02:16

Re: Stuttering Sound - For Windows and Linux Guests

Postby jsffive » 27. May 2009, 04:24

I had a similar problem. When I installed XP as a guest, the sounds would stutter, and yet, when I would install a Linux distro, I didn't have any problems with sound at all. That SHOULD have keyed me to the problem, however, that I still fought with this for months.

To begin with I have a 2.4 Pentium 4 CPU, with 4 gigs of RAM (1024 MB dedicated for the guest), and AC'97 sound on the system board.

I tried downloading the drivers from Realtek and installing them, but it didn't help. So, as a last resort, I went into device manager, right-mouse-clicked on the sound card driver, selected "update driver", and when the prompt asked me if Windows could go out the the Internet to find the driver, I selected "No, not this time", and clicked on "Next". The next window asks if you want to install automatically or from a list. I selected "Install from a list or specific location", then clicked "Next". In the next window, I chose "Don't search. I will choose the driver to install.", then I clicked on "Next". In the next window, I selected the INTEL driver (for my computer, it was the Intel(r) 82801AA AC'97 Audio Controller) and let it install that driver instead of the default Vinyl AC'97. After a reboot, my sound problem went away.

My guess would be that the default driver is a resource hog, whereas the Intel driver is stripped down and less cumbersome.

In any event, I hope this helps someone out there.
jsffive
 
Posts: 2
Joined: 27. May 2009, 04:06
Primary OS: PCLinuxOS
VBox Version: PUEL
Guest OSses: XP

Re: Stuttering Sound - For Windows and Linux Guests

Postby MWNZ » 27. May 2009, 06:07

I had this problem with a USB sound device. I run AMD64 Ubuntu 9.04 and WinXP guest. With the default kernel, I had major issues. After intstalling the RT kernel in the apt-repositories, sound is much better. There are some minor dropouts, but it is at least workable (for Skype).
MWNZ
 
Posts: 2
Joined: 27. May 2009, 05:38
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows XP

Re: Stuttering Sound - For Windows and Linux Guests

Postby Pretzel » 14. Jan 2011, 22:38

Hope this helps.

Using Ubuntu 10.10 64 bit host
Windows 7 64 bit guest


Try disabling 2D and 3D Video acceleration.
Pretzel
 
Posts: 1
Joined: 14. Jan 2011, 22:02
Primary OS: Ubuntu other
VBox Version: OSE Fedora
Guest OSses: Win7 64

Re: Stuttering Sound - For Windows and Linux Guests

Postby Yacy » 29. Dec 2011, 15:02

Disabling Intel® HT Technology (Hyper-Threading) in the host Bios settings completely eliminated the audio stuttering in my windows xp guest.
Yacy
 
Posts: 3
Joined: 29. Dec 2011, 14:55
Primary OS: Ubuntu other
VBox Version: OSE other
Guest OSses: Windows XP


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 10 guests