"Other" OSs that VBox can run

Discussions about using non Windows and Linux guests such as FreeBSD, DOS, OS/2, OpenBSD, etc.

"Other" OSs that VBox can run

Postby S.SubZero » 1. Jan 2008, 13:03

Virtualbox is great for virtualizing Windows and Linux. That's all well and good, but they get boring after a while. The drop-down list in VBox has OS/2, Solaris, BSD, Netware, L4.. Yay.

There's also that.. "Other/Unknown" option. Hmm.. What "Other/Unknown" OSs have you tried in VBox?

(I don't use USB so I have it disabled and untested on all guests)

BeOS, maybe?

Install: A little tricky
Settings: 512MB RAM, 8MB Video, ACPI enabled, VT-x disabled, 1280x1024x16 custom video mode
Support: VESA video (w/3rd party app), network, sound (flaky)
Speed: Interface feels slow, disk access is pretty bad
Stability: Decent, but leave VT-x off!
Note: They still port Firefox and Seamonkey to BeOS but they run VERY slow



Install: Rough, but procedures can be found on Google
Settings: 512MB RAM, 8MB Video, ACPI/VT-x disabled, 1400x1050x32 custom video mode
Support: VESA video (after last patch), network
Speed: Probably beyond native, since the fastest PC it likely ever saw in it's day was barely a Pentium II
Stability: Good! (not that it can do much)
Note: virtualbox.org cannot properly render in nine year old web browsers.


Perhaps some Rhapsody?

Install: Same as OpenStep
Settings: 192MB RAM, 8MB Video, ACPI/VT-x disabled, video cannot go to VESA
Support: Nothing, really ; ;
Speed: Unbearably slow, due to the lack of VESA
Stability: Good, tho it did BSOD my host once, might have been VT-x on at the time.
Note: Rhapsody is one of the development platforms Apple released during the design and development of OS X. It is basically OpenStep with OS 9 stylings. It also marked an early interest Apple had in the Intel platform, as this is an X86 version, circa 1999.

Speaking of OS 9, let's cheat.

Windows 2000 guest running Mac OS 9.0.4 under SheepShaver, a PPC emulator. It runs as well as can be expected. SheepShaver is very glitchy and unstable, and crashes seemingly at random, but the speed in a VM is about the same as running it straight on XP64. I run it in a VM since SheepShaver can't do networking in XP64.
Posts: 123
Joined: 5. Oct 2007, 21:30

Postby Technologov » 2. Jan 2008, 00:02

Happy New Year !

Well, it's really good that you provide such detailed info & screenshots. I appreciate that very much !

NOTE: Putting Mac OS 9 in this list is technically incorrect, because in this case you use dual-virtualization layers, so you don't test Mac OS 9 on VirtualBox, rather you actually test only "SheepShaver" and Win2000 on VirtualBox - only first layer after the VirtualBox.

-Technologov, 1.1.2008 !
Posts: 3313
Joined: 10. May 2007, 16:59
Location: Israel

Postby soliars » 22. Feb 2008, 12:45

Happy new year!!!

And thank you for your information.
Posts: 3
Joined: 22. Feb 2008, 12:39

Postby Snow123 » 2. Mar 2008, 11:37

Thank you for your information.
Happy new year!!! :D
Posts: 3
Joined: 2. Mar 2008, 11:31

Postby Rohan » 4. Mar 2008, 09:03

Syllable 0.6.5 under VirtualBox Image
Posts: 7
Joined: 4. Mar 2008, 08:40

Postby ThePhwner » 8. Apr 2008, 03:38

Plan 9 guest on a Vista X64 host

Posts: 6
Joined: 8. Apr 2008, 02:46

Postby S.SubZero » 13. Apr 2008, 14:16

Ah very nice, Plan 9! I tried to get that going in the VBox 1.5.2 days but never got the GUI to start. I also realized I had nothing to really do on it so I lost interest.
Posts: 123
Joined: 5. Oct 2007, 21:30

Postby ThePhwner » 13. Apr 2008, 16:05

Hah! I know exactly what you mean - after all the fanfare of getting it running, there is oh so very little to be done with it.

Having a much better time with Fedora 8 and Solaris 10.
Posts: 6
Joined: 8. Apr 2008, 02:46

Postby lugoteehalt » 19. Jun 2008, 12:21

Tried GeexBox - a multimedia, bootable CD. But it didn't really work. I could easilly be doing something wrong.
Posts: 57
Joined: 14. Jun 2008, 12:12

Postby Rhapsody » 10. Jul 2008, 12:22


Install: Froze up on the first attempt, worked fine on the second attempt.
Settings: 128MB RAM, 8MB video RAM, ACPI enabled, VT-x disabled, OS didn't have a clue about the video card or monitor but let me use up to 1024x768x32 anyway.
Support: Didn't test the video much, OS doesn't have sound support at all, didn't test networking.
Speed: Feels pretty quick, but then my PC is quick too.
Stability: A bit glitchy, but then this is alpha quality software. Hasn't crashed so far.
Note: While the ReactOS download page lists four possible emulators to run it on, VirtualBox isn't there! Seems fine to me though.

Haiku (Senryu weekly build)

Install: No install needed, I ran it straight from a pre-made HDD image.
Settings: 128MB RAM, 8MB video RAM, ACPI enabled, VT-x enabled, uses 1024x768x32 (the maximum it'll allow) by default.
Support: No idea about the video, sound doesn't seem to work, didn't test networking.
Speed: Takes a surprising amount of time to load, and the interface feels pretty sluggish.
Stability: A program went down on exit, but the OS seems stable enough. This is actually pre-alpha quality though...
Note: This image was specially made for VirtualBox, so it's not surprising it works well. Enabling VT-x/AMD-V was a suggestion I got from the Haiku development tracker, it apparently crashes on booting without it.
Posts: 4
Joined: 10. Jul 2008, 11:52

Postby RichFellows » 11. Sep 2008, 20:56

Is it at all possible to run a Mac OS on VirtualBox? For example Mac OS X Leopard. I'd like to learn the OS as much as possible but don't want to go buy a new machine. I see above someone did a workaround with an emulator......is this the only way?

/edit Found a thread talking about this.
Posts: 5
Joined: 11. Sep 2008, 20:53

Problems running ReactOS

Postby Paul Abrahams » 13. Sep 2008, 05:59

I was able to get ReactOS started, but when I attempted to install the Guest Additions, the process got stuck just after extracting files and attempting to stop the Vbox Service. I'm running OpenSuSe 11.0, 64-bit version.

I also could not see how to load a web browser -- any web browser.
Paul Abrahams
Posts: 141
Joined: 2. Jun 2008, 17:49

Postby The MAZZTer » 17. Sep 2008, 06:22


NT 3.51 Workstation. Am I the first? Probably not. Oh well. :)

I used the Windows NT 4 OS setting, 64mb ram, 2gb disk. Remember the NT 3.51 CD isn't bootable, you need to use the boot floppies.

Installer auto detects the network card fine.

DHCP works, not sure if you NEED to manually configure the gateway and DNS but I set 'em to and

Gateway works, can't test DNS. No nslookup client or proper web browser. I could not telnet out of the sandbox or access SMB shares. :(

Standard SB16 driver included works. You'll have to open Control Panel and add the driver manually. It will complain about MPU not being found, select "disable" from that drop down and it'll work.

For video, once you install the VGA driver (during setup or in windows) it'll show only 640x480. Reboot and it'll show a slightly better 800x600.

Better Video Drivers here:

Download the drivers (I used the unstable ones).

From the driver archive, get vbe20\nt35x\* and get framebuf.dll from your WINNT dir or disc (use expand.exe on i386\framebuf.dl_) Put all four files together in one directory and get them on the VM somehow (if you don't have networking make a floppy disk image with the files on 'em... I used WinImage).

For some reason the installer wants framebuf.dll. Don't give it the one on the website (that's for NT4!).

Navigate the control panel labyrinth and tell Windows where your "Other" Display drivers live. Turn up the screen res and bit depth! :)

Tried running the VBox Guest Additions installer. Surprisingly it runs, though not very well.


Drat! :)

NT 3.51 is fun to look around in, it showcases the first appearance of some dialogs and features that are still present in XP and Vista. Console Property dialogs, Display property dialog, merging of Network Setup and Control Panel, a shutting down dialog box, etc.

It's also a lot easier to get working than MS-DOS and Windows 3.11 :)

All of this worked without any service packs, fyi, but you'll probably want it anyway: http://support.microsoft.com/kb/128465

If you can't get networking to work download a trial UltraISO or something and stick it on an ISO. You gotta copy it to your HD though cause the updater is gonna want the Windows NT disc.

[Edit: Networking works.

Here is an IE5.0 download and post-SP5 patches: http://www.hpcfactor.com/support/patching/winnt351/ ]

[Edit: I got farther in the VBox Guest Additions installer, just for kicks.

Install the latest hotfixes from ftp://ftp.microsoft.com/bussys/winnt/wi ... s-postSP5/ after installing SP5 (install in ascending hotfix order... pscript and sfm fixes may not apply to you if you have no printer/mac networking).

Then install newshell2.zip from the bottom of this page. This will add shell objects to NT, giving you the desktop, windows explorer, recycle bin, new control panel (sort of), etc. You also get the NT/9x window title bars for free. http://www.geocities.com/bearwindows/winnt351.htm (some good stuff on this page besides that)

As the notes say, NT now acts like it's NT4, so the installer will get farther.


Aw... maybe in VBox3.0 :P
Posts: 129
Joined: 16. Sep 2008, 23:22
Location: Internet
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu, Chromium OS, Windows

Postby SnakeMedia » 26. Oct 2008, 00:25

Hi i am new to Virtual BoX. I want to say a big thanks for test with Game Mapping on Windows XP when I am using ATI Radeon HD on my Computer. Sorry my Language is German in the Picture: Sometime my picture is size big: can you read bette. When I am Virtual Mapper :) lol...

Because problem of ATI Radeon and ATI Radeon HD while you can not use with old Goldsource Mapping like Half-Life Maps ...

I want to tell about Game Mapping can not work on ATI Drivers. I have been inventted a trick of VGA Support for using function. a big Thank for VirtualBox.

I want to ask you, when Mac OS X can work on VirtualBox? Can it not?

Thanks bye SnakeMedia
Posts: 9
Joined: 26. Oct 2008, 00:00

Postby emn8w8 » 29. Oct 2008, 02:44

From IBM....and the 90's..... mistakenly considered death by some...


It just takes some effort to get it installed....

The latest version from IBM: 4.52 (a.k.a. Merlin Convenience Pack)


Installed like a charm....

OS/2 successor: eComStation.
For those who are struggling: yes, it can be done..! :)
This is v 1.2:

and the latest: v 2.0RC5

Installing eCS the standard way is impossible...but a detour can be taken to get it up and running..!

Best regards, Erik
Posts: 45
Joined: 27. Mar 2008, 18:15
Location: Netherlands
Primary OS: openSUSE
VBox Version: PUEL
Guest OSses: OS/2 (Warp 4-4.52), eComStation (1.2...2.0RC7, IBM PC_DOS, Windows XP


Return to Other Guests

Who is online

Users browsing this forum: Google [Bot] and 4 guests