Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

For discussions related to using VirtualBox on Mac OS X pre-releases

Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby Derm FL » 27. Feb 2017, 20:42

I just recently tried to start any VM's after I had upgraded to 10.12.4 Beta.

The error message is this.
Failed to open a session for the virtual machine Decapod.

The virtual machine 'Decapod' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {b2547866-a0a1-4391-8b86-6952d82efaa0}

I tried to upgrade to the latest pre-release of VirtualBox thinking that support for 10.12.4 may be included. The installer fails at "Validating Packages". I found this in the Console logs.
Code: Select all   Expand viewCollapse view
default   13:39:24.688019 -0500   kernel   disabling SMAP for VBoxDrvDarwinIOCtl
default   13:39:24.688026 -0500   kernel   VBoxDrv: vmx_resume=ffffff801e210fe0 vmx_suspend=ffffff801e210f90 vmx_use_count=ffffff801e88e7c0 (0) cr4=0x3627e0
default   13:39:24.688027 -0500   kernel   VBoxDrv: cdevsw_add failed (-1)
default   13:39:24.688028 -0500   kernel   Kext org.virtualbox.kext.VBoxDrv start failed (result 0x5).
default   13:39:24.688030 -0500   kernel   Kext org.virtualbox.kext.VBoxDrv failed to load (0xdc008017).
default   13:39:24.688032 -0500   kernel   Failed to load kext org.virtualbox.kext.VBoxDrv (error 0xdc008017).
default   13:39:24.696490 -0500   kextd   Failed to load /Library/Application Support/VirtualBox/VBoxDrv.kext - (libkern/kext) kext (kmod) start/stop routine failed.


I have tried running the VirtualBox_Uninstall.tool script with reboots before and after but no change in result.

Attached is a copy of the VBox.log from a VM that was last run in Sept 2016. When launching a VM today it apparently does not even get far enough to write a log, perhaps because the VBoxDrv KEXT is not running.

Thanks for any help!

[Mod edit: VBox.log (unzipped) from 5-month old working installation, removed]
Derm FL
 
Posts: 7
Joined: 27. Feb 2017, 20:33

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby socratis » 27. Feb 2017, 21:54

In that case, the log won't tell me anything. Logs are useful when something fails, not when everything is peachy. Plus, it was taking space, since you didn't zip it.

I haven't tried 10.12.4b, but did you do a full install? Did you do an automatic upgrade? Did you download the standalone updater? Is there a standalone updater to begin with? If so, try uninstalling VirtualBox, clearing out the caches, the kext caches, re-apply the updater and re-install VirtualBox. See where that takes you...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby Derm FL » 28. Feb 2017, 03:45

The betas are now installed from the App Store as an update, there is no full installer that I am aware of. It is not possible to uninstall without wiping the system and re-loading. Also I have not found a way to "re-apply" the beta update from the App Store.
I have filed a bug-report with Apple to see if anything comes of that.
Derm FL
 
Posts: 7
Joined: 27. Feb 2017, 20:33

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby socratis » 28. Feb 2017, 11:40

I never said to uninstall 10.12.4b, I know you can't. I asked you if you had the "Automatic updates" on or off, i.e. was this an automatic update, or one initiated by you, on purpose? And BTW, the AppStore won't give you that update unless you're a developer.

So, my next question was: can you download a standalone updater? From the Developer Downloads (https://developer.apple.com/download/)? I can't because you have to be in the paid Apple Developer Program or the Apple Developer Enterprise Program. I'm in the "free" (as in money) channel and I can't download it. The question is: can you?
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby Derm FL » 28. Feb 2017, 16:42

First thank you for your assistance. I do appreciate the responses. Perhaps I have not been explaining my thoughts well.

1) As a developer I have requested Beta updates by downloading the Beta Access utility which enables the Beta updates from the App Store.
2) "...there is no full installer that I am aware of." as they use the Beta Access utility to instruct the App Store to download the beta updates at each stage.
3) Before posting my request in the forum I spent many hours searching the web and these forums to be sure that I did not post my question as a duplicate. I also tried all the steps that I found first. Another result involved someone running beta that did a clean install back to the latest release. I was simply trying to cover all bases and giving you a heads up.

I rarely post in forums because I find that people who "live" in the forums understand all the rules and acceptable practices. I am not here to offend or be little anyone, I would just like to resolve my issue and hopefully help someone else in the future that has this same problem.

Again, thank you for your assistance.
Derm FL
 
Posts: 7
Joined: 27. Feb 2017, 20:33

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby socratis » 28. Feb 2017, 18:06

Derm FL wrote:I would just like to resolve my issue and hopefully help someone else in the future that has this same problem.

Several people have already had the same problem so far, even with normal system minor updates like from 10.12.2 to 10.12.3, that's why I was asking those specific questions. There seems to be a pattern where (and I'm not talking about the beta, I'm talking every day normal use):
  • Automatic updates are enabled.
  • Update is issued, update happens without user realizing it in the background, using "softwareupdated".
  • Kext caches seem to not get invalidated(?) / rebuilt at reboot (?), preventing the new VirtualBox kext to install/work correctly.
  • Re-applying the standalone updater seems to correct the situation, since "softwareupdated" is not involved.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby Derm FL » 7. Mar 2017, 01:18

I guess I am lost as to where we are with this. Are you waiting for me to reply with something or am I waiting to see if there are any updates coming in a future release? I have tried rebuilding the KEXT cache with no change in result.
Derm FL
 
Posts: 7
Joined: 27. Feb 2017, 20:33

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby socratis » 7. Mar 2017, 01:29

I'm not sure why you're lost, I thought I was pretty clear on my last message on what I think the culprit might be. As far as I'm concerned, I'm stuck, since I can't test the beta. All I can do is draw conclusions from past experience and behavior.

Did you have any luck in locating a stand-alone updater? Does such a beast exist? If not, I'm afraid you'll have to wait for someone that has deeper pockets than myself and has subscribed to the Apple Developer Connection (ADC) program, and uses VirtualBox, and knows their way around their intertwined relationship, and faces the same issue.

Have you tried OnyX to clean up your caches (and more)? Give it a shot...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby Derm FL » 14. Mar 2017, 16:24

I installed the latest 10.12.4 Beta yesterday (16E189a) and this morning I opened VirtualBox and it starts and is running without issue. Apple had previously responded to my bug report with the following.

We tried installing 16A323 and VirtualBox 5.1.6 then upgraded to 16D17a. From there we upgraded to 16D30a and then to 16E144f. We then installed VirtualBox 5.1.14 which was successful.

According to the attached install log this first started failing for the user when they installed VirtualBox 5.1.14 onto a 16E144f system.

We’ve been unable to reproduce the issue as described.
Derm FL
 
Posts: 7
Joined: 27. Feb 2017, 20:33

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby socratis » 14. Mar 2017, 18:06

That's a relief (well, sort of...). If Apple cannot reproduce the issue, I can stop banging my head against the wall (that's the "relief" part ;) ).

They didn't offer any other clues from what I see, so it would be good if we could gather this information over time, and since you have a developer status, you could "forward" it to them...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby Derm FL » 14. Mar 2017, 19:47

I have updated them and will send logs as I see any changes.
Derm FL
 
Posts: 7
Joined: 27. Feb 2017, 20:33

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby socratis » 14. Mar 2017, 23:24

Great! If you do contact Apple, please tell them what my observations have been so far with several versions of 10.12.x and several versions of VirtualBox. Mind you, it's not a widespread phenomenon, so it may be really hard to reproduce conclusively. The symptoms as I said so far are:
  • Automatic updates are enabled.
  • OSX update is issued, update happens without user realizing it in the background, using "softwareupdated".
  • Kext caches seem to either not get invalidated(?), or not getting rebuilt at reboot (?), which seems to prevent the new VirtualBox kext to install/work correctly.
  • Re-applying the standalone updater seems to correct the situation, since "softwareupdated" is not involved.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby Derm FL » 27. Mar 2017, 17:49

It seems now that I am on 5.1.18 the VM fails to start again.

Failed to open a session for the virtual machine Windows 10.

The virtual machine 'Windows 10' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {b2547866-a0a1-4391-8b86-6952d82efaa0}
Derm FL
 
Posts: 7
Joined: 27. Feb 2017, 20:33

Re: Mac OS 10.12.4 Beta all VM fail to start NS_ERROR_FAILURE (0x80004005)

Postby socratis » 27. Mar 2017, 17:53

So far we were trying to get VirtualBox installed. You briefly mentioned the VM startup failure, but after that, the focus was on getting VirtualBox installed, not about the startup error...

Please open a new thread...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to VirtualBox on Mac OS X pre-releases

Who is online

Users browsing this forum: No registered users and 1 guest