VERR_NEM_VM_CREATE_FAILED with Win10 10.0.18362 (#18536)

For discussions related to using VirtualBox on Windows pre-releases (e.g. Windows 10 > build 10240).

VERR_NEM_VM_CREATE_FAILED with Win10 10.0.18362 (#18536)

Postby tarbear123 » 31. Mar 2019, 23:50


ModEdit; related ticket: #18536: error however i try to change my system
Title changed from "trying to run virtralbox" to something more appropriate


when I go to run it, I get this error
Failed to open a session for the virtual machine linux.

Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
Last edited by socratis on 3. Apr 2019, 02:12, edited 2 times in total.
Reason: Added ticket related information.
tarbear123
 
Posts: 7
Joined: 31. Mar 2019, 23:48

Re: trying to run virtralbox

Postby socratis » 1. Apr 2019, 00:17

What's your host? Get the information, all of it, by running "WinVer" in your host. Please read the following: Minimum information needed for assistance.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25284
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: trying to run virtralbox

Postby tarbear123 » 1. Apr 2019, 00:26

[img]C:\Users\taran\Pictures\Screenshots\Screenshot%20(5).png[/img]
tarbear123
 
Posts: 7
Joined: 31. Mar 2019, 23:48

Re: trying to run virtralbox

Postby socratis » 1. Apr 2019, 00:29

Well, obviously the forums don't have a file like this, you need to upload the image...
Image


Plus I don't think that the link that I gave you talks about images. At all! Describe the setup. With text...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25284
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: trying to run virtralbox

Postby tarbear123 » 1. Apr 2019, 00:30

I do and it comes up with a error saying that its too big
tarbear123
 
Posts: 7
Joined: 31. Mar 2019, 23:48

Re: trying to run virtralbox

Postby socratis » 1. Apr 2019, 00:31

Describe it, I do NOT want a picture!
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25284
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: trying to run virtralbox

Postby tarbear123 » 1. Apr 2019, 00:34

I click the start button and it pops up with this error
Failed to open a session for the virtual machine linux.

Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
tarbear123
 
Posts: 7
Joined: 31. Mar 2019, 23:48

Re: trying to run virtralbox

Postby socratis » 1. Apr 2019, 00:36

That is not the information I asked for. What I asked for is:
socratis wrote:What's your host? Get the information, all of it, by running "WinVer" in your host. Please read the following: Minimum information needed for assistance.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25284
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: trying to run virtralbox

Postby tarbear123 » 1. Apr 2019, 00:54

the version is Version 6.0.4 r128413 (Qt5.6.2)
the host is a window OS
Attachments
linux-2019-03-31-16-48-41.log
the log files
(31.5 KiB) Downloaded 349 times
tarbear123
 
Posts: 7
Joined: 31. Mar 2019, 23:48

Re: trying to run virtralbox

Postby socratis » 1. Apr 2019, 00:57

tarbear123 wrote:the host is a window OS
I'm sorry, there is some miscommunication going on here! I gave you very specific instructions, didn't I?
socratis wrote:Get the information, all of it, by running "WinVer" in your host

If we have to exchange 5 messages to get to your host's version, you need to start paying more attention, OK?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25284
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: trying to run virtralbox

Postby tarbear123 » 1. Apr 2019, 01:02

I'm sorry, I don't understand what a host is, the problem is me not understanding, plz have patents with me, hope we can figure it out together
tarbear123
 
Posts: 7
Joined: 31. Mar 2019, 23:48

Re: trying to run virtralbox

Postby socratis » 1. Apr 2019, 01:22

You sound like a new user to VirtualBox. You are expected to know some basic terms before we have a conversation. Start by reading three small chapters from the User Manual:
Or even better, read the whole chapter 1. First steps, then you'll know what "host" is.

If you can't understand English very well, try https://www.deepl.com/translator or https://translate.google.com/

00:00:02.540387 OS Product: Windows 10
00:00:02.540388 OS Release: 10.0.18362
That's your host's version, the information I was asking for. This is a Windows pre-release, released on 2019-03-20 (10 days ago), moving from "Using VirtualBox" to "Windows pre-releases".

00:00:02.843112 HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
00:00:02.931104 NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...
It seems that you have Hyper-V enabled. Look in the "Control Panel" » "Programs and Features" » "Turn Windows features on or off", and make sure that the none of the following are active:
  • Hyper-V
  • Virtual Machine Platform
  • Windows Hypervisor Platform
Disable Hyper-V in your host and see what happens...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25284
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: trying to run virtralbox

Postby mpack » 1. Apr 2019, 10:32

tarbear123 wrote:when I go to run it, I get this error
Failed to open a session for the virtual machine linux.

Call to WHvSetupPartition failed: ERROR_SUCCESS (Last=0xc000000d/87) (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Where did this VM come from? Did it ever work? I believe the error message means that the current host has Hyper-v but it doesn't have the Hypervisor Platform feature to allow third party VMs to run. So either the VM never worked, or it was copied from another host. We'd need the background details.
mpack
Site Moderator
 
Posts: 29715
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: trying to run virtralbox

Postby socratis » 1. Apr 2019, 11:20

mpack wrote: I believe the error message means that the current host has Hyper-v but it doesn't have the Hypervisor Platform feature to allow third party VMs to run

That's exactly why I was asking persistently for the Win10 revision. Because that feature is included in 1809 rev.17763.1 ("September 2018 Update", and later I assume, 1903 isn't out yet). And 1809 is actually required for VirtualBox to run alongside Hyper-V, because of the Hypervisor Platform that you mentioned. Maybe it's simply that a required component not enabled?

It is an Insider build after all, we don't (at least I don't) have access to that, so I can't test it. I think I know someone that does though... ;)
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 25284
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: trying to run virtralbox

Postby Jacob Klein » 1. Apr 2019, 14:43

Oh hai, Socratis! I have received your request in the other thread, and will attempt tests shortly, and will report results here.
Jacob Klein
 
Posts: 485
Joined: 20. Nov 2013, 01:07

Next

Return to VirtualBox on Windows pre-releases

Who is online

Users browsing this forum: No registered users and 2 guests