[SOLVED] Enabling encryption breaks guest os and prevents installation

Postings relating to old VirtualBox pre-releases

[SOLVED] Enabling encryption breaks guest os and prevents installation

Postby JoergK » 25. Aug 2017, 10:43

Hello,

Running some tests with VirtualBox Beta 2 I encountered a problem with the encryption of the virtual disk image. Enabling the disk encryption for a VM with an installed guest os (with guest additions installed) breaks the guest. The filesystem is damaged and in a non recoverable state. I tried this with two VMs running RHEL 7.4 as guest os.

In a second scenario I created a new VM and enabled the disk encryption prior to the guest os installation. Powering up the VM and starting the installer (RHEL 7.4 with anaconda) works fine. When the installation starts and the filesystem is going to be accessed for the first time the VM freezes or the installer crashs with an exception that the filesystem cannot be accessed or mounted. Restarting the installation shows that the filesystem was destroyed. The installer shows the partition created in the last installation attempt without any filesystem.

My test environment is:
  • VirtualBox 5.2.0 Beta2r117563
  • Guest os: RHEL 7.4
  • Disk Type: VDI
  • Encryption: AES-XTS256-PLAIN64

If you need more information to track this down, tell me what information and how to collect them, please.

Best regards,
Joerg
Last edited by JoergK on 13. Oct 2017, 12:01, edited 1 time in total.
JoergK
 
Posts: 26
Joined: 25. Aug 2017, 09:37

Re: Enabling encryption breaks guest os and prevents installation

Postby aeichner » 31. Aug 2017, 11:54

Please post a VBox.log of the affected VM.
aeichner
Oracle Corporation
 
Posts: 154
Joined: 31. Aug 2007, 19:12

Re: Enabling encryption breaks guest os and prevents installation

Postby aeichner » 31. Aug 2017, 15:06

Found an issue which could be responsible for the corruption you are seeing, will be fixed in the next Beta/RC. Thanks for letting us know!
aeichner
Oracle Corporation
 
Posts: 154
Joined: 31. Aug 2007, 19:12

Re: Enabling encryption breaks guest os and prevents installation

Postby JoergK » 1. Sep 2017, 09:08

No problem. I've attached the VBox.log if you like to have a look at it.

I'm waiting for the next Beta/RC and test again.

Cheers,
Joerg
Attachments
VBox.log
Log file of the affected VM.
(122.74 KiB) Downloaded 21 times
JoergK
 
Posts: 26
Joined: 25. Aug 2017, 09:37

Re: Enabling encryption breaks guest os and prevents installation

Postby JoergK » 13. Oct 2017, 12:00

Hi,

Encryption works properly in the RC1. The problem seems to be solved.

Tested with:
Host: Ubuntu 16.04
Guest: RHEL 7.4
JoergK
 
Posts: 26
Joined: 25. Aug 2017, 09:37


Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 1 guest