Mouse too big on Hi-DPI windows guest

Postings relating to old VirtualBox pre-releases

Mouse too big on Hi-DPI windows guest

Postby tym0 » 8. Jul 2015, 16:10

Hi, I'm on Retina MPB 13" and Hi-DPI Windows 10 guest has been pretty much unusable since I switch to the beta.
The reason is that the fake mouse cursor that VirtualBox create on top of the one from the guest is scaled with the "Change the size of text,apps, and other items" settings, so if you set the resolution 2560 x 1600 and then set the "Change the size of text,apps, and other items" at 200% you end up with an interface that looks like 1280 x 800 but with a mouse cursor twice too big.
It feels a bit like playing chess with oven mitt. The solution would be to be able to deactivate that scaling manually or when the Hi-DPI mode is activated. Meanwhile does anyone knows how to deactivate this fake mouse cursor?

tl;dr: The mouse cursor is twice too big in Hi-DPI mode.

Edit: I found a way to disable Mouse Integration (Host+I) but it's hard to be precise without it.

Edit2: Just tried it with an Ubuntu guest and I've got the same problem.
tym0
 
Posts: 3
Joined: 8. Jul 2015, 15:42

Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 1 guest

cron