Page 1 of 2

[FIXED] 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 3. Aug 2012, 18:33
by stefan.becker
3D for Windows 7 guests seems to be broken. Symptoms: Guest Additions can be installed, but Aero is deactivated and does not reappear after chossing an aero theme again.

VBOX version 4.2.0 Beta 1

Linux Host Mint 13 64 Bit (=Ubuntu 12.04)

Win7/Home 32 Bit guest. 2D+3D activated.

Newest guest additions installed

AMD Radeon 6570 VGA card, checked with Catalyst 12.6 and the free driver.

With the last ISO from the WIN 8 thread (4.1.51.79382) the guest additions in another Win7 Guests work OK.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 3. Aug 2012, 18:35
by stefan.becker
The log file:

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 3. Aug 2012, 18:59
by stefan.becker
Same with 64 Bit Windows 7 guests. Working with one version before, not working with the newest guest additions.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 3. Aug 2012, 19:01
by stefan.becker
Tomorrow i will check it on my second machine with Suse 64 Bit and Nvidia.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 3. Aug 2012, 19:04
by misha
Could you do the following:

In your Win7 guest having new Additions installed, enable backdoor logging for VBox 3D components:

To enable it
1. Create a VBoxLogUm DWORD value under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VBoxVideoWddm and set it to 1
2. set CR_DEBUG_BACKDOOR=1 environment variable (for crOpenGL backdoor logging)
3. set WINEDEBUG=+err,+warn,+fixme and WINEDEBUG_BACKDOOR=1 environment variables (for wine backdoor logging)
4. Restart guest

The above will make VBox 3D components to write the logging info to the host VM log.
After a guest reboot, try enabling the Aero again, shut down the VM and post the Log for that VM session here.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 3. Aug 2012, 19:05
by misha
Also please try if disabling the 2D acceleration makes any difference.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 4. Aug 2012, 00:06
by stefan.becker
Sure, here are 2 Logs.

First without Aero new start, then activate aero and restart. 2D disabled.

Second with activated Aero and enabled 2D.

No difference between en/disabling 2D.

I think you mean setting the environment variables on the host like this:

Code: Select all   Expand viewCollapse view
stefan@stefan-desktop ~ $ CR_DEBUG_BACKDOOR=1
stefan@stefan-desktop ~ $ WINEDEBUG=+err,+warn,+fixme
stefan@stefan-desktop ~ $ WINEDEBUG_BACKDOOR=1
stefan@stefan-desktop ~ $ VirtualBox

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 4. Aug 2012, 13:43
by misha
stefan.becker wrote:I think you mean setting the environment variables on the host like this:

No, all modifications (environment and registry) should be done in your Win7 GUEST.
I.e. for Win7 guest: "Start" Button->right-click "Computer" -> Properties -> Advanced System Settings -> in "Advanced" tab press "Environment Variables" button -> add environment variables to "System Variales" list.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 4. Aug 2012, 13:48
by stefan.becker
OK.

Meanwhile i checked it on my other machine (Suse 12.1 / 64 Bit, Nvdia GT 9500, native driver). Same result. Does not work with new version of GA, works with old GA version.

Some minutes later i will posts the log again.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 4. Aug 2012, 13:58
by stefan.becker
So, here again the logs. Same as above. First without 2D, Second with 2D.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 4. Aug 2012, 14:15
by misha
Thanks for the logs! They revealed the misbehave. Investigating what might have caused it..

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 5. Aug 2012, 12:36
by Rui Baptista
Now with "Windows 7 64 bits" host, "NVIDIA GeForce 9600M GT" display:

- aero working with 4.1.8 additions
- not working after 4.2 additions install
- working again after aero troubleshooting, or simply restarting "Desktop Window Manager Session Manager" service
- I have to restart the service after each reboot
- besides that, aero works afaics

hummm, we still can't mention "the operating system that can't be used outside the walled garden"? I have one vm here with "Unexpected trap during early EFI bootstrap!!", in no way I update to 4.2 with this…

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 5. Aug 2012, 14:53
by misha
Thanks stefan.becker and Rui Baptista for the info.
Here is a test build of VBox Guest Additions that should hopefully solve the 3D issues you're seeing.
Please give it a try and let me know how it goes.
Needles to say, these additions should be used under VBox 4.2 Beta 1 host installation.

http://www.virtualbox.org/download/test ... -79783.iso

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 5. Aug 2012, 15:00
by stefan.becker
Rui Baptista wrote:... or simply restarting "Desktop Window Manager Session Manager" service ...


Can confirm this.

Re: 3D broken (Linux 64 Host, Win7 Guest, Radeon)

PostPosted: 5. Aug 2012, 15:27
by Rui Baptista
Nice, misha, your Guest Additions test build do solve the problem.

and please forgive my small talk, it isn't a 4.2 issue